YouTube - PAL vs. NTSC - 24, 25, 30 fps

Hi,

This is a topic for all interested in publishing your film on YouTube. I live in Europe so I use PAL and I have made a video in 24fps (from Nikon D90). When I published it on YouTube, the friend of mine realized is "choppy". For the beginning I thought is because of video quality of Nikon D90, but after spending a lot of time and watching a hundreds of videos on YouTube 5 realized a problem is somewhere else.

I have found that YouTube change original 25fps (PAL from Europe) into 30fps (NTSC) - it repeats every 5th frame, so it means why I find the playback jittery and annoying to watch when you have moving objects (eg. cars).

You can see it in this video:
Comparison Panasonic Lumix ZS3 (NTSC 30fps) vs TZ7 (PAL 25 fps)
http://www.youtube.com/watch?v=bEIRSbahLnw

You can see a man in white shirt in abou 46-47 sec. its freeze for a bit of second. I have uploaded this video into kdenlive and in 46 sec frame 19 is the same like frame 20, 25 is the same like 26.

Its easy to see the problem here (video in PAL 25fps):
http://www.youtube.com/watch?v=budXesxddvc

The cars freeze for second so it doesn't like smooth.

So, because I am interested mainly in publishing on YouTube, I have bought a new body D5100 which support 24,25,30 fps and both PAL and NTSC.

My question is, if is it any difference in rendering profile in Kdenlive for YouTune or H.264 when we choice NTSC or PAL?
Can anyone find a difference in examples bellow?

Here profile for YouTube form Kdenlive for NTSC:
f=mp4 hq=1 acodec=aac ab=128k ar=44100 vcodec=mpeg4 minrate=0 b=2000k s=1280x720 aspect=%dar mbd=2 trellis=1 mv4=1 subq=7 qmin=10 qcomp=0.6 qdiff=4 qmax=51

Here profile for YouTube form Kdenlive for PAL:
f=mp4 hq=1 acodec=aac ab=128k ar=44100 vcodec=mpeg4 minrate=0 b=2000k s=1280x720 aspect=%dar mbd=2 trellis=1 mv4=1 subq=7 qmin=10 qcomp=0.6 qdiff=4 qmax=51

Here profile for H.264 4k form Kdenlive for PAL:
f=mp4 hq=1 acodec=aac ab=128k ar=48000 pix_fmt=yuv420p vcodec=libx264 minrate=0 b=4000k g=250 bf=3 b_strategy=1 subcmp=2 cmp=2 coder=1 flags=+loop flags2=dct8x8 qmax=51 subq=7 qmin=10 qcomp=0.6 qdiff=4 trellis=1 aspect=%dar

Here profile for H.264 4k form Kdenlive for NTSC:
f=mp4 hq=1 acodec=aac ab=128k ar=48000 pix_fmt=yuv420p vcodec=libx264 minrate=0 b=4000k g=250 bf=3 b_strategy=1 subcmp=2 cmp=2 coder=1 flags=+loop flags2=dct8x8 qmax=51 subq=7 qmin=10 qcomp=0.6 qdiff=4 trellis=1 aspect=%dar

Another question - which frame rate profile should I chose for Nikon D5100 - 30fps or 29.97fps?
Nikon says it:
A frame rate of 30 p (actual frame rate 29.97 fps) is available when NTSC is selected for video mode. 25 p is available when PAL is selected for video mode. Actual frame rate when 24 p is selected is 23.976 fps.

And which frmae rate use YouTube 30fps or 29.97fps?

Thx for the answers.

p.s. I know that Vimeo has 25fps for 25fps upload film.

Forums:

Can't really answer your questions, but I upload everything to YouTube in 25fps and never had choppy video. Normally use MPEG4, have tried H.264, but it came out very wrong when the speed effect was used.

Morsey,

It really noticeable in scenes eg. where the camera is panning.

Many people had the same problem:

How to fix jittery video on YouTube?
http://www.google.com/support/forum/p/youtube/thread?tid=78a21e9bdc4114f...

Youtube is changing my 25fps to 29.97, why?
http://www.google.com/support/forum/p/youtube/thread?tid=12b19b1aff99d32...

weird, guess it depends on the format the file is in. The YouTube channel I run for my local Air Cadet Sqn has videos on, all seem fine. Recent ones are made in kdenlive, output at MPEG4 - 18000K 1920x1080 25FPS

www.youtube.com/atc146

The render settings from the dialog or XML file is a subset of the full render settings. Frame rate is decided by the project setting. (And one should not attempt to override it because all the edit timings are based on frame unit values.)

The aforementioned discussion threads are more than two years old. There are no confirmations or proofs in these threads, just some ramblings. Being based in Europe and from my own Channel on YouTube I can't confirm 30fps transcoding. On the contrary, my 25fps videos seem to be fine on YouTube.

in fact youtube told me several times after uploading, that my video is not 30 fps and therefore it is not the optimum.

I also found it choppy, when there are camera moves.
For example: http://youtu.be/h1pu8Br8Ht8

I use a Canon 600d in Full HD (Pal).
Rendering: Video - h264 (2 turns)

Pages