rendering suddenly goes to 100% after first title clip

Hy,
(excuse for my poor and not good english)
i always used kdenlive (great video editor) whitout problem in ubuntu 11.04 but now i installed (from ubuntu software center) and use kdenlive (0.82.1) under Ubuntu 12.04 (64bit and kernel release 3.2.0-24-generic) and i encounter always this problem: if i start rendering (any format) it suddenly goes 100% as soon as meet the first title clip!
if in timeline there aren't any title clips the rendering work fine.

how is it possible to solve this poblem?

thanks
corrado

Forums:

Yes! The same for me. I use ubuntu 12.04 (64 bit) and kdenlive 0.9 from ppa:sunab/kdenlive-release. I realy need help!

I'm seeing the exact same problem on Ubuntu 12.04 and kdenlive 0.8.2.1.

Removing all titles means the whole video is rendered. If any titles are left in, rendering stops when it reaches the first one.

Any solution would be much appreciated :o)

Cheers,

Alex

i am looking at this issue. Seems to be a packaging problem in mlt. Rendering as root seems to work..

Thank you! It's true, rendering as root works well. Hmm... Any ideas to fix this?

I tracked down the problem to sunab's frei0r package. I contacted him and hope we can solve the problem soon.

Thank you so much! Waiting...

I also have this problem, except it just goes 100% as soon as I click Render to File. How do you render as root?

Edit : Actually mine probably isn't any different, I just remember my title clip is at the exact start of the video, so thats probably why mine looks like its as soon as I click "Render to File". Still need to know how to render as root :P

Just login as root and start Kdenlive. If already logged in, use the "su" command to become root.

Any files written will be probably owned by root, so to avoid problems with accessing them from your normal user account, do

chown your_user_name file_written_by_kdenlive

while still root.

Some new distributions do not have a root account, so
"sudo kdenlive" from your user account will probably work too.

I don't think I can login as root on ubuntu 12.04, so I do "sudo kdenlive" and is now working properly, thanks for your fast reply, you saved me :P
BTW is kdenlive supposed to look like it has a windows theme when ran as root?

Hi guy,
I tried to start Kdenlive as sudo (type "sudo kdenlive", in a terminal window) and it is works fine. In this case, no problem with render if title clips are in the timeline.

I found, in the Bug Tracker (http://www.kdenlive.org/mantis) another way that works very well, and i quote it (ID 0002592):

j-b-m wrote
---------------------------------------------------
Ok, I found the problem. It is related to 2 frei0r effects using OpenCV. I have not yet found a fix, but as a workaround, you can delete (or move to a backup location) the files:

/usr/lib/frei0r-1/facebl0r.so
/usr/lib/frei0r-1/facedetect.so

After that, rendering should work fine. Still working on a real fix.
------------------------------------------------------

@beermats
Nice find, I'm going to try this as soon as I get home from work and see how it goes.

Marko and the rest above, THANK YOU SO MUCH for this help, as this solved my issue. I have a deadline on this video i have been making, and I FINALLY decided to try to render it, and came across the title clip problem. It took a while to figure out it was the title clip, then took me a bit to track down the info to here. Eitherway, you guys saved my @$$.

Thanks!
now back to working on this damn video.

alex

Thanks . I have been battling with this for hours . At last my deadline is in with a chance thanks guys !

:)

Thanks so much Marko and everyone who recommended me do sudo kdenlive... that works perfect!!!!

Hello there, I'm Antony from Greece, not a linux master but for 15 years i edit films for a living.
I've been reading, tried many of what i've read, nothing happened for me.
Had issues with title rendering (the main issue), it was crashing to 100%.

I also tried sudo kdenlive, nothing here for me.

Here's what worked:

(i was using footage from dv camera, jpegs, footage from cell phone camera and some footage from a hd handycam).
changed my DV-PAL project (the goal was a dvd-video), to HDV (1080 25p for me). I edited "project settings". If you're not sure, save your project to another name before you try anything.
What i got was the same timeline with some issues at every shot had a "pan n zoom" effect. I removed the and made new ones. Same with titles, they were at the wrong place and smaller, I deleted the "composite" of each title, then made a new one.
When everything seemed ok in the timeline, i rendered everything and there wasn't any problem at all.

What i have now is a 1920x1080 master clip, and i can use any program i want for convert, transcode, or dvd authoring.

I hope this helps, take care,
Antony

----------------------------------
Linux Mint 13 Maya Cinnamon
latest kdenlive install from software center

Trying to render as root does not helpfor me.
I'm running 4.8.5 on Xubuntu 12.04
I'm really fed up of constant bugs in kdenlvie

Chris

Ubuntu 12.10, latest KDEnlive from Ubuntu software.

I had this problem. Solve by "sudo su" and then "kdenlive".

T H A N K S !!!

Thanks for the 'run as root' fix.

Can we pay someone to fix this properly?

Rather than running as root to fix it you could try the delete the

/usr/lib/frei0r-1/facebl0r.so
/usr/lib/frei0r-1/facedetect.so

files fix described at
http://www.kdenlive.org/mantis/view.php?id=2592

As to paying someone to fix it maybe it already has been- have you tried installing the latest development version 0.9.3 ?

I run that version and do not have this issue.

the issue is still here for me today on the latest Ubuntu and latest version of KDEnlive.
as I am a newbee, the only thing that works for me is "sudo kdenlive"

I tried deleting the files as mentionned
but there's now only one : /usr/lib/frei0r-1/facedetect.so
AND ... I can't if I am not "root"
but as I am a newbee I have no idea what the password is for "root" on my new Ubuntu system!

You should be able to do it as super user do. sudo nautilus, browse to /usr/lib/frei0r-1/ and delete facedetect.so

But when you say 'latest version of Kdenlive' do you mean latest distro version?, if you're using Ubuntu you could add sunabs 'stable' or 'git' PPA and have 0.9.6 which is the latest version and not have the screwed up permissions problems.

Pages