Kdenlive not installing - dependency issues

Help! I am trying to upgrade from Kdenlive 0.7.7.1 to 0.9.2. I am using Ubuntu 10.04 Lucid.
I have upgraded the repository so that Synaptic can find the 0.9.2 version, but it wont install it because of a dependency problem.
It says "The following packages have unresolvable dependencies. Make sure that all the required repositories are added and enable in the preferences." ...and...
"kdenlive:
Depends: kdebase-runtime (>=4:4.4.5) but 4:4.4.2-0ubuntu4 is to be installed
Depends: kdelibs5 (>=4:4.4.5) but 4:4.4.2-0ubuntu4 is to be installed"

The problem seems to be that Kdenlive needs an updated version (4:4.4.5) of these 2 packages (kdebase-runtime & kdelibs5) and my computer is using the old one (4:4.4.2).

I cannot find the repository for these files, and it wont let me put them in manually (something about them being part of a KDE4 package?).

Does anyone have any suggestions?

[SOLVED]
Hi, me again. I've solved this issue and thought I would write it up in case someone else had the same problem.
Basically what you have to do is install "Important Security Updates" in the Update Manager of Ubuntu. Kdenlive (KDE Non LInear Video Editor) uses KDE libraries to operate and these need to be up to date for the up to date version. The problem is that the 2 files listed above do not belong to your standard ppa repository, they are in a secured area for system updates.

1. Open System > Admin > Update Manager
2. Click on 'Settings'
3. Check box 'Important Security Updates' and then 'Close'
4. Click 'Check' to update listings of updates
5. Right mouse and click 'Uncheck all' in the updates list
6. Find one of the files you are looking for (e.g. kdebase-runtime) and check box. This should automatically select the other associated files because they are part of a package.
7. Install checked updates (mine selected 31 packages)
8. Close, and then install Kdenlive in Synaptic.

Hope this helps someone.

Pages