problem synchronizing sound and video

Hello everyone,

I'm really pleased to enter the kdenlive-forum world.
I have a problem with Kdenlive, and I would like to know if it is solveable.
I am trying to synchronise a video I've made, with a sound made separately (from a handy recorder). But I can never really be precise because the timeline has some sort of "steps" when I try to move sound, and it's making it impossible to be precise in the synchronization. Am I a real noob, or is it a limitation in Kdenlive?
I've got the 0.8.2.1 version under Lubuntu 12.04 32bits.

Thanks

If you were to try a later version there is a audio syncronize feature to do what you need, how successful it is I am unsure.

You're on Ubuntu so you could use sunabs PPA's or use the build script to get latest version.

sunabs 'stable' PPA should have the feature:

https://launchpad.net/~sunab/+archive/kdenlive-release

And also latest git build:

https://launchpad.net/~sunab/+archive/kdenlive-svn

Build script allows you to keep your lUbuntu repos as is and build a git kdenlive to a dated folder within your home directory, gives ability to have both your distro's version of kdenlive and a cutting edge git version available.

http://www.mltframework.org/bin/view/MLT/BuildScripts

Also nightly builds of numerous MLT based apps, kdenlive, Shotcut, Openshot here:

http://builds.meltytech.com/

In maximum zoom, you can move the sound in frame-wide steps. If one frame (0,04 seconds for a 25 fps profile) is too much, you could try to trim your sound (cut or add silence) using audacity or a similar tool.

Crazgun may be having the same issue I'm having with Kdenlive audio which is that the sound doesn't seem to stay put. I had some problems with audio slipping and found that it seemed to jump around slipping in and out of sync, even when grouped with its video clip.

I also found that the waveforms don't bear much relationship to the actual position of the sound.

Does you still have problems after export ? or 'just' in the timeline ?
What is the sampling rate 44.1khz , 48khz... ?

Try to give a max of infos to help to resolve.

And i agree with "av25fps" tips of max zoom to correctly place clips !

see:;ya

I think crazygun is more specific in asking about syncing sound between a reference audio track recorded on camera syncing to higher quality audio recorded to an external device like a Zoom 4n, a kdenlive dev added a feature that allowd one to set an audio track as reference and sync another higher quality version to it, ala Pluraleyes.

http://www.singularsoftware.com/pluraleyes.html

Its a very common requirement.

re waveform rendition, a git commit yesterday/today may help, 'waveform generation more like Audacity'. :-)

@djay 48hz and it's happening in the timeline. Whatever I get in the timeline seems to export fairly faithfully, it's just I can't really get what's in the timeline to stay put. Just adding a few frames to the end of a soundclip or a transition will cause the sound to shift a few frames.

@Yellow Good news on the update there. Will see if it improves things.

Pages