When I change video profile the project gets corrupted

Hi,

I recently built a ~40 minute-long project with many photo/video/audio clips and text overlays and chose a 720p @30fps profile. It renders fine in that video profile (though strangely, for some reason finishes and always says it crashes at the end.. but the resulting output file plays fine all the way through..?) but I have need to change this profile to a lower FPS to try to allow it to play satisfactorily on some older equipment.

When I change the profile from 720p 30fps to eg 720p 25fps (I've tried several other profiles) half the time it locks up and doesn't come back (have to kill it). The other half the time it completes and the project timeline looks OK but I get errors if I try to edit something (unable to move clip, etc etc). If if I save it, quit and go back into the project I get a warning while loading about overlapping transitions and everything in the project is offset and messed up. So, that project file is now junk and I have to go back and try again.

I'm not claiming to be any kind of expert here, so maybe I'm doing something wrong. Is it proper to want to change the video profile inside the project and expect it will not corrupt the project timeline?

Thanks...

Forums:

kdenlive version?
mlt version?
platform, os versions?
package sources?

Sorry for not including that detail.

Fedora 17 - all versions of apps/libs that come with the distro, latest yum update.

kdenlive-0.9.2-1.fc17.x86_64
mlt-0.7.8-1.fc17.x86_64

AMD64, 4-core machine, 16G RAM.

If you're importing video, then won't that determine framerate? If older / lower powered hardware is having problems with playback then wouldn't bitrate and resolution be better to adjust first before framerate, in fact not change framerate at all.

Personally frame rate choice is about asthetic not whether or not a piece of hardware can play it back in realtime. Once framerate is chosen for a project it shouldn't really be changed in its entirety later.

So, that's a good question and I'll show my ignorance. There are video sources in this project from four or more different devices recorded at three different resolutions and I believe framerates. There are clips from two GoPros, a couple mobile phone videos from iPhones, and a few videos from at least one point-and-shoot camera. The project seems to take this all and produce a working video that plays without hiccups on 'modern' hardware at least. I didn't think about it too much - and maybe falsely assumed it was converting the framerate to match that designated in the project. Is that not the case? It does adjust all the resolutions nicely (though some are 16:9, others 4:3 letterboxed...) and automatically to fit that designated in the project's video profile.

The resulting video plays fine on a relatively modern Linux or Windows PC or Mac. I am able to play other 720p H.264 videos on the devices I'm having problems with (three media stations) and I've already dialed-down video and audio bitrates from h.264 default to what I see in the properties from other working videos, but it still stutters pretty awfully, so I thought to adjust down the framerate next (I figured I probably don't need 30fps).

I'm not a professional video producer, as you can probably guess - I just heard good things about Kdenlive and I'm a Linux guy, so I jumped in and made some videos without having used too many other tools (eg some simple Avidemux transcoding). I have to say the tool works pretty darn good despite a few issues here and there. I've also located a few bugs which I can work around but I should probably report since they are reproducible.. and maybe that includes this inability to change the video profile of an existing project w/o corrupting the timeline? I have 250+ objects in the project.

You're right in your assumptiin that framerates are automatically adjusted, done by MLT and it appears you're getting successful playback via computer hardware so that's ok.

If other h264 files at same resolution and bitrate play successfully on the media players but kdenlives don't then perhaps look a little deeper into the h264 encodings that do play and try to match them with a custom h264 render profile in kdenlive, it might be quicker to test by rendering out a short section to something like ffv1 and then using a tool like Handbrake with its encoder presets for various devices to do the final encode.

Kdenlive also has render profiles for media players and mobile devices in the drop down menu under render settings, have you tried any of those?

Also is your audio output the same codec in both cases?

...but kdenlive should't lock up nevertheless. Maybe filing a bug could help making the devs aware of the issues, but don't expect this to get fixed soon, depending on interest and complexity of the bug.

I'll fill a bug report. I can reproduce this behavior 100% of the time. The worst part about it is the corruption of the timeline - everything gets offset by a second or less.... every transition is misaligned when trying to change framerate.

Pages