Kdenlive crash causes corruption of project file

Have been using kdenlive for a week now and for the most part have found it a great video editor. But on a couple of occassions have had it crash, then when i try to load the project again, it complains about invalid characters.

this happens whenever you are working on a project and it crashes now.

It thought my project was lost untill i noticed that the project file is an xml document so opened it up in a text editor to see if there were any errors within the file/.

Sure enough there were some red highlighted parts.

Basically the crash seems to put a few extra / symbals in specific places, and also puts / in place of . again in specific places.

Here is where the first courruption of the file is

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0//EN" "http://www.w3.org/TR/REC-html40/strict.dtd">
<html><head><meta name="qrichtext" content="1" /><style type="text/css">
p, li { white-space: pre-wrap; }
</style></head><body style=" font-family:'Sans Serif'; font-size:8pt; font-weight:600; font-style:normal;">
<p style="-qt-paragraph-type:empty; margin-top:0px; margin-bottom:0px; margin-left:0px; margin-right:0px; -qt-block-indent:0; text-indent:0px;"><br /></p></body></html>

In the 2nd line there has been a / after content="1"

It also happens again in the last line here

Simply removing these / fixes these errors.

further down into the file there is a slightly different error

meta.attr.WM/Provider.markup="AMG" has a / instead of a . so changing this for the . fixes that

Once i have fixed these errors the project opens again without problems, until kdenlive decides to have another crash and the exact same errors happen, in the exact same places. which can be fixed.

these have also cropped up in backups aswell, the only working backup i got working after a crash was half way through doing my project which was way too much work lost.

running the latest version of KDENLIVE from the PPA

Ubuntu Studio 12.10 64 bit with latest updates running XFCE desktop
AMD athlon 64 dual core processor
3gb ram
Onboard Nvideo graphics (with restricted drivers installed)

Forums:

This problem was fixed in git, you can get the current git version on sunab's experimental PPA:
https://launchpad.net/~sunab/+archive/kdenlive-svn

I will make a new Kdenlive release in the next days so that the fix is available to everyone.

Thanks will test it out now, just added the ppa, though after updating my sources, nothing came up to update i had to searxch manually to find the components to update.

Did you find the components to update. If not try closing Synaptic or Software Center then reopening and update.

I got kdenlive updated, along with some associated librariers, and also melt.

the crash corrupting the file is now fixed.

However, kdenlive is now so unstable it cant be used.

playback became very jittery, and nothing responded while it was playing back, i managed to solve this by changing the driver from automatic, to xvideo.

but its still very unstable, i tried to create a few title clips, and on the third, the background once inserted into a video track was black instead of transparrent, then when trying to edit the title clip, kdenlive locks up. Every time i try to edit the title clip, locks up

odd, seems fine now everything is working ok it seems

Just an update as this is now solved.

project file corruption is now fixed, and kdenlive is running pretty solid without crashes

Pages