Kdenlive playback problems. Stuttering and unresponsive gui[Solved]

So recently i upgraded to 0.9.5 to solve the problems that kdenlive has with crashes and corrupting the project file.

Now it has made kdenlive become unstable while playing back the project, the playback gets jerkier than it was in previous versions. The main problem is that sometimes the gui can become unresponsive. If you hit pause, it can sometimes take a while to actually stop playback.

Also the playback marker does not move smoothly anymore, it jumps in large amounts instead of mooving normally, and this is a majour problem when you are wanting to line clips in time with the beat changes in music. this was easily done in previous versions as when you hit stop rarely did it take any noticable time to actually stop. this makes trying to line clips up impossible.

i just started a new prokect which only had an mp3 track, and a couple of pictures, this should have bene an easy task for kdenlive, but again stopping playback is troublesome and lining simple pictures up to the beat changes in the music impossible.

I also noticed that kdenlive is using 1.5gb memory without any actually video clips loaded. just a 3 minute song and 5 pictures.

I read somewhere else here that another user had a similar problem and was suggested to build from git using scripts.

but the kdenlive script returns

./build-kdenlive.sh: line 4: syntax error near unexpected token `newline'

so ive went from kdenlive that would frequently corrupt the project file to one that is almost unusuable.

hellow again, are you getting your 0.9.5 upgrade via sunabs unstable PPA?

When did you download the build script, as it works fine for me. Did you chmod on the downloaded script as explained here: http://www.mltframework.org/bin/view/MLT/BuildScripts under 'Run The Scripts'

Have you tried a daily build from here: http://builds.meltytech.com/kdenlive/latest.rss

yup tried that script and another one from the git site.

I ended up removing the ppa for 0.9.5 and went back to 0.9.2 which at first seemed better, but then was so unstable.

I then tried updating my video card drivers to use the most recent nvidia driver. my glx gears perfrmance went up.

But then playback in kdenlive is worse. Then i decided for some reason to turn of frame dropping. Not only does playback now not stutter i can play and pause with little delay. Not only that, transitions play back way smoother than it did when set to drop frames, and the playback bar moves pretty smoothly.

Im going to try going back to 0.9.5 as 0.9.2 crashes far too often.

then i will try a daily build.

this is going to get interesting once i switch to an ati radeon card i have (waiting on dvi-vga adapters) to get dual monitors running.

hmmm i tried a daily build today for ubuntu 12.10 64 bit and while it played back properly, it crashed when i tried to remove an effect, with segmentation fault.

Im starting to wonder if its ubuntu 12.10 thats unstable of my computer rather than kdenlive.

Need to get a copy of 12.04 for further testing.

For some unknown reason 0.9.4 has became so unstable, playback within kdenlive actually resulted in me having to reset my pc as it used up all memory and 100% cpu to the point nothing was responsive.

Downloaded the daily build, which seems to work fine so far

http://builds.meltytech.com/kdenlive/kdenlive-ubuntu12.04-x86_64-2013031...

This build seems to work perfect for me, not one crash or problem. Solved :D

Pages