Kdenlive 0.7.4 Launchpad debs for jaunty and intrepid

A/ sudo gedit /etc/apt/sources.list

Jaunty

##Kdenlive 0.7.4
deb http://ppa.launchpad.net/dominik-stadler/ppa/ubuntu jaunty main
##deb-src http://ppa.launchpad.net/dominik-stadler/ppa/ubuntu jaunty main

intrepid

##Kdenlive 0.7.4
deb http://ppa.launchpad.net/dominik-stadler/ppa/ubuntu intrepid main
##deb-src http://ppa.launchpad.net/dominik-stadler/ppa/ubuntu intrepid main

B/ sudo apt-get update

C/

sudo apt-get install melt

sudo apt-get install kdenlive

and don't forget to do an update for libmlt1, without this, when saving the project, it crash.

I cant get this repo to work. Very odd. The pool files are there, but synaptic doesnt see the Intrepid source.

Any ideas? I running 8.10.

There isnt even a package for

sudo apt-get install melt

either. Its like synaptic hasnt registered your repo. I have used the authentication too.

This package is the best Kdenlive on Ubuntu Jaunty 64 I've ever seen. I removed 0.7.3 and MLT and libmlt1, and added your PPA. Then installed kdenlive, melt, libmlt1.

Startup correctly detected an upgrade; all components and codecs accounted for in the initial wizard; Kdenlive started quickly; none of the previous problems from the presence of frei0r package. Loaded a project started in 0.7.3 with no problems.

Will be putting this through it's paces, but so far I can see one big improvement in addition to a perfect install: AVCHD seeking is definitely improved. I'm using 1080p30 .MTS footage direct out of a Canon HF100. Previously it worked alright but you couldn't seek to midway into a clip and play back, you'd just get a grey screen. Now it's still dropping b-frames so a bit jerky still, but you can definitely seek and play. Very nice.

This package is just what I've been waiting for. The Lure PPA build did not work for me. Was gonna relent and give it a go with the Build Wizard today, but now I don't have to. Big thanks again to buntuking - dominik-stadler PPA!

Forgive stating the obvious, but are you sure you did you do a 'reload' in synaptic, or sudo apt-get update?

@joolsr

see it by yourself:

https://launchpad.net/~dominik-stadler/+archive/ppa

"Display sources.list entries for": ---> intrepid

this repo is good !

If I try and download the deb packages individually, i get a dependency error where libmlt1 requires libavcode52|libavcode-unstripped-52 . Which i dont appear to have in a normal Ubuntu Intrepid install. Perhaps this is why Synaptic doesnt like this repo .. ?

For me, the libavcodec-unstripped-52 package is definitely necessary and is in the us.archive.ubuntu.com/multiverse repo. Make sure you have multiverse repo checked.

@joolsr

Howto multiverse repo

Synaptic: System > Administration > Synaptic >> Settings >> Repositories.

https://help.ubuntu.com/community/Repositories/Ubuntu

install kdenlive :

A/sudo apt-get remove --purge kdenlive kdenlive-data libmlt++2 libmlt-data libmlt1 melt

B/for intrepid :

sudo gedit /etc/apt/sources.list

##Kdenlive 0.7.4
deb http://ppa.launchpad.net/dominik-stadler/ppa/ubuntu intrepid main
##deb-src http://ppa.launchpad.net/dominik-stadler/ppa/ubuntu intrepid main

C/ must not forget----> sudo apt-get update

D/ sudo apt-get install kdenlive kdenlive-data libmlt++2 libmlt-data libmlt1 melt

Just did a 2-pass render to h.264 with success. Previously 2 pass would crash, and result of 1-pass was not always playable. Excellent.

Thanks for your help.

I'm a Linux user since 1999, and an Ubuntu user since Warty, and I've never seen this problem.

Your repo does work fine for me on Jaunty on another pc though ;-)

I think I'll just have to upgrade my Intrepid one ..

#Julian

Jaunty is a worthy upgrade - if only to get a usable Kdenlive. I've also been on Ubuntu for about the same length of time, and past experience makes me wary of upgrading a machine more than once, and I had already upgraded to Intrepid. So it was a fresh install for Jaunty. Very worth it.

The dominik stadler repo works fine on Jaunty, (I just upgraded !), but I did have problems with Intrepid that I couldnt resolve

I installed this and it worked fine, except for rendering that just crashed. Then I removed my old self-compiled MLT and it's only asking for a path for the profiles. The default is /usr/local/share/mlt/profiles/. If I change it to the correct one (same without the 'local' directory) it creates this:

Application: Kdenlive (kdenlive), signal SIGSEGV

Thread 1 (Thread 0xb5cca920 (LWP 13048)):
[KCrash Handler]
#6 mlt_properties_fetch (this=0x0, name=0x826476e "resize") at mlt_properties.c:348
#7 0xb807494f in mlt_properties_set_int (this=0x0, name=0x826476e "resize", value=1) at mlt_properties.c:738
#8 0xb80589d0 in Mlt::Properties::set () from /usr/lib/libmlt++.so.2
#9 0x080b7a7a in _start ()

kdenlive 0.7.4 looks good on jaunty. Thanks to buntuking and the packagers.

However, it looks like mlt is not linked against frei0r. I guess the packaging is derived from Debian's, and the issue is the same http://www.kdenlive.org/forum/kdenlive-debian-sid-and-squeeze-call-testi...

That would be nice also if the deb package kdenlive could depend on the package melt.

(deleted - misunderstood.)

@Hohoo

"Application: Kdenlive (kdenlive), signal SIGSEGV"

Thread 1 (Thread 0xb5cca920 (LWP 13048)):
[KCrash Handler]
#6 mlt_properties_fetch (this=0x0, name=0x826476e "resize") at mlt_properties.c:348
#7 0xb807494f in mlt_properties_set_int (this=0x0, name=0x826476e "resize", value=1) at mlt_properties.c:738
#8 0xb80589d0 in Mlt::Properties::set () from /usr/lib/libmlt++.so.2
#9 0x080b7a7a in _start ()

https://bugs.launchpad.net/ubuntu/+source/kdenlive/+bug/363265

solving this bug after unistalling frei0r-plugins on Kubunty Jaunty i686!

Why won't my Synaptic accept the PGP key provided at http://keyserver.ubuntu.com:11371/pks/lookup?op=get&search=0x2380DF3029E... (via http://kdenlive.org/forum/kdenlive-074-launchpad-debs-jaunty-and-intrepid)?? I've copied the part between the two clip marks into a text file, I import that text file from Synaptic's authentication tab, but all I get is a spinning busy-cursor forever. I'm running Jaunty on an AMD64; I already am running kdenlive 0.73 but would like to try out the update. Am I doing something stupid here? I'm doing the same as I've already done with a few other non-Ubuntu packages, as far as the authentication key goes. Help. I've attached the key file I'm using.

Uh, never mind. I was indeed doing something stupid. I had failed to include the "-----BEGIN PGP PUBLIC KEY BLOCK-----
" and corresponding end tag in the key file. Sorry....

PGP key should be part of packages like this is the case in Debian.

Could you confirm this MLT/Frei0r bug:
http://www.kdenlive.org/mantis/view.php?id=917

If you manage bugs on Ubuntu servers and do not escalate them on Kdenlive, there are less chances that we fix the bugs. I had this bug on Debian before I found the report on Ubuntu launchpad.

UBUNTU SCRIPT TO AUTOMATICALLY INSTALL LAUNCHPAD PPA KEYS FOR ALL YOUR REPOSITORIES

A/Create a new file " launchpad-update "

B/Copy and paste this code :
________________________________________________________________

#!/bin/bash
sudo apt-get install curl
for i in `cat /etc/apt/sources.list | grep "deb http" | grep ppa.launchpad | grep "$(lsb_release -cs)" | cut -d/ -f4`; do
curl `curl https://launchpad.net/~$i/+archive/ppa | grep "http://keyserver.ubuntu.com:11371/pks/" | cut -d'"' -f2 ` | grep "pub " | cut -d'"' -f2 >> keyss
done
for j in `cat keyss` ; do
curl "http://keyserver.ubuntu.com:11371$j" | grep -B 99999 END |grep -A 9999 BEGIN > keyss2
sudo apt-key add keyss2
rm keyss2
done
rm keyss

__________________________________________________________________

D/ Open a Terminal

E/ chmod +x launchpad-update

F/ ./launchpad-update

D/wait until script has finished ,then make: sudo apt-get update

https://launchpad.net/~dominik-stadler/+archive/ppa

I really cannot see any deb for Intrepid. Kdenlive 0.7.4 only for Jaunty?

Confirming this works like a charm on Jaunty. Moreover 0.7.4 seems to be a very nice release, probably the first I can use in production as the crashes I experienced seems to have been fixed. Thanks everyone!

Hello. I confess I messed a little with my system (Ubuntu 9.04) while trying to compile and install version 0.7.4. Currently, version 0.7.3 from the Ubuntu repositories is not able to run on my box (something to do with missing SDL or something like that), although it used to before I became so bold.

Later, I tried to install 0.7.4 from the repository indicated in this thread. Synaptic reported the following errors:

E: /var/cache/apt/archives/kdenlive-data_0.7.4-0ubuntu3~ppa1_all.deb: trying to overwrite `/usr/share/kde4/config.kcfg/kdenlivesettings.kcfg', which is also in package build
E: /var/cache/apt/archives/kdenlive_0.7.4-0ubuntu3~ppa1_i386.deb: trying to overwrite `/usr/share/applications/kde4/kdenlive.desktop', which is also in package build

Any help?

Thank you

Jaunty - its ok but only dv codec works.
Other codecs are gone.

What should I do?

Piotr, I had the same problem. Try removing the kdenlive directory in .kde/share/apps and the kdenliverc in .kde/share/config. That helped here.

If not, you could try to purge all packages that have to do with kdenlive and mlt and then reinstall.

pseudoruprecht
It did not help at all.

kdenlive 0.7.4 krashed if i try open project from 0.7.3

[...
kdenlive(6699) TrackView::parseDocument: /////////// TOTAL PROJECT DURATION: 3711
[Thread 0x7f78fe24e950 (LWP 6710) exited]
[Thread 0x7f78fda4d950 (LWP 6711) exited]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7f791d754750 (LWP 6699)]
0x00007f791d357b90 in ?? () from /usr/lib/libmlt.so.1
]

@Piotr: Did the additional codecs work before you added the repo for 0.7.4?

If yes, try
sudo apt-get purge kdenlive melt
Followed by
sudo apt-get --purge autoremove (

Then reinstall kdenlive and melt.

Before you run the reinstalled kdenlive, you might have to remove the configuration files for kdenlive in your /home (see above), but it might work without that step.

______________________________________________

A/ sudo gedit /etc/apt/sources.list

Jaunty

##Kdenlive 0.7.4
deb http://ppa.launchpad.net/dominik-stadler/ppa/ubuntu jaunty main
##deb-src http://ppa.launchpad.net/dominik-stadler/ppa/ubuntu jaunty main

intrepid

##Kdenlive 0.7.4
deb http://ppa.launchpad.net/dominik-stadler/ppa/ubuntu intrepid main
##deb-src http://ppa.launchpad.net/dominik-stadler/ppa/ubuntu intrepid main

B/ sudo apt-get update

C/

sudo apt-get install melt

sudo apt-get install kdenlive

_______________________________________________________

Important remark about kdenlive 0.7.4 , intrepid or Jaunty

At start, if Kdenlive says mlt's sdl module is not present

A/sudo apt-get remove --purge kdenlive kdenlive-data libmlt++2 libmlt++1 libmlt-data libmlt1 melt libcvaux1 libgavl1 libcv1 libhighgui1

B/ gksu nautilus

C/Go to /usr/lib

D/Use the search button in the nautilus toolbar , search " libmlt "

E/select all this files " libmlt.* " , then delete all this files

F/ sudo apt-get install kdenlive kdenlive-data libmlt++2 libmlt-data libmlt1 melt

Dear Buntuking,

You now have an editor role.
Can you maintain the Ubuntu page with sufficient information.
We have several bugs due to Ubuntu users running Kdenlive 0.7.3 and not 0.7.4.
So it would be nice to switch to unofficial repositories, provided that you mantain and release packages on time.

Kind regards,
JMP

I installed Kdenlive from the "Dominik Stadler"-repositories, but somehow there are still problems.

Whenever I start Kdenlive, I get the issue, that the "melt program required for rendering" can't be found...

@Puzzlenoise: Read the instructions ;)

sudo apt-get install melt && sudo apt-get install kdenlive

And don't feel ashamed, I did it wrong the first time, too. I realized that it was in the instructions only while I was typing a reply to this very thread, which was meant to express my surprise why melt wasn't it the packages dependencies or mentioned anywhere. Well...

Puzzlenoise, did you already do what buntuking told two post above your message? That worked for me.

I guess Theora rendering bug is not yet fixed in this release? At least all I got out from my Theora experiments was coffee break with hd's singing on the background.
http://mltframework.org/gitweb/mlt.git?p=mltframework.org/mlt.git;a=comm...

@pseudoruprecht

Yes all codecs worked in 7,3 in Intrepid.

I uninstalled Kdenlive in Intrepid
- upgraded to Jaunty
- installed Kdenlive from this repository

Im not experienced enough Linux user to do what you recommended not so I will wait for 7,5 of get some help from rel life friends.

regs.
Piotr

Ps.
if nit the bugs Kdenlive is the best I started to use it to teach my mother video editing :)

@Piotr:

Do not despair. My warnings regarding autoremove were for the case that you spent hours and hours hacking the configuration files of some server or the like. And it isn't even necessary, it's only the quick 'n' dirty way of what buntuking wrote in his updated install instructions on 2009-06-20 (see above).

Try his steps first, you can still give in after that. Or you could ask for further help here ;)

Kdenlive deserves to be liked. Everyone I pointed to it went "wow". And when VDPAU accelerated decoding comes along, this will change to "wow, wow, wow!", I'm sure.

Kdenlive new packages !

kdenlive - 0.7.4+svn3592-1ubuntu2~ppa1 for Intrepid and Jaunty

https://launchpad.net/~dominik-stadler/+archive/ppa

-------------------------------sources.list----------------------

##Kdenlive 0.7.4
deb http://ppa.launchpad.net/dominik-stadler/ppa/ubuntu jaunty main
##deb-src http://ppa.launchpad.net/dominik-stadler/ppa/ubuntu jaunty main

intrepid

##Kdenlive 0.7.4
deb http://ppa.launchpad.net/dominik-stadler/ppa/ubuntu intrepid main
##deb-src http://ppa.launchpad.net/dominik-stadler/ppa/ubuntu intrepid main

hi,

more bleeding edge packages on my ppa : deb http://ppa.launchpad.net/sunab/ppa/ubuntu jaunty main

- Kdenlive 0.7.4 svn in revision 3711
- MLT 0.4.3 git

In the MLT package frei0r-plugins are enabled by default.
With the Kdenlive package the unstripped versions of ffmpeg libs are installed in one shot.(providing the widest range of codecs)

edit : MLT 0.4.4 released, package updated on my ppa

Upgraded to 0.7.4 --Everything went smoothly. Later, updates were made available via "Update Manager." After installing additional upgrades Kdenlive does not launch any longer.

Resulting error:

--------

kdenlive(5235) MainWindow::parseProfiles: RESULTING MLT PATH: "/usr/share/mlt/profiles/"
KCrash: Application 'kdenlive' crashing...
sock_file=/home/~/.kde/socket-gerri/kdeinit4__0

--------

I've deleted the "kdeninit4__0" as a trial/error and re-installed. No changes.

I'm not clear on what the other posts are offering on sollutions, or if they're even related. I tried removing kdenlive and melt. Autoremoved afterwards and just now attempted a fresh install w/ the sunab's repos.

Error persists.

I'm using Kubuntu 9.04

Thank you

i have the same problem .. updates via synaptic results in a 'crash

kdenlive(4257) MainWindow::parseProfiles: RESULTING MLT PATH: "/usr/share/mlt/profiles/"
KCrash: Application 'kdenlive' crashing...
sock_file=/home/hasp/.kde/socket-automatix/kdeinit4__0

i tried to install the debug infos to get more details

The first sentence is german (i'm running a german kubuntu), which says (more or less) "A correct backtracing is not possible. May be your system-data is not generated for backtracingm or the stack frame for the application was damaged while the application crashed"

Eine korrekte Rückverfolgung ist nicht möglich.
Wahrscheinlich sind die Dateien Ihres Systems in einer Weise erstellt worden, die eine solche Rückverfolgung (Backtrace) nicht erlaubt. Oder der so genannte „Stack Frame“ für das Programm wurde durch den Absturz unbrauchbar gemacht.

[Thread debugging using libthread_db enabled]
[New Thread 0x7f4bda193750 (LWP 4343)]
0x00007f4bd5e19cf0 in nanosleep () from /lib/libc.so.6
[Current thread is 0 (process 4343)]

Thread 1 (Thread 0x7f4bda193750 (LWP 4343)):
#0 0x00007f4bd5e19cf0 in nanosleep () from /lib/libc.so.6
#1 0x00007f4bd5e19b47 in sleep () from /lib/libc.so.6
#2 0x00007f4bd9574b1f in ?? () from /usr/lib/libkdeui.so.5
#3 0x00007f4bd957542a in KCrash::defaultCrashHandler () from /usr/lib/libkdeui.so.5
#4
#5 0x00007f4bc33ad83d in ?? () from /lib/libselinux.so.1
#6 0x00007f4bc33a02ff in ?? () from /lib/libselinux.so.1
#7 0x0000000001e363e8 in ?? ()
#8 0x0000000000000000 in ?? ()
#0 0x00007f4bd5e19cf0 in nanosleep () from /lib/libc.so.6

ANY help?

hi hasp,

what is your arch? x86 or amd 64 ?

have you used dominik stadler packages before using my ppa ?

edit : to hasp have you tried to delete .kde/share/config/kdenliverc (in your home folder) after the update ?

I guess nevermind..

MLT & libmlt1 updates appeared in my "Update Manager" I'm assuming as of today. Regardless, Kdenlive seemingly works again.

--Hasp, I've set my Adept Software Sources to "Unsupported updates" & "Check for updates: Daily"
I hope that helps.

If anyone is curious | AMD 64 | initially Dominik Stadler | currently Sunab's

ok pseudyo,

I update my packages very often, daily if I have time ...

to hasp : can you confirm the problem is over with last update ? (3 hours ago)

i will recheck in an hour ...

@sunab arch is 64 ... and yes I used Dominik Stadler packages ... and yes i tried to delete .kde/share/config/kdenliverc

@all seems my fault, sorry: I updated from Dominik Stadler and not from sunab, i changed from Dominik to Sunab, and since KDENLIVE is starting again ....

Thanks a lot ...
hasp

Pages