Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001004KdenliveTransitionspublic2009-07-06 00:302010-02-02 10:38
ReporterJPtja 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platform32 bit intel and alikeOSUbuntuOS Version9.04
Product Version0.7.5 
Target VersionFixed in Version0.7.6 
Summary0001004: Crash when I use the Home-button to go to the start of a clip
DescriptionWhen I use the Home-button to go to the start of the selected clip, most of the times it quit itself.. One or two times it didn't quit, but I don't know why.
This happens when I was testing the transitions, I had two pictures, the second one was selected, then I was changing the transition, pushed the Home-button and it quits with these details:

Application: Kdenlive (kdenlive), signal SIGSEGV
[Current thread is 0 (LWP 11928)]

Thread 3 (Thread 0xaaebfb90 (LWP 12114)):
#0 0xb7f8d430 in __kernel_vsyscall ()
#1 0xb6551412 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
0000002 0xb6658344 in pthread_cond_timedwait () from /lib/tls/i686/cmov/libc.so.6
0000003 0xb7f6f9f9 in mlt_consumer_get_frame () from /usr/lib/libmlt.so.1
0000004 0xb654e9ce in pthread_mutex_lock () from /lib/tls/i686/cmov/libpthread.so.0
0000005 0x00000000 in ?? ()

Thread 2 (Thread 0xb217cb90 (LWP 12115)):
#0 0xb7f8d430 in __kernel_vsyscall ()
#1 0xb65510e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
0000002 0xb66582ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
0000003 0xb38a6d7c in ?? () from /usr/lib/mlt/libmltsdl.so
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 1 (Thread 0xb5bc0920 (LWP 11928)):
[KCrash Handler]
0000006 0x08101d4e in _start ()

TagsNo tags attached.
Build/Install Method3rd party package
Attached Filespng file icon crash handler.png [^] (1,246,806 bytes) 2009-07-07 15:34
png file icon transition.png [^] (212,365 bytes) 2009-07-07 17:25

- Relationships
duplicate of 0001114closedj-b-m Home key crashes kdenlive if transition is selected 

-  Notes
(0003610)
Granjow (developer)
2009-07-07 11:36

Could you perhaps take a screenshot of how it looks like? Or create a sample project and upload it here as archive? Pictures wouldn't be too big.

I tried to reproduce it, didn't work.
(0003621)
JPtja (reporter)
2009-07-07 15:35

Ive uploaded a screenshot of the Crash Handler, but sometimes it just works xD
After 2 or 3 times after using the home screen, it crashed.
(0003622)
Granjow (developer)
2009-07-07 16:56

Sorry, I meant a screenshot of your kdenlive, to see the clips on your timeline and the effects. Still, easiest would be if you could upload a small sample project here.
(0003623)
JPtja (reporter)
2009-07-07 17:27

transition.png ;)
When I pushed the Home-button at that moment, it crashed with the same crashreport as the previous one ;)

- Issue History
Date Modified Username Field Change
2009-07-06 00:30 JPtja New Issue
2009-07-06 00:30 JPtja Build/Install Method => 3rd party package
2009-07-07 11:36 Granjow Note Added: 0003610
2009-07-07 11:36 Granjow Status new => feedback
2009-07-07 15:34 JPtja File Added: crash handler.png
2009-07-07 15:35 JPtja Note Added: 0003621
2009-07-07 16:56 Granjow Note Added: 0003622
2009-07-07 17:25 JPtja File Added: transition.png
2009-07-07 17:27 JPtja Note Added: 0003623
2009-11-26 08:57 j-b-m Relationship added duplicate of 0001114
2009-11-26 08:57 j-b-m Status feedback => resolved
2009-11-26 08:57 j-b-m Fixed in Version => Recent git
2009-11-26 08:57 j-b-m Resolution open => fixed
2009-11-26 08:57 j-b-m Assigned To => j-b-m
2009-11-26 08:57 j-b-m Fixed in Version Recent git => 0.7.6
2010-02-02 10:34 j-b-m Fixed in Version 0.7.6 => 0.7.7
2010-02-02 10:37 j-b-m Fixed in Version 0.7.7 => 0.7.6
2010-02-02 10:38 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker