Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001068KdenliveMLTpublic2009-07-29 18:552010-02-20 08:16
Reportererv 
Assigned Toddennedy 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionnot fixable 
PlatformOSOS Version
Product Version0.7.3 
Target VersionFixed in Version 
Summary0001068: SOHO mpg loads 8 frames only to project, MPEG-ES file format
DescriptionSOHO mpg's won't load into project correctly, truncated to 8 frames.

System:
P5Q SE, Intel Core2 Duo E7200, 3GB Mem, with ATI Radeon 4500, ati drivers
Ubuntu 9.04 jaunty with KDE/Gnome (KDE4.2.2,Gnome 2.26.1)


reference video at (* attached)
  SOHO (esa/NASA Solar Heliospheric Observatory)
  http://sohowww.nascom.nasa.gov/data/realtime/mpeg/ [^]
* file: current_eit_195.mpg loads 8 frames of estimated 300 frames
  file: current_eit_195small.mpg loads 3 frames of estimated 300 frames.

Kdenlive's excellent frame server is super for frame by frame analysis/review.
The videos load and play in their entirety in players Totem(Gstreamer) and mplayer.

 
mplayer messages:
=====================================
Playing current_eit_195.mpg.
MPEG-ES file format detected.
VIDEO: MPEG1 512x512 (aspect 1) 30.000 fps 0.0 kbps ( 0.0 kbyte/s)
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 512 x 512 (preferred colorspace: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm: libmpeg2 (MPEG-1 or 2 (libmpeg2))
==========================================================================
Audio: no sound
Starting playback...
VDec: vo config request - 512 x 512 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.00:1 - prescaling to correct movie aspect.
VO: [xv] 512x512 => 512x512 Planar YV12
=========================================etc, video was playing.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files? file icon current_eit_195.mpg [^] (3,609,923 bytes) 2009-07-29 18:55
png file icon SOHO mpg Header.png [^] (269,193 bytes) 2010-02-11 17:17

- Relationships

-  Notes
(0003739)
j-b-m (administrator)
2009-07-29 22:16

File does not play with melt (only first frames), but works in ffplay, so it looks like an MLT issue
(0004703)
erv (reporter)
2010-02-11 17:16

Further info.. the SOHO videos are encoded using the University of California Berkeley codec.. "MPEG stream encoded by UCB Encoder (mpeg_encode) v1.5". The quote is from the file "current_eit_195.mpg" header area.

I'll attach a view of the top of the video mpg file in HEX which may help a little if the fix just ID'ing an existing codec in the libs or such.
(0004706)
ddennedy (developer)
2010-02-12 06:01

$ ffmpeg -i current_eit_195.mpg

[mpegvideo @ 0x63a3c0]Estimating duration from bitrate, this may be inaccurate
...
  Duration: 00:00:00.27, bitrate: 104856 kb/s

ffmpeg is unable to determine the duration. MLT requires a duration to support editing and random access. ffplay does play it longer than that duration because it is not an editor. If you try seeking in ffplay (click along horizontal axis of video window), you will see that it does not work correctly.
(0004707)
ddennedy (developer)
2010-02-12 06:03

In the latest release, Kdenlive includes a "Fix MPEG-1" transcode profile that creates an usable copy of this file without quality loss.

- Issue History
Date Modified Username Field Change
2009-07-29 18:55 erv New Issue
2009-07-29 18:55 erv File Added: current_eit_195.mpg
2009-07-29 18:55 erv Build/Install Method => Distribution package
2009-07-29 22:16 j-b-m Note Added: 0003739
2009-07-29 22:16 j-b-m Category File Loading => MLT
2009-07-29 22:16 j-b-m Status new => acknowledged
2010-02-11 17:16 erv Note Added: 0004703
2010-02-11 17:17 erv File Added: SOHO mpg Header.png
2010-02-12 06:01 ddennedy Note Added: 0004706
2010-02-12 06:03 ddennedy Note Added: 0004707
2010-02-12 06:03 ddennedy Status acknowledged => resolved
2010-02-12 06:03 ddennedy Resolution open => not fixable
2010-02-12 06:03 ddennedy Assigned To => ddennedy
2010-02-20 08:16 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker