Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001098KdenliveUser Interfacepublic2009-08-23 15:362010-02-02 10:38
Reporteramain 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.7.5 
Target VersionFixed in Version0.7.6 
Summary0001098: Kdenlive in Ubuntu Jaunty crashes after using the project monitor or clip monitor
DescriptionOS: Ubuntu Jaunty

kdenlive: 0.7.5-0ubuntu0~ppa1
ffmpeg: 3:0.svn20090303-1ubuntu6+patch~ppa3
libmlt1: 0.4.4-0ubuntu0~ppa4
libmlt1: 0.3.8-0ubuntu2
melt: 0.4.4-0ubuntu0~ppa4
libmlt++2: 0.4.4-0ubuntu0~ppa4

Reproduce path #1:

1. Add clip to Project Tree
2. Play in clip monitor
3. (right)click on the clip in the Project Tree
4. crash

Reproduce path 0000002:

1. Add clip to Project Tree
2. Drag clip to a track in the timeline
3. Play in project monitor
4. (right)click on the clip in the Project Tree
    ( or click elsewhere and after a while kdenlive will crash )
5. crash

- ffplay plays my movie without problems
- melt plays my movie without problems
- melt plays the test_file.kdenlive without problems

Workaround: create debian sid choot with debootstrap. Install kdenlive 0.7.5 for Debian and everything works fine!!!

note: I've never used Video Editing software but I was able to create with little effort my first video with kdenlive after viewing a couple of tutorials on the website! Great peace of software...and great that's it's free!
Additional InformationI've been testing with kdenlive 0.7.3 and 0.7.4, and 0.7.5 unstable ubuntu pakages found on the forum and the same problem exits in these version.
TagsNo tags attached.
Build/Install MethodOther Method?
Attached Filestxt file icon debugout.txt [^] (871 bytes) 2009-08-23 15:36 [Show Content]

- Relationships
related to 0001117closedj-b-m Adding or selecting items from the the Project Tree causes crashes. 
has duplicate 0001097closedj-b-m Kdenlive in Ubuntu Jaunty crashes after using the project monitor or clip monitor 

-  Notes
(0003869)
j-b-m (administrator)
2009-09-07 18:28

Please start by removing the 0.3.8 version of MLT, it will conflict with the 0.4.4 version. Then, try to delete you file:
$HOME/.kde/share/config/kdenliverc

and restart kdenlive. If it is still the same, you should remove the pulseaudio server which breaks Kdenlive, as reported by several users.
(0004057)
amain (reporter)
2009-10-02 16:53

Hi,

- libmlt-0.3.8 was already not on my system ( I mistakenly added it to the list of installed softeware in this bugreport ).
- pulseaudio indeed breaks kdenlive and lot of other stuff as well, so pulsaudio was already not present ( renamed the binary; removing package is not advised, because it depends on the ubuntu-desktop package, which is used for proper ubuntu upgrades )

Removed $HOME/.kde/share/config/kdenliverc, but unfortunately problem persists. I have a 64 bit laptop now, and kdenlive works great. If you suspect this bug is not seen by lot of other Ubuntu users, and/or not worth investigating, you could close the bug. I have my old Ubuntu laptop still around so, if you want to investigate, I can help testing stuff or giving additional info.

Thanks so far.
(0004058)
amain (reporter)
2009-10-02 17:01

Hi,

I decided to remove the pulseaudio package (and not just renaming the pulseaudio binary), since I'm not going to use the laptop anymore and......no crashes anymore!!!

Regards,

Amain
(0004060)
raps (reporter)
2009-10-03 22:13

I had problems with Pulseaudio too.
Using Xubuntu Jaunty.
Kdenlive reacts with a crash when Pulseaudio is not correctly configured (Pulseaudio was not working right) and/or some packages are not installed.

I got a hint with the command "pulseaudio" in the terminal.
I described it in the issue 1117.

Precision: with other programs the sound was working. So I don't know really why it is so, and today I solved the problem as described in the issue 1117.

- Issue History
Date Modified Username Field Change
2009-08-23 15:36 amain New Issue
2009-08-23 15:36 amain File Added: debugout.txt
2009-08-23 15:36 amain Build/Install Method => Other Method?
2009-08-26 18:04 j-b-m Relationship added has duplicate 0001097
2009-09-07 18:28 j-b-m Note Added: 0003869
2009-09-07 18:28 j-b-m Status new => feedback
2009-10-02 16:53 amain Note Added: 0004057
2009-10-02 17:01 amain Note Added: 0004058
2009-10-03 22:13 raps Note Added: 0004060
2009-10-03 22:17 j-b-m Relationship added related to 0001117
2009-10-05 19:10 j-b-m Status feedback => resolved
2009-10-05 19:10 j-b-m Resolution open => fixed
2009-10-05 19:10 j-b-m Assigned To => j-b-m
2009-10-08 20:21 j-b-m Fixed in Version => 0.7.6
2010-02-02 10:35 j-b-m Fixed in Version 0.7.6 => 0.7.7
2010-02-02 10:37 j-b-m Fixed in Version 0.7.7 => 0.7.6
2010-02-02 10:38 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker