Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001110KdenliveRenderingpublic2009-08-30 18:192010-02-20 08:16
Reporterybecognee 
Assigned Toj-b-m 
PrioritynormalSeveritymajorReproducibilityrandom
StatusclosedResolutionno change required 
PlatformOSOS Version
Product Version0.7.5 
Target VersionFixed in Version 
Summary0001110: Kdenlive some times is reading/export my clips, some times it don't.
DescriptionI have realized a KDEnLive project with clips from my camera "Sony T20" It accepts loading .mpg files without any problem. But some time to time it can't read some of them on time line : no video (black), only sound. When it don't read a clip : I go in tree and read it, then it works in time line. But when I export, almost 3/4 clips are black...
Additional InformationI'm under Ubuntu 9.04 with 7.5.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files? file icon MOV06552.MPG [^] (14,894,063 bytes) 2009-08-30 18:19
jpg file icon version-ffmpeg.jpg [^] (138,141 bytes) 2009-09-02 08:33


? file icon test.mpg [^] (11,124,736 bytes) 2009-09-04 19:39
txt file icon convert.txt [^] (338 bytes) 2009-09-22 11:50 [Show Content]

- Relationships
duplicate of 0000535closedddennedy some clips in the timeline no longer show anything in the clipmonitor 
has duplicate 0001088closedj-b-m Black is rendered everytime a clip is cutted at the beginning 
related to 0001746assignedj-b-m large files rendered as black video (sound is fine), preview as well 

-  Notes
(0003840)
j-b-m (administrator)
2009-09-01 19:37

What happens if you try to play the .kdenlive project file with melt?

melt myproject.kdenlive

Do you also have black clips? My guess is that that might be caused by your version of FFmpeg, can you tell us which version you have?
(0003846)
ybecognee (reporter)
2009-09-02 08:37

When melt is reading my .kdenlive project, it does the same : most of clips are black. Some are ok, althout all comes from the same camera.

I have uploaded a screenshot of synptic to show you my ffmpeg version

Thank for all
(0003847)
j-b-m (administrator)
2009-09-02 09:36

Ok, that is an FFmpeg issue, which is still present in latest svn version of FFmpeg. For some reason, when seeking into the file, FFmpeg has problems with the streams.

Reproducable with your uploaded clip:

ffplay MOV06552.MPG
it works

ffplay MOV06552.MPG -ss 2
Does not work (should start playing 2 seconds after beginning)

Also, trying to transcode the clip with FFmpeg:

ffmpeg -i MOV06552.MPG -vcodec copy -acodec copy -ss 2 test.mpg

creates a file with no video stream. I will upload your file to FFmpeg and report the bug.
(0003848)
j-b-m (administrator)
2009-09-02 09:43
edited on: 2009-09-02 09:54

Just to be sure, the attached MOV06552.MPG is taken from your camera, you did not edit or convert it in any way?

Edit: The bug already exists in FFmpeg bug tracker:
https://roundup.ffmpeg.org/roundup/ffmpeg/issue748 [^]

(0003861)
ybecognee (reporter)
2009-09-04 19:37

This video is directly comes from a "Sony DSC-T20"
http://www.letsgodigital.org/fr/13222/sony_cybershot_dsct20/ [^]
I did that :
ffmpeg -i MOV06552.MPG -vcodec copy -acodec copy -ss 2 test.mpg

The test.mpg files is attached.

Thank you for your help
(0003891)
ybecognee (reporter)
2009-09-14 19:52

Have-you got the movie ?
Have you got an idea when ffmpeg will update and repare this bug ?

Thank you
(0003903)
j-b-m (administrator)
2009-09-15 23:08
edited on: 2009-09-15 23:09

Yes, I got the movie & did put all relevant infos on the camcorder page:

http://kdenlive.org/video-editor/sony-dsc-t20 [^]

Unfortunately, I have no idea when the issue will be fixed in FFmpeg...

(0003938)
j-b-m (administrator)
2009-09-16 23:22

After seeing that the Sony DSC t70 had the same issue, I did some research and it looks like the problem is related to Sony using a stupid proprietary format called MPEG VX which is not editable. I saw several users reporting issues with this format with various video editors.

Looks like the best solution will be to convert your video files using that command:

ffmpeg -i original_clip.mpg -sameq -acodec copy -vcodec mpeg1video duplicate.mpg

The resulting file should work fine in Kdenlive & quality should be preserved if I am right.

Feedback welcome.
(0003940)
ddennedy (developer)
2009-09-16 23:26

Sorry, I have known about poor mpeg1 support since bug 535. Some clips work fine, others do not. We should probably add a "Fix MPEG-1" transcode preset. What do you think?
(0003948)
j-b-m (administrator)
2009-09-17 01:38

Yes, a transcode profile is a good idea. I just committed it, and will see if I can find some time to improve the mass transcoding feature (save transcoded files in another folder for example...)

The profile contains the parameters mentioned in my previous comment and works for the file attached to this bug report.
(0003964)
ybecognee (reporter)
2009-09-19 09:19

Thank you for help

I dont't know a lot of things about commande line. Is it possible to convert more than one clip with only one command line ?
I suppose it's based on :
ffmpeg -i original_clip.mpg -sameq -acodec copy -vcodec mpeg1video duplicate.mpg

Thank you
(0003968)
j-b-m (administrator)
2009-09-22 11:53

I attached a small script called convert.txt.
Download it, then make it executable:

chmod +x convert.txt

Then, copy the convert.txt script to where your source videos are, and run it with:

./convert.txt

It will create a folder called "duplicates" and put all your converted .mpg files in it.
(0003977)
ybecognee (reporter)
2009-09-22 22:41

Thank you very much

I will use it
What langage is-it ?

Thank you again
(0003978)
j-b-m (administrator)
2009-09-22 22:46

It's a bash script:
http://en.wikipedia.org/wiki/Bash [^]
(0004695)
j-b-m (administrator)
2010-02-09 14:16

Good news, the FFMpeg issue was fixed a few days ago (https://roundup.ffmpeg.org/roundup/ffmpeg/issue1226 [^]), and the problem is not reproducible anymore.

- Issue History
Date Modified Username Field Change
2009-08-30 18:19 ybecognee New Issue
2009-08-30 18:19 ybecognee File Added: MOV06552.MPG
2009-08-30 18:19 ybecognee Build/Install Method => Distribution package
2009-09-01 19:37 j-b-m Note Added: 0003840
2009-09-01 19:37 j-b-m Status new => feedback
2009-09-02 08:33 ybecognee File Added: version-ffmpeg.jpg
2009-09-02 08:37 ybecognee Note Added: 0003846
2009-09-02 09:36 j-b-m Note Added: 0003847
2009-09-02 09:43 j-b-m Note Added: 0003848
2009-09-02 09:54 j-b-m Note Edited: 0003848 View Revisions
2009-09-04 19:37 ybecognee Note Added: 0003861
2009-09-04 19:39 ybecognee File Added: test.mpg
2009-09-14 19:52 ybecognee Note Added: 0003891
2009-09-15 23:08 j-b-m Note Added: 0003903
2009-09-15 23:09 j-b-m Note Edited: 0003903 View Revisions
2009-09-16 21:55 j-b-m Relationship added has duplicate 0001088
2009-09-16 23:22 j-b-m Note Added: 0003938
2009-09-16 23:24 ddennedy Relationship added duplicate of 0000535
2009-09-16 23:26 ddennedy Note Added: 0003940
2009-09-17 01:38 j-b-m Note Added: 0003948
2009-09-19 09:19 ybecognee Note Added: 0003964
2009-09-22 11:50 j-b-m File Added: convert.txt
2009-09-22 11:53 j-b-m Note Added: 0003968
2009-09-22 22:41 ybecognee Note Added: 0003977
2009-09-22 22:46 j-b-m Note Added: 0003978
2010-02-09 14:16 j-b-m Note Added: 0004695
2010-02-09 14:16 j-b-m Status feedback => resolved
2010-02-09 14:16 j-b-m Resolution open => no change required
2010-02-09 14:16 j-b-m Assigned To => j-b-m
2010-02-20 08:16 j-b-m Status resolved => closed
2010-08-14 23:19 j-b-m Relationship added related to 0001746


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker