Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001111KdenliveMLTpublic2009-09-01 01:572010-09-22 17:53
Reporternonolemono 
Assigned Toddennedy 
PrioritynormalSeveritymajorReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.7.5 
Target Version0.7.6Fixed in Version0.7.6 
Summary0001111: Render display an INVALID text
DescriptionWhenever I try to render a video project, I get an INVALID text in the video and that's all.
I found out the problem by using the script output and checking the mlt file.
Actually every path are wrong, for whatever reason (don't know if its MLT or Kdenkive) but paths to files are truncated.

For example they will be
<property name="resource" >edias/Kdenlive/default/titles/title003.png</property>
(note the missing M) when they should be
<property name="resource" >/home/nono/DocumentsMedias/Kdenlive/default/titles/title003.png</property>

I first thought the top entry
<mlt title="Anonymous Submission" root="/home/nono/Documents" >
was added to the path, but it does not seem to be the case as making them to match the full path is not a working combination either.

I then tried a project in another folder and this works. The ressource is properly set in the MLT file:
<property name="resource" >/home/nono/tmp/MVI_4553.AVI</property>

I don't know what happens but this is quite annoying and unanderstandable as there are no special character is my paths.
TagsNo tags attached.
Build/Install Method3rd party package
Attached Files? file icon script002.sh.mlt [^] (7,138 bytes) 2009-09-02 14:39

- Relationships

-  Notes
(0003837)
j-b-m (administrator)
2009-09-01 18:13

Can you please try the following in a terminal:

Go in your home folder (/home/nono) and type:

melt ./DocumentsMedias/Kdenlive/default/titles/title003.png -consumer xml:test.xml

Then check the content of the file test.xml to see if the path is correctly set
(0003838)
nonolemono (reporter)
2009-09-01 18:43

I attached the resulting file.
The path seems correctly generated.
(0003839)
j-b-m (administrator)
2009-09-01 19:35

Oups, .xml files were not allowed for upload, I just changed it, please send it again. Can you also try to create a new project with Kdenlive, add your clip & see if the problem is still here? If it is, please also attach the .kdenlive project file.

However, I wonder if your problem occurs only with title clips, because title clips are handled in a special way by Kdenlive, which might be the reason for your problem...

We completely rewrote the way titles are handled for the next release, so that problem - if only present with title clips - should be solved...
(0003841)
nonolemono (reporter)
2009-09-01 20:13

It does not happen onlywith title clips because all paths were wrong.

I'll try with a completely new project tonight but I think the problem might be because of something kdenlive/mlt doesn't like in the path to my files.

I'll report tonight.
(0003844)
nonolemono (reporter)
2009-09-02 03:56

So I tried creating a new project but the result is the same, the path is wrong.
I attached a generated MLT file.
(0003845)
j-b-m (administrator)
2009-09-02 08:26

No file attached... did you select the file & click "Upload file" ?
(0003849)
nonolemono (reporter)
2009-09-02 14:40

Think I forgot to press upload sorry.
The file is script002.sh.mlt
(0003850)
nonolemono (reporter)
2009-09-02 15:15

I've done a few tests and here the results:

- I don't know why but every MLT file has on the second line en entry like
<mlt title="Anonymous Submission" root="/home/nono/Documents" >
I never set this path anywhere in Kdenlive, my default project folder is /home/nono/DocumentsMedias/Kdenlive/default

- The problem only appears when my clip paths start with "Document", which is the case here as my files are in "/home/nono/DocumentsMedias/XXXXX"

The ressources paths are all truncated from "/home/nono/Documents".

For example I created a DocumentsMedias2 for testing purposes, and the resulting ressources paths are like
<property name="resource" >edias2/MVI_4552.AVI</property>

Here again the first part of the path is truncated and the first letter "M" is removed.
(0003855)
j-b-m (administrator)
2009-09-02 23:54
edited on: 2009-09-03 00:23

Ok, I can confirm that it is an MLT bug. It is related to the way MLT creates the "root" property for the xml data.

To reproduce:

Create a directory called Documents and another one called DocumentsMedia, both at the same place.

Go in the Documents folder and type:
melt /path/to/DocumentsMedias/a11.mov -consumer xml:test.xml

This will produce broken paths.

(0003858)
nonolemono (reporter)
2009-09-03 17:23

Yes it is exactly the problem.

However I don't see why Kdenlive behaves as if i had executed my commands from the Documents folder ?
As I said there is no mention of such path anywhere in my configuration.

Anyway we can just wait for it to be fixed now.
(0003859)
ddennedy (developer)
2009-09-04 05:55

In order to reproduce this, you must cd into DocumentsMedias before running melt. I am looking into making a correct fix.
(0003860)
ddennedy (developer)
2009-09-04 06:23

Fixed in MLT Git.

- Issue History
Date Modified Username Field Change
2009-09-01 01:57 nonolemono New Issue
2009-09-01 01:57 nonolemono Build/Install Method => 3rd party package
2009-09-01 18:13 j-b-m Note Added: 0003837
2009-09-01 18:43 nonolemono Note Added: 0003838
2009-09-01 19:35 j-b-m Note Added: 0003839
2009-09-01 19:35 j-b-m Status new => feedback
2009-09-01 20:13 nonolemono Note Added: 0003841
2009-09-02 03:56 nonolemono Note Added: 0003844
2009-09-02 08:22 j-b-m File Added: test.xml
2009-09-02 08:23 j-b-m File Deleted: test.xml
2009-09-02 08:26 j-b-m Note Added: 0003845
2009-09-02 14:39 nonolemono File Added: script002.sh.mlt
2009-09-02 14:40 nonolemono Note Added: 0003849
2009-09-02 15:15 nonolemono Note Added: 0003850
2009-09-02 23:54 j-b-m Note Added: 0003855
2009-09-02 23:54 j-b-m Status feedback => acknowledged
2009-09-03 00:23 j-b-m Note Edited: 0003855 View Revisions
2009-09-03 17:23 nonolemono Note Added: 0003858
2009-09-04 05:55 ddennedy Note Added: 0003859
2009-09-04 06:23 ddennedy Note Added: 0003860
2009-09-04 06:23 ddennedy Status acknowledged => resolved
2009-09-04 06:23 ddennedy Fixed in Version => Recent git
2009-09-04 06:23 ddennedy Resolution open => fixed
2009-09-04 06:23 ddennedy Assigned To => ddennedy
2009-09-10 01:39 xzhayon Target Version => future version
2009-10-08 20:20 j-b-m Fixed in Version Recent git => 0.7.6
2010-02-02 10:35 j-b-m Fixed in Version 0.7.6 => 0.7.7
2010-02-02 10:37 j-b-m Fixed in Version 0.7.7 => 0.7.6
2010-02-02 10:38 j-b-m Status resolved => closed
2010-09-22 17:53 Granjow Target Version future version => 0.7.6


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker