Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001115KdenliveMLTpublic2009-09-05 13:262010-02-02 10:38
Reporterandrej_aschenbrenner 
Assigned Toj-b-m 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platform64 bitOSUbuntu LinuxOS Version9.04
Product Version0.7.5 
Target VersionFixed in Version0.7.6 
Summary0001115: Video is played with double speed compared to audio after loading the .kdenlive project file
DescriptionWhen creating a new project with the profile "HD 720p 25Hz" and adding the Video file (00011.mov) to the project time line, the playing does work as expected. But after saving the project and then loading the saved project in Kdenlive the preview seems to play the video twice as fast as it should be. You can see it because the video stops playing after 0000018:0000030 sec (a black screen is shown) whereby the audio continues to play with the normal speed.
Steps To Reproduce1. Start Kdenlive
2. Add the movie 00011.mov
3. Drag the movie to the project time line
3. Start the playing in the project monitor (does work as expected)
4. Save the project
5. Close Kdenlive
6. Open Kdenlive and load the saved project file
7. Start the playing in the project monitor (video is played twice as fast, audio is OK)
Additional InformationUsed Camcorder: Toshiba Camileo S20
Hardware: Dual Core Intel(R) Core(TM)2 Duo CPU T9300 @ 2.50GHz
OS: Linux hp-laptop 2.6.28-15-generic 0000051-Ubuntu SMP Mon Aug 31 13:39:06 UTC 2009 x86_64 GNU/Linux


Output of ffplay 00011.mov (the played speed is correct):

FFplay version 0.5-svn+3:0.svn20090303-1ubuntu6+patch~ppa3, Copyright (c) 2003-2009 Fabrice Bellard, et al.
  configuration: --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --extra-version=svn+3:0.svn20090303-1ubuntu6+patch~ppa3 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --disable-stripping --disable-vhook --enable-libxvid --enable-libmp3lame --enable-libfaac --enable-libx264 --enable-libdc1394 --enable-shared --disable-static
  libavutil 49.15. 0 / 49.15. 0
  libavcodec 52.20. 0 / 52.20. 0
  libavformat 52.31. 0 / 52.31. 0
  libavdevice 52. 1. 0 / 52. 1. 0
  libavfilter 0. 4. 0 / 0. 4. 0
  libswscale 0. 7. 1 / 0. 7. 1
  libpostproc 51. 2. 0 / 51. 2. 0
  built on Jul 11 2009 13:10:42, gcc: 4.3.3
[h264 @ 0x755f50]B picture before any references, skipping
[h264 @ 0x755f50]decode_slice_header error
[h264 @ 0x755f50]no frame!
[h264 @ 0x755f50]B picture before any references, skipping
[h264 @ 0x755f50]decode_slice_header error
[h264 @ 0x755f50]no frame!
[h264 @ 0x755f50]B picture before any references, skipping
[h264 @ 0x755f50]decode_slice_header error
[h264 @ 0x755f50]no frame!


Output of melt 00011.mov (the played speed is correct):
 
+-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+
|1=-10| |2= -5| |3= -2| |4= -1| |5= 0| |6= 1| |7= 2| |8= 5| |9= 10|
+-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+
+---------------------------------------------------------------------+
| H = back 1 minute, L = forward 1 minute |
| h = previous frame, l = next frame |
| g = start of clip, j = next clip, k = previous clip |
| 0 = restart, q = quit, space = play |
+---------------------------------------------------------------------+
[h264 @ 0xdffe30]B picture before any references, skipping
[h264 @ 0xdffe30]decode_slice_header error
[h264 @ 0xdffe30]no frame!
Current Position: 1239
TagsNo tags attached.
Build/Install Method3rd party package
Attached Filesmov file icon 00011.mov [^] (26,034,120 bytes) 2009-09-05 13:26
? file icon Test.kdenlive [^] (6,128 bytes) 2009-09-05 13:27

- Relationships

-  Notes
(0003863)
andrej_aschenbrenner (reporter)
2009-09-05 13:39

I have played around a bit and found that when I refresh the clip then the video is played with correct speed again.

In Test.kdenlive I have found the following (snippet):
 <producer in="0" out="1239" id="1" >
  <property name="mlt_type" >producer</property>
  <property name="aspect_ratio" >1.000000</property>
  <property name="length" >1240</property>
  <property name="meta.media.0.stream.frame_rate" >29.970030</property>
...
  <property name="source_fps" >59.940060</property>
 </producer>

Could this "source_fps"=59.940060 be the reason for the double speed playing of video?
(0003864)
j-b-m (administrator)
2009-09-05 17:30

Not reproducable with recent MLT & Kdenlive svn. I think the issue is effectively related to the wrong source_fps value.

This wrong fps detection happened when muxer and codec report different fps, and was fixed in the following MLT commit:
http://mltframework.org/gitweb/mlt.git?p=mltframework.org/mlt.git;a=commitdiff;h=2e7094eebd8d7ade29c187e421491c35122ddfe6 [^]

A new release of MLT & Kdenlive should hopefully happen in the next weeks.
(0003867)
andrej_aschenbrenner (reporter)
2009-09-06 15:46

I have manually changed the occurrence of 59.940060 fps in the Test.kdenlive

from
<property name="source_fps" >59.940060</property>
to
<property name="source_fps" >29.970030</property>

and
<kdenlive_producer audio_max="1" id="1" default_video="0" fps="59.940060"...
to
<kdenlive_producer audio_max="1" id="1" default_video="0" fps="29.970030"...

but having still the same problem. So the loader of the video is to blame.
Unfortunately currently I don't have the time to compile the svn sources. So I'm waiting for the next package release to test it out.
(0003913)
ddennedy (developer)
2009-09-16 08:09

The source_fps in XML is always overridden by MLT by design. In fact, it can be argued that MLT should not write that value into the XML to avoid confusion. It determines the value using FFmpeg libs. Therefore, editing this value in your XML will not resolve the problem. What JBM refers to is the fact that in MLT, since your version, there was a change in logic in the determination of the source_fps and that logic change fixes the problem with the files you provided.
(0003931)
narcisgarcia (reporter)
2009-09-16 20:33

Bug confirmed with Ubuntu GNU/Linux 9.04 (32bits), installing the provided .deb package.

I used various .FLV video files.
(0003932)
narcisgarcia (reporter)
2009-09-16 20:54
edited on: 2009-09-16 21:20

How can I downgrade to Ubuntu's repositories Kdenlive 0.7.3 ?

I've tried with Synaptic to remove the launchpad-sunab repository, updating, removing 0.7.5 and installing 0.7.3, but now Kdenlive returns a fatal error about MLT (Inigo): SLD module for MLT not found.

-- Update --
I see; I needed to remove "kdenlive" folders in $HOME and $HOME/kde/

(0004093)
andrej_aschenbrenner (reporter)
2009-10-09 09:04

I can confirm that this issue is fixed in the 0.7.6 release. So this issue can be closed.

- Issue History
Date Modified Username Field Change
2009-09-05 13:26 andrej_aschenbrenner New Issue
2009-09-05 13:26 andrej_aschenbrenner File Added: 00011.mov
2009-09-05 13:26 andrej_aschenbrenner Build/Install Method => 3rd party package
2009-09-05 13:27 andrej_aschenbrenner File Added: Test.kdenlive
2009-09-05 13:39 andrej_aschenbrenner Note Added: 0003863
2009-09-05 17:30 j-b-m Note Added: 0003864
2009-09-05 17:30 j-b-m Status new => feedback
2009-09-06 15:46 andrej_aschenbrenner Note Added: 0003867
2009-09-16 08:09 ddennedy Note Added: 0003913
2009-09-16 20:33 narcisgarcia Note Added: 0003931
2009-09-16 20:54 narcisgarcia Note Added: 0003932
2009-09-16 21:20 narcisgarcia Note Edited: 0003932 View Revisions
2009-10-09 09:04 andrej_aschenbrenner Note Added: 0004093
2009-10-09 13:19 j-b-m Status feedback => resolved
2009-10-09 13:19 j-b-m Fixed in Version => 0.7.6
2009-10-09 13:19 j-b-m Resolution open => fixed
2009-10-09 13:19 j-b-m Assigned To => j-b-m
2010-02-02 10:35 j-b-m Fixed in Version 0.7.6 => 0.7.7
2010-02-02 10:37 j-b-m Fixed in Version 0.7.7 => 0.7.6
2010-02-02 10:38 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker