Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001117KdenliveUser Interfacepublic2009-09-05 15:032010-02-02 10:38
Reporterneoarttec 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSOS Version
Product Version0.7.5 
Target VersionFixed in Version0.7.6 
Summary0001117: Adding or selecting items from the the Project Tree causes crashes.
DescriptionProject Tree

Selecting items sometimes causes crashes

Adding a Title Clip always causes crashes

Produces a segmentation fault.

Crash report is attached.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Filestxt file icon kdenlive-20090905.kcrash.txt [^] (4,870 bytes) 2009-09-05 15:03 [Show Content]
txt file icon kdenlive-20090909.kcrash.txt [^] (8,654 bytes) 2009-09-09 01:50 [Show Content]
txt file icon kdenlive-20090915.kcrash.txt [^] (8,685 bytes) 2009-09-15 14:27 [Show Content]
txt file icon kdenlive-20090918.kcrash.txt [^] (9,211 bytes) 2009-09-18 04:54 [Show Content]

- Relationships
has duplicate 0001116closedj-b-m Adding or selecting items from the the Project Tree causes crashes. 
related to 0001098closedj-b-m Kdenlive in Ubuntu Jaunty crashes after using the project monitor or clip monitor 

-  Notes
(0003865)
j-b-m (administrator)
2009-09-05 17:32

Can you please tell us which MLT / MLT++ packages are installed on your computer?
(0003874)
neoarttec (reporter)
2009-09-08 02:16

Sorry, running SVN versions now.
(0003881)
neoarttec (reporter)
2009-09-09 01:52
edited on: 2009-09-09 02:33

Latest SVN version built with Kdenlive Builder has also crashed adding a clip to the time line. Crash report has been added.

 kdenlive-20090909.kcrash.txt

which MLT / MLT++? Latest as built with Kdenlive Builder.

Crash appears to occur after playing the main time line. If I open the project, and do not play the time line, I can select clips, add and edit to the time line.
 
After playing the time line, I can edit and play the time line again. However, selecting a clip from the project tree will cause a crash.

The crash occurs regardless of playing the project or clip monitor.

(0003884)
neoarttec (reporter)
2009-09-09 03:49

Have DL latest sources from SVN.

ffmpeg rev: 19796
mlt commit: d4176e88ca3717b149d48b4ef12fd514ebe16d10
kdenlive rev: 3882

It appears the issue may have been resolved. I am not experiencing any crashes with this issue.
(0003887)
xzhayon (developer)
2009-09-10 01:35

nothing has been committed yet, please, keep on watching out for the crashes
(0003893)
neoarttec (reporter)
2009-09-15 15:10

I think I have identified the problem. After the computer wakes from hybernation, the ALSA sound is not working. So I then have to "rcalsasound restart" so that various applications can use the sound again.

Now, if I haven't done the restart, audio playback of clips crackles, plus, if I select a clip, Kdenlive then crashes.
(0004013)
raps (reporter)
2009-09-26 21:41
edited on: 2009-09-26 21:44

I have that problem too... but it seems I have not ALSA but pulse.

OS: Xubuntu 9.04
MLT: 0.4.5
Kdenlive: 0.7.5 - package of sunab from
deb http://ppa.launchpad.net/sunab/sunab2/ubuntu [^] jaunty main

The command "rcalsasound restart" does not exists.

The original package for Ubuntu had also this problem.
deb http://ppa.launchpad.net/sunab/ubuntu [^] jaunty main

On the last version i used (Kdenlive 0.7.1), with Xubuntu 8.10, didn't had that problem.
I installed the Ubuntu package from
deb http://ppa.launchpad.net/baudm/ubuntu [^] intrepid main

I guess my system uses pulse, and i generally didn't noticed problems with the sound...

(0004021)
neoarttec (reporter)
2009-09-28 02:12

"rcalsasound restart" has to be executed as SuperUser, sudo
(0004033)
raps (reporter)
2009-09-28 23:00

The result is not better.

~$ sudo rcalsasound restart
sudo: rcalsasound: command not found


Meanwhile as i posted on the forum it seems KDE has a problem with my eth / wifi connection:

I have this error in the terminal when it crashes:
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
I: caps.c: Dropping root privileges.
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
KCrash: Application 'kdenlive' crashing...
sock_file=/home/thomas/.kde/socket-NB01-HN/kdeinit4__0

If I undestand right, it reports a problem of KDE with my (ethernet/wifi) connection.
It is strange (for me), because I use xfce and I don't see what it has to do with the desktop environment.
(0004035)
j-b-m (administrator)
2009-09-28 23:10

Several users reported crashes and slowdown using pulseaudio. It is recommended to remove the pulseaudio server to use Kdenlive and instead use alsa sound
(0004039)
raps (reporter)
2009-09-29 01:04
edited on: 2009-09-29 01:05

Some feedback:
1) I tried to get Kdenlive to work with pulse. I had no sound anymore on Kdenlive, but it was stable.

sudo apt-get install libsdl1.2debian-all

I tried this too:

sudo apt-get install libsdl1.2debian-pulseaudio

Kdenlive shown a message on the statusbar like: SDL: cannot find audio driver

2) I tried to replace pulse with alsa. I had sound back on Kdenlive but it was unstable again (even after restart):

sudo apt-get --purge remove pulseaudio* libpulse*
sudo apt-get install alsa-utils gstreamer0.10-alsa
sudo apt-get install alsamixergui

sudo apt-get install kdenlive (as this package were removed)
sudo apt-get install openoffice.org (as this package were removed)

I think the first try was not bad, but i maybe missed something in the configuration. There is a commad "export SDL_AUDIODRIVER=pulse" i don't understand at the moment...

Links:
http://ubuntuforums.org/showthread.php?t=776739 [^]
http://doc.ubuntu-fr.org/pulseaudio#firefox_flash_et_pulseaudio [^]

(0004048)
raps (reporter)
2009-09-30 01:39
edited on: 2009-10-03 22:13

After hours looking for a solution... the solution!

I activated/installed Pulseaudio back, chose "automatic" in the audio configuration of Kdenlive.
Package "libsdl1.2debian-pulseaudio" and "pavucontrol" are installed too.

Now running "pulseaudio" in a terminal I got errors.
Namely, the owner of the file ".pulse-cookie" was "root":
Failed to open cookie file '/home/thomas/.pulse-cookie'

Solution: change owner of that file.
sudo chown thomas:thomas .pulse-cookie

In pavucontrol i can see Kdenlive as client of pulseaudio :)


- Issue History
Date Modified Username Field Change
2009-09-05 15:03 neoarttec New Issue
2009-09-05 15:03 neoarttec File Added: kdenlive-20090905.kcrash.txt
2009-09-05 15:03 neoarttec Build/Install Method => Distribution package
2009-09-05 16:57 j-b-m Relationship added has duplicate 0001116
2009-09-05 17:32 j-b-m Note Added: 0003865
2009-09-05 17:32 j-b-m Status new => feedback
2009-09-08 02:16 neoarttec Note Added: 0003874
2009-09-09 01:50 neoarttec File Added: kdenlive-20090909.kcrash.txt
2009-09-09 01:52 neoarttec Note Added: 0003881
2009-09-09 02:32 neoarttec Note Added: 0003883
2009-09-09 02:33 neoarttec Note Deleted: 0003883
2009-09-09 02:33 neoarttec Note Edited: 0003881 View Revisions
2009-09-09 03:49 neoarttec Note Added: 0003884
2009-09-10 01:35 xzhayon Note Added: 0003887
2009-09-15 14:27 neoarttec File Added: kdenlive-20090915.kcrash.txt
2009-09-15 15:10 neoarttec Note Added: 0003893
2009-09-18 04:54 neoarttec File Added: kdenlive-20090918.kcrash.txt
2009-09-26 21:41 raps Note Added: 0004013
2009-09-26 21:44 raps Note Edited: 0004013 View Revisions
2009-09-28 02:12 neoarttec Note Added: 0004021
2009-09-28 23:00 raps Note Added: 0004033
2009-09-28 23:10 j-b-m Note Added: 0004035
2009-09-29 01:04 raps Note Added: 0004039
2009-09-29 01:05 raps Note Edited: 0004039 View Revisions
2009-09-30 01:39 raps Note Added: 0004048
2009-09-30 01:39 raps Note Edited: 0004048 View Revisions
2009-10-03 22:13 raps Note Edited: 0004048 View Revisions
2009-10-03 22:17 j-b-m Relationship added related to 0001098
2009-10-03 22:17 j-b-m Status feedback => resolved
2009-10-03 22:17 j-b-m Resolution open => no change required
2009-10-03 22:17 j-b-m Assigned To => j-b-m
2009-10-08 20:21 j-b-m Fixed in Version => 0.7.6
2010-02-02 10:35 j-b-m Fixed in Version 0.7.6 => 0.7.7
2010-02-02 10:37 j-b-m Fixed in Version 0.7.7 => 0.7.6
2010-02-02 10:38 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker