Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000112KdenliveBuild Systempublic2008-04-04 04:002008-10-23 00:22
ReporterEspinosa 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0000112: Build failure - ffmpeg header structure changed
Description[ 10%] Building CXX object kdenlive/CMakeFiles/kdenlive.dir/krender.o
/home/espinosa/src2/kdenlive/kdenlive/krender.cpp:28:29: error: ffmpeg/avformat.h: No such file or directory

There is no more ffmpeg/avformat.h in includes directory.
ffmpeg directory seems to split to several separate directories. avformat.h is now in libavformat/avformat.h.

Additional Information[espinosa@pavilon src2]$ ./kdenlive_builder.sh info
FFmpeg SVN version:
Revision: 12684
Last Changed Date: 2008-04-04 01:43:34 +0100 (Fri, 04 Apr 2008)
MLT SVN version:
Revision: 1107
Last Changed Date: 2008-03-22 15:11:46 +0000 (Sat, 22 Mar 2008)
MLT++ SVN version:
Revision: 1107
Last Changed Date: 2008-02-27 18:25:58 +0000 (Wed, 27 Feb 2008)
Kdenlive SVN version:
Revision: 2155
Last Changed Date: 2008-02-24 14:08:13 +0000 (Sun, 24 Feb 2008)
TagsNo tags attached.
Build/Install Method
Attached Files

- Relationships

-  Notes
(0000181)
Espinosa (reporter)
2008-04-13 00:42

OK, there is a workaround simply link ffmpeg header files back to a former structure. Now MLT and Kdelive builds again for me.

I use this batch (part of a new kdenlive_build script):

# Simulate older ffmpeg header files
# Bash custom procedure
function ffmpeg_headers_hack1 {
    mkdir $DEST_DIR/include/ffmpeg
    cd $DEST_DIR/include/ffmpeg
    ln -sf ../libavformat/* .
    ln -sf ../libavcodec/* .
    ln -sf ../libavdevice/* .
    ln -sf ../libavutil/* .
    ln -sf ../libpostproc/* .
    ln -sf ../libswscale/* .
    cd -
}

# Simulate older ffmpeg header files
# Bash custom procedure
function ffmpeg_headers_hack2 {
    cd $DEST_DIR/include
    ln -sf libavformat/* .
    ln -sf libavcodec/* .
    ln -sf libavdevice/* .
    ln -sf libavutil/* .
    ln -sf libpostproc/* .
    ln -sf libswscale/* .
    cd -
}

To maintainer:
As there is a workaround you can decrease severity level to minor.
(0000189)
Espinosa (reporter)
2008-05-16 20:47
edited on: 2008-05-16 20:48

Probably a duplicate of 0000079

(0000192)
lyon (reporter)
2008-06-08 11:25

I can confirm this. I'm using 2008/05/31 ffpmeg version and the structure is as stated above.

- Issue History
Date Modified Username Field Change
2008-04-04 04:00 Espinosa New Issue
2008-04-13 00:42 Espinosa Note Added: 0000181
2008-05-16 20:47 Espinosa Note Added: 0000189
2008-05-16 20:48 Espinosa Note Edited: 0000189
2008-06-08 11:25 lyon Note Added: 0000192
2008-09-04 17:34 administrator Status new => resolved
2008-09-04 17:34 administrator Resolution open => fixed
2008-10-23 00:22 madsdyd Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker