Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001120KdenliveTransitionspublic2009-09-07 09:502010-02-02 10:38
Reportermax_e 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.6 
Summary0001120: latest SVN crashes when timeline cursor is over composite transition
DescriptionI uploaded the clip I'm using, which was created a while ago with gtk-recordmydesktop. Sorry it's a big file, compressed from 145.5 mb down to 78.8 mb using 7zip.
http://www.4shared.com/file/130800614/bbb9b837/outogv.html [^]

I also uploaded the project file I'm using.
http://www.4shared.com/file/130801115/714df941/rndvid1.html [^]

I don't know if it matters, but the video clip on my system is in /home/maxtothemax/vids/out.ogv and the project file is in /home/maxtothemax/school/sci/rndvid1.kdenlive

Steps to reproduce: Load up the project with the clip. Drag the timeline cursor over the transition effect (located approximately two minutes into the project) and it will instantly crash with 100% reliability (as far as I can tell after about a half-hour of trying it over and over.)

Sometimes a popup notification with a report but option shows up, but almost never does this happen. Here is the crash information from one of these rare incidences.
http://pastebin.com/m5ac1bbef [^]

The CLI output varies, so here are a bunch of samples. The last one was the one where the notification popped up.
http://pastebin.com/m7a13c148 [^]

====BACKSTORY=====

With the 0.7.5 version from the repos, it would constantly crash whenever I tried to remove a third track which I had added earlier (plus any transition that had anything to do with transparency, color to alpha, or fading was a complete no-op, didn't do anything.) So I decided to try installing MLT and Kdenlive from git/svn to see if that issue had been resolved. I followed the directions from this page:
http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive [^]

The only non-standard thing I did was copy swscale.h from /usr/include/swscale (or something like that) into /usr/include, otherwise MLT wouldn't compile. But after that it compiled just fine. I don't know if that's relevant or not.

I also stuck with the Debian-Multimedia version of FFMPEG, because the page with directions on it praised the Debian-Multimedia version of the package.

Otherwise I did everything according to the directions, installing all dependencies until I was able to compile with the suggested configure options.

I was at least able to successfully remove that third track, so that's no longer a problem. But now this new error pops up (with very similar CLI output to the old crash with the third track.)





I will provide any other info needed, I will gladly try any potential workarounds, etc. I do need to get this project done ASAP, it's for school. I don't mean to trouble everyone else with my personal problems, I'm just putting that out there. :)
Additional InformationOS is Debian GNU/Linux Sid/Squeeze w/ experimental repos and Debian multimedia repos, all relevant packages up-to-date.

Kernel is a custom compile from the kernel.org sources, 2.6.31-rc5, SMP, Preempt-able core2-optimized kernel with V4L2 and V4L1 compatibility layer. I can provide the kernel .config if needed but I don't think that would be the problem.



VERSIONS:
Kdenlive is latest SVN as of a half hour or so ago
MLT is latest git as of about 45 min ago
FFMPEG is latest from Debian-Multimedia repos.
QT4 is 4:4.5.2-2
KDELIBS is 4:4.3.1-1
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0003868)
j-b-m (administrator)
2009-09-07 18:22

Ok, I can reproduce the crash. The reason is that in your composite transition, you use a luma file that is not present on my system:

/usr/share/mlt/lumas/PALluma18.pgm.png

Looks like something is wrong in Kdenlive because the luma path should probably be:

/usr/share/mlt/lumas/PAL/luma18.pgm

Can you open your project file in a text editor and replace the broken path with the correct one (line 102)? I will investigate to see if I find a reason why that path was corrupted.

(0003870)
max_e (reporter)
2009-09-07 20:59

I actually didn't need to use a text editor. I could still select the transition without putting the timeline cursor over it, so it wouldn't try to render anything in the project monitor. I was able to select "none" for the wipe file field, and return the "with track" field to "1."


So now it doesn't crash. Also, the composite effect no longer does absolutely nothing (see screenshot.)
http://img40.imageshack.us/img40/2208/wierdcorruption.png [^]
Same results if I do or don't select a wipe file. And when I render the project, there's still no effect at all.

Still that's an entirely separate bug. Should I open a different report on it?





Also, I may have a hint for you in your investigation of how the weird filename got there.


I remember back when I was trying to use 0.7.5 (earlier yesterday,) and the composite effect was simply not working at all, one of the things I tried was selecting one of the luma effects that didn't have a thumbnail. There were a few luma effects that did have thumbnails, and then about the same number which didn't have thumbnails, right below it. Maybe those ones were corrupt? (BTW those ones missing the thumbnails are gone in the SVN I have, I checked.)
(0003871)
j-b-m (administrator)
2009-09-07 23:04

I just added a check in svn so that when opening a document, Kdenlive verifies that all luma files are present, or a dialog will popup.

Now, there seems to be a bug when using transitions over clips with speed effect. That is probably a bug in MLT's frambuffer producer, which creates the slowmotion effect. I will try to take a look in the next days...
(0003878)
max_e (reporter)
2009-09-08 10:46

Updated to include your fix, no longer have the screwed up project file and cannot be bothered to download it again. I'm taking your word for it that the check for missing lumas works.

BTW I can confirm that the dissolve effect works just fine at normal speed. So I figured out the workaround of speeding up the clip, exporting a video, then using THAT with the transition. Seems to work okay.

Seems that a lot of the kinks with kdenlive are due to me using the speed feature to go faster. I gather the original intent was for slow-motion, I'm using it here for time-lapse, so maybe my usage is not typical. Anyway, as soon as I have this project done I will have at least one more bug report to file, (involving the first entire minute of rendered video during a specific clip exporting as pure white for some reason.) But I'm busy now.
(0003912)
ddennedy (developer)
2009-09-16 07:59

The bug in MLT framebuffer when using a composite transition has been fixed in its git tree.

- Issue History
Date Modified Username Field Change
2009-09-07 09:50 max_e New Issue
2009-09-07 09:50 max_e Build/Install Method => Manual build from SVN
2009-09-07 18:22 j-b-m Note Added: 0003868
2009-09-07 18:22 j-b-m Assigned To => j-b-m
2009-09-07 18:22 j-b-m Status new => acknowledged
2009-09-07 20:59 max_e Note Added: 0003870
2009-09-07 23:04 j-b-m Note Added: 0003871
2009-09-08 10:46 max_e Note Added: 0003878
2009-09-16 07:59 ddennedy Note Added: 0003912
2009-09-16 07:59 ddennedy Status acknowledged => resolved
2009-09-16 07:59 ddennedy Fixed in Version => Recent git
2009-09-16 07:59 ddennedy Resolution open => fixed
2009-10-08 20:20 j-b-m Fixed in Version Recent git => 0.7.6
2010-02-02 10:35 j-b-m Fixed in Version 0.7.6 => 0.7.7
2010-02-02 10:37 j-b-m Fixed in Version 0.7.7 => 0.7.6
2010-02-02 10:38 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker