Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001133KdenliveUser Interfacepublic2009-09-14 22:562011-11-01 18:56
Reporterreinhard 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platform32 bit intel and alikeOSUbuntu LinuxOS Version9.04
Product VersionRecent git 
Target VersionFixed in Version0.8.2 
Summary0001133: check if xine-ui is installed
DescriptionHi,

in the rendering dialog we have the option to enable "play after render", but it fails for me just saying xine is needed for playback.

I figured out that I have to install "xine-ui", but maybe it would be better to integrate this check into the "config wizard", because other users might have problems to find out what package exactly needs to be installed...

greetings
reinhard
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files

- Relationships

-  Notes
(0003909)
ddennedy (developer)
2009-09-16 07:49

The only thing in Kdenlive that uses xine is the DVD Wizard. If you were not using the DVD Wizard but instead the Render dialog, then check your Settings > Environment > Default Apps > Video player. If you put xine in there, then this is not a bug in kdenlive.
(0003939)
reinhard (reporter)
2009-09-16 23:22

Oh man, I don't know what's going on that evening, but what I meant was the Preview-button in the DVD wizard, where xine seems to be used for playback as the default player - SORRY!!!!

So, this is really not a bug, right, but it still might be good to check in the config wizard if xine is installed?!?
(0003941)
ddennedy (developer)
2009-09-16 23:34

Kdenlive does not know that your distribution requires a xine-ui package, and adding distribution-oriented intelligence to Kdenlive is non maintainable. Kdenlive's DVD Wizard Preview already shows the error "You need program xine to perform this action" if the execution fails. Perhaps you should verify that your distribution strongly recommends a xine frontend package when you install libxine, xine-backend, or whatever.

But, yeah, I suppose for consistency, it ought to be added to the config wizard where it checks for other runtime dependencies. It still will not be able to recommend an exact package though.
(0003961)
reinhard (reporter)
2009-09-19 00:48

ok, I think integrating this check into the config wizard should be sufficient to give the user a hint what to do...

thanks in advance
(0006233)
Granjow (developer)
2010-12-26 10:50

The config wizard does not check for xine yet, right?
Should we do that @jb?
(0006242)
j-b-m (administrator)
2010-12-26 13:01

Done

- Issue History
Date Modified Username Field Change
2009-09-14 22:56 reinhard New Issue
2009-09-14 22:56 reinhard Build/Install Method => Build Wizard
2009-09-16 07:49 ddennedy Note Added: 0003909
2009-09-16 07:49 ddennedy Status new => feedback
2009-09-16 23:22 reinhard Note Added: 0003939
2009-09-16 23:34 ddennedy Note Added: 0003941
2009-09-19 00:48 reinhard Note Added: 0003961
2010-12-26 10:50 Granjow Note Added: 0006233
2010-12-26 13:01 j-b-m Note Added: 0006242
2010-12-26 13:01 j-b-m Status feedback => resolved
2010-12-26 13:01 j-b-m Resolution open => fixed
2010-12-26 13:01 j-b-m Assigned To => j-b-m
2011-07-05 12:15 j-b-m Fixed in Version => 0.8.2
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker