Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001146KdenliveUser Interfacepublic2009-09-17 00:142010-02-02 10:38
Reporterneoarttec 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityrandom
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.6 
Summary0001146: Crash on move Group
DescriptionAdd clips to group.

Move group, Kdenlive crahes.
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Filestxt file icon kdenlive-20090916.kcrash.txt [^] (6,942 bytes) 2009-09-17 00:14 [Show Content]

- Relationships

-  Notes
(0003946)
j-b-m (administrator)
2009-09-17 01:08

Cannot reproduce. The backtrace seems to indicate that there was a transition in your project...

Could you please try to find the exact steps to reproduce the crash when starting with a blank project?

I really want to fix those group move issues...
(0003965)
neoarttec (reporter)
2009-09-20 00:48

Yes, transitions were problematic with the group move. They do not move with their associated clips. I had to individually select each transition and add them to the group.

Secondly after I did manage to move the group ( on with many clips) it had spewed a trail of transition copies along the time line.

I will make a test from a blank project and attempt to reproduce the issue while noting the steps I took.
(0004027)
j-b-m (administrator)
2009-09-28 12:05

I made several changes to group move recently. Could you please try and tell me if you are still having issues ? Would be great to have feedback in the next days since we are preparing for 0.7.6 release...

regards
(0004037)
neoarttec (reporter)
2009-09-29 00:40

That appears to be a fix.
(0004038)
neoarttec (reporter)
2009-09-29 00:40

However, some general feed back on selecting for groups. Selecting clips seems to be finicky, it is not easy to slelect many clips. For a large project where many clips have to be moved, this is very laborious. Perhaps a new tool is needed to select multiple clips.

Also, transitions must be individually selected. But the hotspot for selection is can be difficult, sometimes resulting in all previous multiple selections being lost.

It would be nice if there was some sort of option to automatically include transitions in a selection or group.
(0004040)
j-b-m (administrator)
2009-09-29 09:46

Hmm, I don't understand. To select several clips, you can Shift + click and draw a rectangle around your clips. After that, using Shift + Ctrl + click allows you to create another rectangle of selection that will be added to the group. In these cases, the transitions included in the rectangle are also selected...

Can you please describe more precisely how to reproduce the problem?
(0004041)
neoarttec (reporter)
2009-09-29 14:55

Indeed it does. Shift + click.

Thanks for that j-b-m.

Although... it would be nice if the timeline scrolled automatically left or right as the selection approaches the edge of the left or right visible area.


But as I said, the original bug I reported appears to be fixed.

- Issue History
Date Modified Username Field Change
2009-09-17 00:14 neoarttec New Issue
2009-09-17 00:14 neoarttec File Added: kdenlive-20090916.kcrash.txt
2009-09-17 00:14 neoarttec Build/Install Method => Build Wizard
2009-09-17 01:08 j-b-m Note Added: 0003946
2009-09-17 01:08 j-b-m Status new => feedback
2009-09-20 00:48 neoarttec Note Added: 0003965
2009-09-28 12:05 j-b-m Note Added: 0004027
2009-09-29 00:40 neoarttec Note Added: 0004037
2009-09-29 00:40 neoarttec Note Added: 0004038
2009-09-29 09:46 j-b-m Note Added: 0004040
2009-09-29 14:55 neoarttec Note Added: 0004041
2009-10-05 19:22 j-b-m Status feedback => resolved
2009-10-05 19:22 j-b-m Fixed in Version => Recent git
2009-10-05 19:22 j-b-m Resolution open => fixed
2009-10-05 19:22 j-b-m Assigned To => j-b-m
2009-10-08 20:20 j-b-m Fixed in Version Recent git => 0.7.6
2010-02-02 10:35 j-b-m Fixed in Version 0.7.6 => 0.7.7
2010-02-02 10:37 j-b-m Fixed in Version 0.7.7 => 0.7.6
2010-02-02 10:38 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker