Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001156KdenliveFile Loadingpublic2009-09-22 15:382010-02-02 10:38
Reporterberteh 
Assigned Toj-b-m 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSOS Version
Product Version0.7.5 
Target VersionFixed in Version0.7.6 
Summary0001156: transparent background of (png slideshow) clip is not preserved
DescriptionWhen importing a series of png images with transparent background as a slideshow clip, the background renders as black... not displaying the underlying clip.


Importing a single png image with transparency as a clip keeps the transparency information if you tick the box "transparent background"... however there is no such box in 0.7.5 for slideshow clips.


This bug is major as png slideshow is a main pivot format between kdenlive and any other video production software, especially due to its handling transparency.

I'd suggest to make the transparency handling a default for any image with transparency... anyone can easily add a colored background by adding a colored clip below the transparent one.
Additional InformationI installed kdenlive 0.7.5 on KUbuntu 9.04 using repository htps://edge.launchpad.net/~sunab/+archive/ppa [^]

BlueScreen effect is not useable as a workaround (i.e. filtering black color does not make the background transparent), maybe because the real background of the images is transparent and not black.

Transparent effect seems to have no effect either.


to reproduce:
1. download attached png files with transparent background
2. import these neige.%o4d.png into kde as a single slideshow clip (called "neige")
3. add the "neige" clip on top channel
4. add a single colored clip (eg: red) on channel 2
5. preview: falling snow is shown on black background, and not red as expected.

TagsNo tags attached.
Build/Install Method3rd party package
Attached Filesgz file icon neige.tar.gz [^] (13,105 bytes) 2009-09-22 15:38
jpeg file icon snow.jpeg [^] (51,143 bytes) 2009-09-22 18:25

- Relationships

-  Notes
(0003974)
j-b-m (administrator)
2009-09-22 18:27

To see transparency, you must add a composite transition between the slideshow and the background clip. Since your slideshow is not scaled for a PAL size, you may need to check the "Fill" option in the transition settings to have the slideshow in fullscreen, see my attached screenshot.

- Issue History
Date Modified Username Field Change
2009-09-22 15:38 berteh New Issue
2009-09-22 15:38 berteh File Added: neige.tar.gz
2009-09-22 15:38 berteh Build/Install Method => 3rd party package
2009-09-22 18:25 j-b-m File Added: snow.jpeg
2009-09-22 18:27 j-b-m Note Added: 0003974
2009-09-22 18:27 j-b-m Status new => resolved
2009-09-22 18:27 j-b-m Resolution open => no change required
2009-09-22 18:27 j-b-m Assigned To => j-b-m
2009-10-08 20:21 j-b-m Fixed in Version => 0.7.6
2010-02-02 10:35 j-b-m Fixed in Version 0.7.6 => 0.7.7
2010-02-02 10:37 j-b-m Fixed in Version 0.7.7 => 0.7.6
2010-02-02 10:38 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker