Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001172KdenliveTransitionspublic2009-10-01 12:282010-02-02 10:38
Reporterstreumix 
Assigned Toddennedy 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionunable to reproduce 
PlatformOSOS Version
Product Version0.7.5 
Target VersionFixed in Version0.7.6 
Summary0001172: Composite transition ignors effect stack regarding zoom/size
DescriptionWhen "pre-scaling" a track with the pan/zoom effect, a composite transition doesn't pay respect to this resize operation. It resets the track to 100%.
(and it gets even worse when working with non-PAL resolution in 0.7.5: 100% alligns with 720x576, no matter if working on a 720p project or not ! But this will be covered by a different bug report)

Additional InformationI've attached screenshots to demonstrate the issue.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Fileszip file icon composite_ignores_zoom_screenshots.zip [^] (608,600 bytes) 2009-10-01 12:28
jpg file icon Herrenhof_Mussbach_Pano1_geschnitten.MidRes-720.jpg [^] (1,186,298 bytes) 2009-10-05 17:05

- Relationships

-  Notes
(0004067)
neoarttec (reporter)
2009-10-05 17:05

I have the same problem. Composite completely ignores the resize. I have the latest SVN built with the builder.

I have a panorama image I want to scroll. I add it to the timeline. Add composite transition. Resize to "Original Size" which is 2849 x 720.

I then add the second keyframe, and align to right. Now the time line in the composite transition window will show the red box panning, however the main timeline only shows the image scaled down to fit into the video frame. No panning image on the main timeline. When rendered, there is also still no panning image.

I also noted the following:

The first keyframe has added 1 pixel to the height and width. 2850 x 721.
The second keyframe adds a random number of pixels to the height and width, 2 - 4 extra pixes. eg: 2853 x 722.

I am attaching the panorama image I am using.

Herrenhof_Mussbach_Pano1_geschnitten.MidRes-720.jpg
(0004122)
ddennedy (developer)
2009-10-12 02:34

I can confirm that the current design does not allow this.
(0004131)
neoarttec (reporter)
2009-10-12 13:12

I found a work around:

http://www.kdenlive.org/tutorial/kdenlive-creating-video-panorama#comment-3704 [^]

Setting the transition with track "black" will actually force the composite transition to behave correctly. However this is not mentioned any any documentation or the example video. The example video is evidence that earlier versions of Kdenlive could handle this transition correctly.
(0004214)
ddennedy (developer)
2009-10-27 05:59

I was a hasty in my claim "I can confirm that the current design does not allow this." I think I was going through new bugs quickly and misunderstood. I am trying to reproduce the original poster's problem as shown in his screenshots. It is working as expected - at least in 0.7.6. When compositing with images of various aspect ratios as is common with digital photos, the compositor scales the image on top to fit within the compositing rectangle, but it must also respect its aspect ratio. This means it takes the image after pan&zoom and resizes it to fit within. This might be somewhat unexpected, but if you enable the Distort option in the Composite panel, then I think you get what you are expecting. You might also try to use the Crop effect instead of the Pan & Zoom without enabling Distort in Composite.

Note that this comment does not apply to the use case of panning over a panorama. I have to analyze that after this to see if it really the same "bug."
(0004215)
ddennedy (developer)
2009-10-27 06:14

neoarttec, your panorama problem is different and currently the expected behaviour:
http://www.kdenlive.org/tutorial/kdenlive-creating-video-panorama#comment-5574 [^]

- Issue History
Date Modified Username Field Change
2009-10-01 12:28 streumix New Issue
2009-10-01 12:28 streumix File Added: composite_ignores_zoom_screenshots.zip
2009-10-01 12:28 streumix Build/Install Method => Distribution package
2009-10-05 17:05 neoarttec File Added: Herrenhof_Mussbach_Pano1_geschnitten.MidRes-720.jpg
2009-10-05 17:05 neoarttec Note Added: 0004067
2009-10-12 02:33 ddennedy Status new => assigned
2009-10-12 02:33 ddennedy Assigned To => ddennedy
2009-10-12 02:34 ddennedy Note Added: 0004122
2009-10-12 02:34 ddennedy Status assigned => acknowledged
2009-10-12 13:12 neoarttec Note Added: 0004131
2009-10-27 05:59 ddennedy Note Added: 0004214
2009-10-27 05:59 ddennedy Status acknowledged => feedback
2009-10-27 06:14 ddennedy Note Added: 0004215
2009-10-27 06:14 ddennedy Status feedback => resolved
2009-10-27 06:14 ddennedy Resolution open => unable to reproduce
2010-02-02 10:34 j-b-m Fixed in Version => 0.7.7
2010-02-02 10:37 j-b-m Fixed in Version 0.7.7 => 0.7.6
2010-02-02 10:38 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker