Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001191KdenliveUser Interfacepublic2009-10-06 22:232010-02-02 10:38
Reporterreinhard 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platform32 bit intel and alikeOSUbuntu LinuxOS Version9.04
Product VersionRecent git 
Target VersionFixed in Version0.7.6 
Summary0001191: Can't delete clip(s) and crash when undo
DescriptionHi,

I've made a test project where:

- the first clip fading in from black
- then comes a clip with speed effect
- followed by a clip that freeze the last picture of the previous one

finally I've added a title clip above the freezed clip that should crawl in from the buttom to center, but this don't work and instead I've got crazy side effects that I really can't describe well, sorry, and a crash happened...

Now, as I've restarted kdenlive and reloaded the project, I cannot delete clip(s), but applied effects and kdenlive crash when undo this effect deletion.

This is not an important project, but maybe it can help you to find the reason for the crash, or a hidden bug causing this...

Attached is the error log and the project file.

greetings

TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Filestxt file icon kbw.gdb.output.SNfySTNx.txt [^] (47,980 bytes) 2009-10-06 22:23 [Show Content]
? file icon klettern169.kdenlive [^] (11,700 bytes) 2009-10-06 22:24
png file icon titleonfreeze.png [^] (210,488 bytes) 2009-10-06 22:47

- Relationships

-  Notes
(0004079)
reinhard (reporter)
2009-10-06 22:47

I was able to capture the screen to show you what happen when I try to animate the text over the freeze. The title (test) is printed several times during his movement...
(0004080)
j-b-m (administrator)
2009-10-07 16:41

Ok, your project file is corrupted, you can see the following line:

<property name="video_index" >xx���� </property>

The "video_index" value should be an integer. I think I found the problem in Kdenlive and will commit soon. In the meantime, you can simply edit your file and replace the above line with:

<property name="video_index" >0</property>
(0004083)
reinhard (reporter)
2009-10-07 22:02

this works, thanks!

- Issue History
Date Modified Username Field Change
2009-10-06 22:23 reinhard New Issue
2009-10-06 22:23 reinhard File Added: kbw.gdb.output.SNfySTNx.txt
2009-10-06 22:23 reinhard Build/Install Method => Build Wizard
2009-10-06 22:24 reinhard File Added: klettern169.kdenlive
2009-10-06 22:47 reinhard Note Added: 0004079
2009-10-06 22:47 reinhard File Added: titleonfreeze.png
2009-10-07 16:41 j-b-m Note Added: 0004080
2009-10-07 16:41 j-b-m Status new => feedback
2009-10-07 22:02 reinhard Note Added: 0004083
2009-10-08 15:46 j-b-m Status feedback => resolved
2009-10-08 15:46 j-b-m Fixed in Version => Recent git
2009-10-08 15:46 j-b-m Resolution open => fixed
2009-10-08 15:46 j-b-m Assigned To => j-b-m
2009-10-08 20:20 j-b-m Fixed in Version Recent git => 0.7.6
2010-02-02 10:35 j-b-m Fixed in Version 0.7.6 => 0.7.7
2010-02-02 10:37 j-b-m Fixed in Version 0.7.7 => 0.7.6
2010-02-02 10:38 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker