Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001198KdenliveUser Interfacepublic2009-10-10 19:242010-02-20 08:16
Reporterleandroferra 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionno change required 
Platform64 bitOSUbuntu LinuxOS Version9.04
Product Version0.7.6 
Target VersionFixed in Version 
Summary0001198: What I was doing when the application crashed
Descriptionwhen i click whith the rigth button and select title template the program chashed
Additional InformationApplication: Kdenlive (kdenlive), signal: Aborted
[Current thread is 0 (LWP 29505)]

Thread 4 (Thread 0x7f7fa09f6950 (LWP 29992)):
#0 pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:217
#1 0x00007f7fc2b2d943 in mlt_consumer_get_frame () from /usr/lib/libmlt.so.2
0000002 0x00007f7fc2b2dbb5 in mlt_consumer_rt_frame () from /usr/lib/libmlt.so.2
0000003 0x00007f7fab22e7a4 in ?? () from /usr/lib/mlt/libmltsdl.so
0000004 0x00007f7fbe7343ba in start_thread (arg=<value optimized out>) at pthread_create.c:297
0000005 0x00007f7fbec32fcd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
0000006 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f7f9bfff950 (LWP 29993)):
#0 pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1 0x00007f7fab22df2b in ?? () from /usr/lib/mlt/libmltsdl.so
0000002 0x00007f7fbe7343ba in start_thread (arg=<value optimized out>) at pthread_create.c:297
0000003 0x00007f7fbec32fcd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
0000004 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f7f9b5c9950 (LWP 32409)):
#0 0x00007f7fbec24fcb in write () from /lib/libc.so.6
#1 0x00007f7fbebc084a in _IO_new_file_write (f=0x7f7fbeeb9860, data=0x7f7f9b5c6650, n=54) at fileops.c:1268
0000002 0x00007f7fbebc06f9 in _IO_new_file_xsputn (f=0x7f7fbeeb9860, data=0x7f7f9b5c6650, n=54) at fileops.c:522
0000003 0x00007f7fbeb9798a in buffered_vfprintf (s=0x7f7fbeeb9860, format=<value optimized out>, args=<value optimized out>) at vfprintf.c:2209
0000004 0x00007f7fbeb92d16 in _IO_vfprintf_internal (s=0x7f7fbeeb9860, format=0x651980 "Failed to read event from Jog Shuttle FILE DESCRIPTOR\n", ap=0x7f7f9b5c8f00) at vfprintf.c:1288
0000005 0x00007f7fbec49ad2 in ___fprintf_chk (fp=0x7f7fbeeb9860, flag=1, format=0xa524f5450495243 <Address 0xa524f5450495243 out of bounds>) at fprintf_chk.c:37
0000006 0x0000000000443451 in ShuttleThread::run (this=0x100e610) at /usr/include/bits/stdio2.h:99
0000007 0x00007f7fc04fbd35 in QThreadPrivate::start (arg=0x100e610) at thread/qthread_unix.cpp:188
0000008 0x00007f7fbe7343ba in start_thread (arg=<value optimized out>) at pthread_create.c:297
0000009 0x00007f7fbec32fcd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
0000010 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f7fc2f14750 (LWP 29505)):
[KCrash Handler]
0000005 0x00007f7fbeb7ffb5 in *__GI_raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
0000006 0x00007f7fbeb81bc3 in *__GI_abort () at abort.c:88
0000007 0x00007f7fc04f3da5 in qt_message_output (msgType=QtFatalMsg, buf=<value optimized out>) at global/qglobal.cpp:2042
0000008 0x00007f7fc04f3eeb in qFatal (msg=<value optimized out>) at global/qglobal.cpp:2241
0000009 0x00007f7fbe4a32f0 in Soprano::FilterModel::listStatements () from /usr/lib/libsoprano.so.4
0000010 0x00007f7fc26b3dc6 in Nepomuk::ResourceData::load (this=0x29735a0) at /build/buildd/kde4libs-4.3.2/nepomuk/core/resourcedata.cpp:362
0000011 0x00007f7fc26b4528 in Nepomuk::ResourceData::property (this=0x29735a0, uri=@0x7fffcaf545c0) at /build/buildd/kde4libs-4.3.2/nepomuk/core/resourcedata.cpp:230
0000012 0x00007f7fc26cbe42 in Nepomuk::Resource::property (this=<value optimized out>, uri=@0x6) at /build/buildd/kde4libs-4.3.2/nepomuk/core/resource.cpp:269
0000013 0x00007f7fc26cdaf9 in Nepomuk::Resource::description (this=0x7fffcaf54690) at /build/buildd/kde4libs-4.3.2/nepomuk/core/resource.cpp:487
0000014 0x000000000046bad3 in ProjectList::slotAddClip (this=0x108c5d0, clip=0x291c9f0, getProperties=true) at /build/buildd/kdenlive-0.7.6/src/projectlist.cpp:576
0000015 0x0000000000471813 in ProjectList::qt_metacall (this=0x108c5d0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffcaf54ae0)
    at /build/buildd/kdenlive-0.7.6/obj-x86_64-linux-gnu/src/cmake_bindir/projectlist.moc:172
0000016 0x00007f7fc05faea2 in QMetaObject::activate (sender=0x2591e10, from_signal_index=<value optimized out>, to_signal_index=6, argv=0xffffffffffffffff) at kernel/qobject.cpp:3113
0000017 0x000000000049e213 in KdenliveDoc::addProjectClip (this=0x7341, _t1=0x291c9f0, _t2=true) at /build/buildd/kdenlive-0.7.6/obj-x86_64-linux-gnu/src/cmake_bindir/kdenlivedoc.moc:142
0000018 0x00000000004a42d0 in KdenliveDoc::addClip (this=0x2591e10, elem={<QDomNode> = {impl = 0x7fffcaf55280}, <No data fields>}, clipId=
      {static null = {<No data fields>}, static shared_null = {ref = {_q_value = 27757}, alloc = 0, size = 0, data = 0x899c1a, clean = 0, simpletext = 0, righttoleft = 0, asciiCache = 0, capacity = 0, reserved = 0, array = {0}}, static shared_empty = {ref = {_q_value = 107}, alloc = 0, size = 0, data = 0x7f7fc08d885a, clean = 0, simpletext = 0, righttoleft = 0, asciiCache = 0, capacity = 0, reserved = 0, array = {0}}, d = 0x7fffcaf55270, static codecForCStrings = 0x0}, createClipItem=true) at /build/buildd/kdenlive-0.7.6/src/kdenlivedoc.cpp:919
0000019 0x0000000000443b59 in AddClipCommand::redo (this=0x2916540) at /build/buildd/kdenlive-0.7.6/src/addclipcommand.cpp:49
0000020 0x00007f7fbfe24eb8 in QUndoStack::push (this=0x250bac0, cmd=0x2916540) at util/qundostack.cpp:543
0000021 0x0000000000526fd1 in ClipManager::slotAddTextTemplateClip (this=0x2592050, titleName=<value optimized out>, path={<QUrl> = {d = 0x7fffcaf55580}, d = 0x7f7fc08d6050},
    group=<value optimized out>, groupId=@0x1dcb610) at /build/buildd/kdenlive-0.7.6/src/clipmanager.cpp:438
0000022 0x00000000004a620e in KdenliveDoc::slotCreateTextTemplateClip (this=0x2591e10, group=
      {static null = {<No data fields>}, static shared_null = {ref = {_q_value = 27757}, alloc = 0, size = 0, data = 0x899c1a, clean = 0, simpletext = 0, righttoleft = 0, asciiCache = 0, capacity = 0, reserved = 0, array = {0}}, static shared_empty = {ref = {_q_value = 107}, alloc = 0, size = 0, data = 0x7f7fc08d885a, clean = 0, simpletext = 0, righttoleft = 0, asciiCache = 0, capacity = 0, reserved = 0, array = {0}}, d = 0x7fffcaf55780, static codecForCStrings = 0x0}, groupId=@0x1dcb610, path={<QUrl> = {d = 0x7fffcaf55710}, d = 0x7fffcaf55570})
    at /build/buildd/kdenlive-0.7.6/src/kdenlivedoc.cpp:1093
0000023 0x000000000046cf48 in ProjectList::slotAddTitleTemplateClip (this=0x108c5d0) at /build/buildd/kdenlive-0.7.6/src/projectlist.cpp:781
0000024 0x000000000047148d in ProjectList::qt_metacall (this=0x108c5d0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fffcaf55af0)
    at /build/buildd/kdenlive-0.7.6/obj-x86_64-linux-gnu/src/cmake_bindir/projectlist.moc:198
0000025 0x00007f7fc05faea2 in QMetaObject::activate (sender=0x1f92420, from_signal_index=<value optimized out>, to_signal_index=6, argv=0xffffffffffffffff) at kernel/qobject.cpp:3113
0000026 0x00007f7fbf803f37 in QAction::triggered (this=0x7341, _t1=false) at .moc/release-shared/moc_qaction.cpp:236
0000027 0x00007f7fbf8053b0 in QAction::activate (this=0x1f92420, event=<value optimized out>) at kernel/qaction.cpp:1160
0000028 0x00007f7fbfc0c52d in QMenuPrivate::activateCausedStack (this=0x1f984f0, causedStack=@0x7fffcaf55c10, action=0x1f92420, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:967
0000029 0x00007f7fbfc1253e in QMenuPrivate::activateAction (this=0x1f984f0, action=0x1f92420, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1060
0000030 0x00007f7fbf85b0bf in QWidget::event (this=0x125c620, event=0x7fffcaf56420) at kernel/qwidget.cpp:7549
0000031 0x00007f7fbfc14d8b in QMenu::event (this=0x125c620, e=0x7fffcaf56420) at widgets/qmenu.cpp:2353
0000032 0x00007f7fbf809f4d in QApplicationPrivate::notify_helper (this=0x8f6140, receiver=0x125c620, e=0x7fffcaf56420) at kernel/qapplication.cpp:4056
0000033 0x00007f7fbf8128ea in QApplication::notify (this=<value optimized out>, receiver=0x125c620, e=0x7fffcaf56420) at kernel/qapplication.cpp:3758
0000034 0x00007f7fc228eabb in KApplication::notify (this=0x7fffcaf58360, receiver=0x125c620, event=0x7fffcaf56420) at /build/buildd/kde4libs-4.3.2/kdeui/kernel/kapplication.cpp:302
0000035 0x00007f7fc05e56ac in QCoreApplication::notifyInternal (this=0x7fffcaf58360, receiver=0x125c620, event=0x7fffcaf56420) at kernel/qcoreapplication.cpp:610
0000036 0x00007f7fbf811b38 in QApplicationPrivate::sendMouseEvent (receiver=0x125c620, event=0x7fffcaf56420, alienWidget=0x0, nativeWidget=0x125c620, buttonDown=<value optimized out>,
    lastMouseReceiver=@0x7f7fc0241010) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
0000037 0x00007f7fbf87bcd4 in QETWidget::translateMouseEvent (this=0x125c620, event=<value optimized out>) at kernel/qapplication_x11.cpp:4343
0000038 0x00007f7fbf87ab53 in QApplication::x11ProcessEvent (this=0x7fffcaf58360, event=0x7fffcaf57fa0) at kernel/qapplication_x11.cpp:3550
0000039 0x00007f7fbf8a3454 in x11EventSourceDispatch (s=0x8f9e20, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
0000040 0x00007f7fba87120a in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
0000041 0x00007f7fba8748e0 in ?? () from /usr/lib/libglib-2.0.so.0
0000042 0x00007f7fba874a7c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
0000043 0x00007f7fc060ea8f in QEventDispatcherGlib::processEvents (this=0x8dbf40, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
0000044 0x00007f7fbf8a2bdf in QGuiEventDispatcherGlib::processEvents (this=0x7341, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
0000045 0x00007f7fc05e3f42 in QEventLoop::processEvents (this=<value optimized out>, flags={i = -889879920}) at kernel/qeventloop.cpp:149
0000046 0x00007f7fc05e4314 in QEventLoop::exec (this=0x7fffcaf582d0, flags={i = -889879840}) at kernel/qeventloop.cpp:201
0000047 0x00007f7fc05e65e4 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
0000048 0x0000000000444a85 in main (argc=4, argv=0x7fffcaf588b8) at /build/buildd/kdenlive-0.7.6/src/main.cpp:86
TagsNo tags attached.
Build/Install Method3rd party package
Attached Files

- Relationships
duplicate of 0001337closedj-b-m Crash when adding mp4 clip to project 

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2009-10-10 19:24 leandroferra New Issue
2009-10-10 19:24 leandroferra Build/Install Method => 3rd party package
2009-12-12 23:01 j-b-m Relationship added duplicate of 0001337
2010-02-16 08:04 j-b-m Status new => resolved
2010-02-16 08:04 j-b-m Resolution open => no change required
2010-02-16 08:04 j-b-m Assigned To => j-b-m
2010-02-16 08:04 j-b-m Relationship added has duplicate 0001446
2010-02-20 08:16 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker