Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001210KdenliveMLTpublic2009-10-13 04:252010-02-20 08:16
Reportergsking1 
Assigned Toddennedy 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionno change required 
Platform32 bit intel and alikeOSKubuntu LinuxOS VersionKubuntu 9.10
Product Version0.7.6 
Target VersionFixed in Version0.7.7 
Summary0001210: m2t clips are crashing kdenlive melt and ffplay
DescriptionMany clips from from my HV30 are crashing ffplay/melt/kdenlive. Mplayer can usually play them okay. I don't know if something is wrong with these or what? Some play better than others. The first clip is below as an example and is especially bad.

Two example files are here (only a few days):
http://bacon.no-ip.info/kdenlive/ [^]

These were captured like this:
gsking@blaster:/media/sdb1/vid/dv/tape09/import1$ sudo dvgrab --format hdv --autosplit --timestamp t09i1-
[sudo] password for gsking:
Found AV/C device with GUID 0x0000850001a0acc6
Capture Started
"t09i1-2009.09.08_14-45-10.m2t": 80.33 MiB 740 frames timecode 00:00:25.03 date 2009.09.08 14:45:34
"t09i1-2009.09.08_14-45-55.m2t": 120.52 MiB 1123 frames timecode 00:01:02.17 date 2009.09.08 14:46:32
"t09i1-2009.09.08_14-47-06.m2t": 178.78 MiB 1663 frames timecode 00:01:58.02 date 2009.09.08 14:48:01
Steps To ReproduceI am using sunab's ffmpeg ppa (20090916) and built frei0r svn, mlt 0.4.6, and kdenlive 0.7.6 from source.

I have been beating my head on the table over this one and it appear to be present with older versions of ffmpeg, et. al. also.

The tape in this case is

About the only thing I have not tried is re-capturing the tape yet, but as can be seen above, the capture looked okay with no errors. I have also not yet tried transcoding.

As can be seen below,in playing the clip there are a bunch of warnings from mpeg2video. The sound cuts out after a few seconds, but the video plays to the end. Then ffplay locks up.

I realize that this may be an ffmpeg problems, but I have never reported bugs there before and thought you might know best what to do.
Additional Informationgsking@blaster:/media/sdb1/vid/dv/tape09/import$ ffplay 2009.09.08_14-45-10-hatteras-tape9.m2t
FFplay version UNKNOWN-4:0.5+svn20090916-0ubuntu0~karmic2, Copyright (c) 2003-2009 Fabrice Bellard, et al.
  configuration: --extra-version='4:0.5+svn20090916-0ubuntu0~karmic2' --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libdirac --enable-libgsm --enable-libopenjpeg --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --disable-stripping --enable-libmp3lame --enable-libmp3lame --enable-gpl --enable-postproc --enable-x11grab --enable-libfaad --enable-libxvid --enable-libx264 --enable-libdc1394 --extra-cflags=-I/build/buildd/ffmpeg-extra-0.5+svn20090916/debian/include --enable-shared --disable-static
  libavutil 50. 3. 0 / 50. 3. 0
  libavcodec 52.35. 0 / 52.35. 0
  libavformat 52.38. 0 / 52.38. 0
  libavdevice 52. 2. 0 / 52. 2. 0
  libavfilter 0. 5. 0 / 0. 5. 0
  libswscale 0. 7. 1 / 0. 7. 1
  libpostproc 51. 2. 0 / 51. 2. 0
  built on Oct 12 2009 20:32:16, gcc: 4.4.1
[mpegts @ 0x9140bc0]MAX_READ_SIZE:5000000 reachedq= 0B
Input #0, mpegts, from '2009.09.08_14-45-10-hatteras-tape9.m2t':
  Duration: 00:00:24.75, start: 0.937767, bitrate: 27220 kb/s
  Program 100
    Stream #0.0[0x810]: Video: mpeg2video, yuv420p, 1440x1080 [PAR 4:3 DAR 16:9], 25000 kb/s, 29.97 tbr, 90k tbn, 59.94 tbc
    Stream #0.1[0x814]: Audio: mp2, 48000 Hz, 2 channels, s16, 384 kb/s
    Stream #0.2[0x815]: Data: 0x00a0
    Stream #0.3[0x811]: Data: 0x00a1
[mpeg2video @ 0x9140520]00 motion_type at 10 61 0B 0B
[mpeg2video @ 0x9140520]mb incr damaged
[mpeg2video @ 0x9140520]00 motion_type at 0 26
[mpeg2video @ 0x9140520]00 motion_type at 0 27
[mpeg2video @ 0x9140520]00 motion_type at 0 28
[mpeg2video @ 0x9140520]00 motion_type at 0 29
[mpeg2video @ 0x9140520]00 motion_type at 0 30
[mpeg2video @ 0x9140520]00 motion_type at 25 31
[mpeg2video @ 0x9140520]00 motion_type at 0 32
[mpeg2video @ 0x9140520]00 motion_type at 0 33
[mpeg2video @ 0x9140520]00 motion_type at 0 34
[mpeg2video @ 0x9140520]ac-tex damaged at 1 35
[mpeg2video @ 0x9140520]00 motion_type at 0 36
[mpeg2video @ 0x9140520]00 motion_type at 0 37
[mpeg2video @ 0x9140520]00 motion_type at 0 38
[mpeg2video @ 0x9140520]00 motion_type at 0 39
[mpeg2video @ 0x9140520]00 motion_type at 0 40
[mpeg2video @ 0x9140520]mb incr damaged
[mpeg2video @ 0x9140520]00 motion_type at 0 42
[mpeg2video @ 0x9140520]00 motion_type at 0 43
[mpeg2video @ 0x9140520]00 motion_type at 0 44
[mpeg2video @ 0x9140520]00 motion_type at 0 45
[mpeg2video @ 0x9140520]00 motion_type at 2 46
[mpeg2video @ 0x9140520]00 motion_type at 0 47
[mpeg2video @ 0x9140520]00 motion_type at 0 48
[mpeg2video @ 0x9140520]00 motion_type at 9 49
[mpeg2video @ 0x9140520]00 motion_type at 2 50
[mpeg2video @ 0x9140520]mb incr damaged
[mpeg2video @ 0x9140520]00 motion_type at 0 52
[mpeg2video @ 0x9140520]00 motion_type at 7 53
[mpeg2video @ 0x9140520]00 motion_type at 0 54
[mpeg2video @ 0x9140520]00 motion_type at 0 55
[mpeg2video @ 0x9140520]00 motion_type at 7 56
[mpeg2video @ 0x9140520]00 motion_type at 0 57
[mpeg2video @ 0x9140520]00 motion_type at 0 58
[mpeg2video @ 0x9140520]00 motion_type at 0 59
[mpeg2video @ 0x9140520]invalid mb type in B Frame at 6 60
[mpeg2video @ 0x9140520]00 motion_type at 1 61
[mpeg2video @ 0x9140520]00 motion_type at 1 62
[mpeg2video @ 0x9140520]00 motion_type at 0 63
[mpeg2video @ 0x9140520]00 motion_type at 0 64
[mpeg2video @ 0x9140520]00 motion_type at 6 65
[mpeg2video @ 0x9140520]00 motion_type at 0 66
[mpeg2video @ 0x9140520]00 motion_type at 2 67
[mpeg2video @ 0x9140520]Warning MVs not available
[mpeg2video @ 0x9140520]concealing 3870 DC, 3870 AC, 3870 MV errors
Seek to 68% ( 0:00:16) of total duration ( 0:00:24)
Killed9 A-V:-17.353 aq= 90KB vq= 1328KB sq= 0B



gsking@blaster:/media/sdb1/vid/dv/tape09/import$ melt 2009.09.08_14-45-10-hatteras-tape9.m2t
+-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+
|1=-10| |2= -5| |3= -2| |4= -1| |5= 0| |6= 1| |7= 2| |8= 5| |9= 10|
+-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+
+---------------------------------------------------------------------+
| H = back 1 minute, L = forward 1 minute |
| h = previous frame, l = next frame |
| g = start of clip, j = next clip, k = previous clip |
| 0 = restart, q = quit, space = play |
+---------------------------------------------------------------------+
Current Position: 0
Killed
TagsNo tags attached.
Build/Install MethodManual build from release
Attached Files

- Relationships

-  Notes
(0004139)
gsking1 (reporter)
2009-10-13 04:44

I can also add that most/many of my m2t files lock up at the end of the clip.

Also, clips that I know played fine a few months ago (0.7.5?) in kdenlive now also lock up at the end of the clip.

I would be glad to post some other examples of files, that don't have the waring/errors like above, but still lock up.

Thanks, Geoff
(0004140)
ddennedy (developer)
2009-10-13 06:45

For a while in August and September and possibly earlier I too had problems with some bad HDV crashing FFmpeg. With my reports and others, they did make some improvements around Sept 14, which you should have based on your package description. Well, I suppose not every bug in mpegts parsing is resolved.

Sorry, but we must redirect you to the ffmpeg bug tracker named "roundup" because we do not have the human resources to relay bugs to dependent project and coordinate them with our own. We can barely keep up with the Kdenlive and MLT big report levels.

- Issue History
Date Modified Username Field Change
2009-10-13 04:25 gsking1 New Issue
2009-10-13 04:25 gsking1 Build/Install Method => Manual build from release
2009-10-13 04:44 gsking1 Note Added: 0004139
2009-10-13 06:45 ddennedy Note Added: 0004140
2009-10-13 06:45 ddennedy Status new => resolved
2009-10-13 06:45 ddennedy Resolution open => no change required
2009-10-13 06:45 ddennedy Assigned To => ddennedy
2010-02-02 10:34 j-b-m Fixed in Version => 0.7.7
2010-02-20 08:16 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker