Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001223KdenliveRenderingpublic2009-10-25 01:532010-02-20 08:17
Reportergriphiam 
Assigned Toddennedy 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platform32 bit intel and alikeOSKubuntu LinuxOS VersionKarmic 9.10
Product Version0.7.6 
Target VersionFixed in Version0.7.7 
Summary0001223: For Karmic 9.10, repository version of ffmpeg no longer supports libfaac
DescriptionAfter upgrading to Karmic and 0.7.6, the ffmpeg that is installed no longer includes libfaac. This means the H.264 render profile does not work.
Additional InformationForum post indicating Debian/Ubuntu altered ffmpeg to not include libfaac

http://ubuntuforums.org/showpost.php?p=8049339&postcount=4 [^]
TagsNo tags attached.
Build/Install Method3rd party package
Attached Files

- Relationships

-  Notes
(0004207)
griphiam (reporter)
2009-10-25 02:12

I tried installing my own version of ffmpeg from svn (and enabled libfaac in the ./configure statement) but kdenlive still says libfaac is not supported (both in Render and Config Wizard). Do I need to refresh something for it to detect there is a new version of ffmpeg?
(0004211)
ddennedy (developer)
2009-10-27 03:46

The 0.7.6 version of Kdenlive contains code to look for 'aac' when libfaac is not available in libavcodec because in early July FFmpeg added their own native aac encoder (after making libfaac nonfree sometime much earlier in the year). Kdenlive also will convert 'libfaac' in the render profiles when libfaac is not available but aac is. You should rebuild FFmpeg without libfaac and try it again.
(0004225)
griphiam (reporter)
2009-11-01 04:13

That still didn't work. Here's my config line for ffmpeg:

--enable-gpl --enable-nonfree --enable-pthreads --enable-libfaad --enable-libmp3lame --enable-libtheora --enable-libx264 --enable-libxvid --enable-x11grab

And here's the dump of formats (searching for aac)

mphilpot@desktop:~$ ffmpeg -formats | grep aac
FFmpeg version SVN-r20368, Copyright (c) 2000-2009 Fabrice Bellard, et al.
  built on Oct 31 2009 20:06:26 with gcc 4.4.1
  configuration: --enable-gpl --enable-nonfree --enable-pthreads --enable-libfaad --enable-libmp3lame --enable-libtheora --enable-libx264 --enable-libxvid --enable-x11grab
  libavutil 50. 3. 0 / 50. 3. 0
  libavcodec 52.37. 1 / 52.37. 1
  libavformat 52.39. 2 / 52.39. 2
  libavdevice 52. 2. 0 / 52. 2. 0
  libswscale 0. 7. 1 / 0. 7. 1
 D aac raw ADTS AAC
 DEA aac Advanced Audio Coding
 text2movsub remove_extra noise mov2textsub mp3decomp mp3comp mjpegadump imxdump h264_mp4toannexb dump_extra aac_adtstoasc

Anything else to try?
(0004242)
ddennedy (developer)
2009-11-03 20:17

Fixed in Subversion a couple of days ago. Now, it only works with 'aac'.

Besides, I can not reproduce your problem with 0.7.6. Maybe there is a problem with your build and it lacks libx264. ffmpeg -formats is not exactly. The Kdenlive Config wizard in the Settings menu will tell you which codecs are available in your build.

- Issue History
Date Modified Username Field Change
2009-10-25 01:53 griphiam New Issue
2009-10-25 01:53 griphiam Build/Install Method => 3rd party package
2009-10-25 02:12 griphiam Note Added: 0004207
2009-10-27 03:46 ddennedy Note Added: 0004211
2009-10-27 03:46 ddennedy Status new => feedback
2009-11-01 04:13 griphiam Note Added: 0004225
2009-11-03 20:17 ddennedy Note Added: 0004242
2009-11-03 20:17 ddennedy Status feedback => resolved
2009-11-03 20:17 ddennedy Fixed in Version => future version
2009-11-03 20:17 ddennedy Resolution open => fixed
2009-11-03 20:17 ddennedy Assigned To => ddennedy
2010-02-02 10:34 j-b-m Fixed in Version future version => 0.7.7
2010-02-20 08:17 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker