Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001267KdenliveMLTpublic2009-11-11 05:512010-02-20 08:17
Reportertidris769 
Assigned Toddennedy 
PrioritynormalSeveritymajorReproducibilityrandom
StatusclosedResolutionwon't fix 
Platform32 bit intel and alikeOSUbuntu LinuxOS Version9.04
Product VersionRecent git 
Target VersionFixed in Version0.7.7 
Summary0001267: Sometimes kdenlive locks up during video playback
DescriptionWhat happens is that occasionally, sometime during the playing of the whole project or the playing of a single clip in the project tree, the video stop updating in the monitor panel. Usually I can interact with the GUI for a while after this happens, but eventually the GUI becomes unresponsive and I have to kill kdenlive. Kdenlive does not crash, it is using 100% processor time when in this locked up mode.

This problem has been happening often enough to get me into the habit of always saving the project before playing the video just in case kdenlive decides to lock up.

I have seen this happen since 0.7.6 and it remains in svn rev 4104. I have seen it happen when working with a variety of video clips ranging from 848x480 mjpeg to 720p AVCHD. I normally use the HD 720p 59.94Hz video profile in my projects.

My computer is a 2.4GHz Core2Duo and is fast enough to play 720p AVCHD smoothly on Totem or VLC.
Steps To ReproducePlay a single clip or the whole project over and over until the problem happens.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0004270)
carlosfehr (reporter)
2009-11-11 13:07

I have the same problem, I noticed that it updates the video image only forwards until you reach the end of the file or clip, that is if you are at 50% of the file you could go to 60 or more but if you go to say, 45% the image thats remains in the monitor is the last one (the further you reached).
(0004271)
tidris769 (reporter)
2009-11-11 14:27
edited on: 2009-11-12 05:29

I have now been able to reproduce this problem with the melt command line tool several times. It has happened when playing a 720p AVCHD video as well as when playing an 848x480x30fps mjpeg video. Melt is able to play both videos without problem most of the time. However if you play a video often enough, sooner or later melt will go into a locked up mode where it uses 100% cpu time without updating the video output and without responding to the keyboard command to quit. Once in this mode I have to use "killall -9 melt" to make melt quit.

me@g2s:~$ melt -version
MLT melt 0.4.6

me@g2s:~$ ffmpeg
FFmpeg version SVN-r20508, Copyright (c) 2000-2009 Fabrice Bellard, et al.
  built on Nov 10 2009 15:50:35 with gcc 4.3.3
  configuration: --prefix=/usr/local --enable-shared --enable-libmp3lame --enable-gpl --enable-libfaad --enable-libvorbis --enable-pthreads --enable-libfaac --enable-libxvid --enable-postproc --enable-x11grab --enable-libgsm --enable-libtheora --enable-libdc1394 --enable-nonfree --disable-stripping --enable-avfilter --enable-libdirac --disable-decoder=libdirac --enable-libschroedinger --disable-encoder=libschroedinger --enable-avfilter-lavf --enable-libx264
  libavutil 50. 4. 0 / 50. 4. 0
  libavcodec 52.38. 1 / 52.38. 1
  libavformat 52.39. 2 / 52.39. 2
  libavdevice 52. 2. 0 / 52. 2. 0
  libavfilter 1. 7. 0 / 1. 7. 0
  libswscale 0. 7. 1 / 0. 7. 1
  libpostproc 51. 2. 0 / 51. 2. 0

me@g2s:~$ export | grep LD_
declare -x LD_LIBRARY_PATH="/usr/local/lib"

(0004284)
nyme (reporter)
2009-11-17 08:16

hi

same problem with avchd 720p, kdenlive build with builderwizard on 9.04, but work good with 640*480 mov clip ...

bye
(0004288)
tidris769 (reporter)
2009-11-17 19:10
edited on: 2009-11-17 19:11

On my computer, this lock up problem is related to audio playback by the mlt SDL module. For reasons I don't yet understand, every once in a while the consumer thread in the SDL mlt module is becoming blocked indefinitely waiting for space in the audio playback buffer to become available. Since the consumer thread is also in charge of feeding video images to the video thread, the video thread becomes starved and video stops updating on the screen.

(0004295)
tidris769 (reporter)
2009-11-17 23:07

This problem seems to have gone away after I switched from package libsdl1.2debian-alsa to libsdl1.2debian-pulseaudio. I have pulseaudio installed on my ubuntu 9.04 computer.
(0004402)
ddennedy (developer)
2009-12-07 00:11

This is a known problem with using the SDL ALSA backend with PulseAudio that we will not be fixing.

- Issue History
Date Modified Username Field Change
2009-11-11 05:51 tidris769 New Issue
2009-11-11 05:51 tidris769 Build/Install Method => Manual build from SVN
2009-11-11 13:07 carlosfehr Note Added: 0004270
2009-11-11 14:27 tidris769 Note Added: 0004271
2009-11-11 14:28 tidris769 Note Edited: 0004271 View Revisions
2009-11-11 14:43 tidris769 Note Edited: 0004271 View Revisions
2009-11-11 18:57 j-b-m Category User Interface => MLT
2009-11-11 21:02 tidris769 Note Edited: 0004271 View Revisions
2009-11-11 21:15 tidris769 Note Edited: 0004271 View Revisions
2009-11-11 21:17 tidris769 Note Edited: 0004271 View Revisions
2009-11-12 05:29 tidris769 Note Edited: 0004271 View Revisions
2009-11-17 08:16 nyme Note Added: 0004284
2009-11-17 19:10 tidris769 Note Added: 0004288
2009-11-17 19:11 tidris769 Note Edited: 0004288 View Revisions
2009-11-17 23:07 tidris769 Note Added: 0004295
2009-12-07 00:11 ddennedy Note Added: 0004402
2009-12-07 00:11 ddennedy Status new => resolved
2009-12-07 00:11 ddennedy Resolution open => won't fix
2009-12-07 00:11 ddennedy Assigned To => ddennedy
2010-02-02 10:34 j-b-m Fixed in Version => 0.7.7
2010-02-20 08:17 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker