Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001310KdenliveUser Interfacepublic2009-11-24 20:402010-09-22 17:53
ReporterGranjow 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version0.7.7Fixed in Version0.7.7 
Summary0001310: Dragging guideline: Draggable label ... slightly too large
DescriptionTake a close look at the screenshot. What will I be dragging? :P
I'd say the draggable label is slightly too long.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Filespng file icon kdenlive-dragging-guide.png [^] (116,741 bytes) 2009-11-24 20:41

- Relationships

-  Notes
(0004347)
j-b-m (administrator)
2009-11-25 19:07

What do you suggest? Shall we trim the guide label to only show the 15th first characters and show the full label in the tooltip when mouse is over the guide?

If that's what you want, I have a patch ready for that, otherwise, please explain how you think we should improve that.

regards
(0004349)
Granjow (developer)
2009-11-25 20:48

Oh, sorry for my inaccurateness.

The «very long guide just for testing purposes» is at the very left of the timeline, the mouse at the right, distance between them about 1000 px. But the red guideline label, although invisible, seems to reach until there. I cannot drag the End guideline because the Very long guide just for testing purposes is overlapping it.

(Hovered guides are red, and I'm hovering the Vlgjftp although the cursor is ways off the label.

About only showing the first 15 characters: I'm not sure about that. I personally would like to keep it that way, because when the label is too long I can still chose a shorter name for it. I hate hovering something to make it reveal its full contents. But that is just my opinion.

:)
(0004351)
j-b-m (administrator)
2009-11-25 22:03

Sometimes a few words are better than an image :)
Should be fixed in svn rev. 4148
(0004360)
Granjow (developer)
2009-11-26 20:47

Well yes. Just, if you know what you've got to look at it is obvious *g*

Confirmed, fixed. My «Very very very extra long guideline also for testing purposes» has both visibly and invisibly correct length.

- Issue History
Date Modified Username Field Change
2009-11-24 20:40 Granjow New Issue
2009-11-24 20:40 Granjow Build/Install Method => Manual build from SVN
2009-11-24 20:41 Granjow File Added: kdenlive-dragging-guide.png
2009-11-25 19:07 j-b-m Note Added: 0004347
2009-11-25 19:08 j-b-m Status new => feedback
2009-11-25 20:48 Granjow Note Added: 0004349
2009-11-25 22:03 j-b-m Note Added: 0004351
2009-11-26 20:47 Granjow Note Added: 0004360
2009-11-26 20:47 Granjow Assigned To => j-b-m
2009-11-26 20:47 Granjow Status feedback => resolved
2009-11-26 20:47 Granjow Resolution open => fixed
2009-11-26 20:47 Granjow Fixed in Version => Recent git
2010-02-02 10:34 j-b-m Fixed in Version Recent git => 0.7.7
2010-02-20 08:17 j-b-m Status resolved => closed
2010-09-22 17:53 Granjow Target Version future version => 0.7.7


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker