Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001335KdenliveRenderingpublic2009-12-09 18:512010-02-20 08:17
Reporterpfong 
Assigned Toddennedy 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platform32 bit intel and alikeOSUbuntu LinuxOS Version9.04
Product Version0.7.6 
Target VersionFixed in Version0.7.7 
Summary0001335: Jittery video from CamStudio screen caps
Description have screen caps produced by CamStudio that become jittery regardless of the output render format I choose. It seems there may be unnecessary de-interlacing going on. Some frames are perfectly clear while alternating frames are shifted slightly and blurry.

My test project is a VGA NTSC project (640x480 progressive). My test clip is a 640x480 encoded with the CamStudio lossless codec. This plays fine in mplayer without any jittering. I've tried various render profiles but I'm currently testing with FFV1 lossless. When I play the output in mplayer or VLC the video jitters. Setting scanning to force progressive does not seem to make a difference.

I'm not sure if this is a rendering or input problem. It's hard to tell but it appears that the jittering may be present when I play in the clip monitor.

I've also tried converting the input clip to FFV1 using mencoder before loading into kdenlive. This does not appear to make a difference.
Steps To ReproducePlace attached test file on timeline in a new VGA NTSC project. Render to FFV1. View in VLC. Notice the text on the Firefox tab jitters.
Tagsrender
Build/Install MethodDistribution package
Attached Files? file icon kdlwebsite.avi [^] (1,711,104 bytes) 2009-12-09 18:51
? file icon registration1.ogv [^] (5,488,408 bytes) 2010-01-08 07:32

- Relationships

-  Notes
(0004499)
deven (reporter)
2010-01-08 07:38

Reporting same problem, adding registration1.ogv as another example source. Details:

1. captured by recordmydesktop
2. profile used was size 1024x700, fps 15, pixel 1x1, aspect 1024x700
3. output was just the input file rendered with no effects
4. Possibly related issue: in this clip a few seconds are ignored, i.e the output rendered as well as clip/project monitor do not display the first few secs of the source.
(0004509)
ddennedy (developer)
2010-01-11 03:39

Fix in MLT commit ce66386.

Indeed, the problem was that not all frames were properly indicating their interlaced status resulting in unneeded deinterlacing. If you are running a SVN version of Kdenlive, a while ago I had added a Force Progressive option in the Advanced section of the clip properties dialog that will let you workaround the problem.

- Issue History
Date Modified Username Field Change
2009-12-09 18:51 pfong New Issue
2009-12-09 18:51 pfong File Added: kdlwebsite.avi
2009-12-22 06:00 ddennedy Status new => assigned
2009-12-22 06:00 ddennedy Assigned To => ddennedy
2010-01-08 07:25 deven Tag Attached: render
2010-01-08 07:32 deven File Added: registration1.ogv
2010-01-08 07:38 deven Note Added: 0004499
2010-01-11 03:39 ddennedy Note Added: 0004509
2010-01-11 03:39 ddennedy Status assigned => resolved
2010-01-11 03:39 ddennedy Fixed in Version => future version
2010-01-11 03:39 ddennedy Resolution open => fixed
2010-02-02 10:34 j-b-m Fixed in Version future version => 0.7.7
2010-02-20 08:17 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker