Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001344KdenliveEffectspublic2009-12-19 19:452010-02-20 08:16
Reporterlexen 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityunable to reproduce
StatusclosedResolutionno change required 
PlatformOSOS Version
Product Version0.7.6 
Target VersionFixed in Version 
Summary0001344: Crash while Editing with effects
Description   I don't know how much good this will do, but I was editing a video with the effects Fade in, Pan and Zoom and Oldfilm when it crashed. The bug report said that it could be useful, so I am filing a report.


Thanks for your time,
Lexen
Additional InformationCrash Report:

Application that crashed: kdenlive
Version of the application: 0.7.6
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
<I don't know how much good this will do, but I was editing a video with the effects Fade in, Pan and Zoom and Oldfilm when it crashed. The bug report said that it could be useful, so I am filing a report.


Thanks for your time,
Lexen>

 -- Backtrace:
Application: Kdenlive (kdenlive), signal: Aborted
_dl_fini () at dl-fini.c:248
    in dl-fini.c
The current source language is "auto; currently c".
[Current thread is 1 (Thread 0x7fabc88b6750 (LWP 4325))]

Thread 6 (Thread 0x7faba37fd910 (LWP 8873)):
#0 pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:220
#1 0x00007fabc84c92d0 in mlt_consumer_put_frame () from /usr/lib/libmlt.so.2
0000002 0x00007fabb3f68f77 in ?? ()
0000003 0x00007fabc42cf290 in __pthread_keys () from /lib/libpthread.so.0
0000004 0x3ff0000000000000 in ?? ()
0000005 0x000000000259c4d0 in ?? ()
0000006 0x000000000259c4a0 in ?? ()
0000007 0x00007fabc483d860 in __elf_set___libc_atexit_element__IO_cleanup__ () from /lib/libc.so.6
0000008 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7faba8b9a910 (LWP 8909)):
#0 pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1 0x00007fabb3f67217 in ?? ()
0000002 0x0000000000001bc0 in ?? ()
0000003 0x00007fab0000bb80 in ?? ()
0000004 0x000019040000bb80 in ?? ()
0000005 0x00000000025b0e80 in ?? ()
0000006 0x0000064100000000 in ?? ()
0000007 0x00000000025b0ea8 in ?? ()
0000008 0x00007faba8b9a060 in ?? ()
0000009 0x00007faba8b9a068 in ?? ()
0000010 0x00007faba8b9a064 in ?? ()
0000011 0x00007faba8b9a06c in ?? ()
0000012 0x00007faba8b9a050 in ?? ()
0000013 0x0000000000000000 in ?? ()
The current source language is "auto; currently asm".

Thread 4 (Thread 0x7faba939b910 (LWP 8910)):
[KCrash Handler]
0000005 0x00007fabc450b4b5 in *__GI_raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
0000006 0x00007fabc450ef50 in *__GI_abort () at abort.c:92
0000007 0x00007fabc4504481 in *__GI___assert_fail (assertion=0x7fabc40c919c "mutex->__data.__owner == 0", file=<value optimized out>, line=62, function=0x7fabc40c9270 "__pthread_mutex_lock")
    at assert.c:81
0000008 0x00007fabc40c10f5 in __pthread_mutex_lock (mutex=0x7faba939b910) at pthread_mutex_lock.c:62
0000009 0x00007fabc84ca40c in ?? () from /usr/lib/libmlt.so.2
0000010 0x00007fabc40bea04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
0000011 0x00007fabc45b77bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
0000012 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fabaa511910 (LWP 8911)):
#0 0x00007fabc45ab373 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1 0x00007fabb38b120f in ?? () from /usr/lib/libpulse.so.0
0000002 0x00007fabb38a15e6 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
0000003 0x00007fabb38a2eb9 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
0000004 0x00007fabb38a2f70 in pa_mainloop_run () from /usr/lib/libpulse.so.0
0000005 0x00007fabb38b112b in ?? () from /usr/lib/libpulse.so.0
0000006 0x00007fabb3672050 in ?? () from /usr/lib/libpulsecommon-0.9.19.so
0000007 0x00007fabc40bea04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
0000008 0x00007fabc45b77bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
0000009 0x0000000000000000 in ?? ()
The current source language is "auto; currently c".

Thread 2 (Thread 0x7faba1750910 (LWP 8913)):
#0 0x00007fabc45ab373 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1 0x00007fabbfdba29a in ?? () from /usr/lib/libxcb.so.1
0000002 0x00007fabbfdba7d7 in ?? () from /usr/lib/libxcb.so.1
0000003 0x00007fabbfdbaa85 in xcb_writev () from /usr/lib/libxcb.so.1
0000004 0x00007fabc3472d4a in _XSend () from /usr/lib/libX11.so.6
0000005 0x00007fabc3472e89 in _XReply () from /usr/lib/libX11.so.6
0000006 0x00007fabc3450e48 in _XGetWindowAttributes () from /usr/lib/libX11.so.6
0000007 0x00007fabc3450fe1 in XGetWindowAttributes () from /usr/lib/libX11.so.6
0000008 0x00007fabb3f661d5 in ?? ()
0000009 0x6e6f633a7473696c in ?? ()
0000010 0x72662d72656d7573 in ?? ()
0000011 0x776f68732d656d61 in ?? ()
0000012 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fabc88b6750 (LWP 4325)):
#0 _dl_fini () at dl-fini.c:248
#1 0x00007fabc4510c12 in __run_exit_handlers (status=1) at exit.c:78
0000002 *__GI_exit (status=1) at exit.c:100
0000003 0x00007fabbc43c716 in ?? () from /usr/lib/libgdk-x11-2.0.so.0
0000004 0x00007fabc7c23498 in KApplication::xioErrhandler(_XDisplay*) () from /usr/lib/libkdeui.so.5
0000005 0x00007fabc346afae in _XIOError () from /usr/lib/libX11.so.6
0000006 0x00007fabc34729a5 in ?? () from /usr/lib/libX11.so.6
0000007 0x00007fabc3473257 in _XEventsQueued () from /usr/lib/libX11.so.6
0000008 0x00007fabc345c01b in XEventsQueued () from /usr/lib/libX11.so.6
0000009 0x00007fabc522767c in ?? () from /usr/lib/libQtGui.so.4
0000010 0x00007fabc0f60a9a in g_main_context_check () from /lib/libglib-2.0.so.0
0000011 0x00007fabc0f61280 in ?? () from /lib/libglib-2.0.so.0
0000012 0x00007fabc0f616b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
0000013 0x00007fabc5f6b1a6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000014 0x00007fabc52274be in ?? () from /usr/lib/libQtGui.so.4
0000015 0x00007fabc5f41532 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000016 0x00007fabc5f41904 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000017 0x00007fabc5f43ab9 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
0000018 0x0000000000444ee5 in main (argc=<value optimized out>, argv=<value optimized out>) at /build/buildd/kdenlive-0.7.6/src/main.cpp:86

Report to http://kdenlive.org/mantis [^]
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Filestxt file icon Kdenlive Crash 2009-12-19 - 001.txt [^] (5,951 bytes) 2009-12-19 19:45 [Show Content]

- Relationships

-  Notes
(0004532)
j-b-m (administrator)
2010-01-19 11:55

I think it might be related to pulseaudio, please see for example this forum thread:
http://kdenlive.org/forum/remember-remove-pulseaudio-if-using-kubuntu-karmic [^]
(0004536)
lexen (reporter)
2010-01-19 20:52

Thanks for responding. I haven't had the issue since then, but I went ahead and followed the steps you gave to remove pulseaudio. If the problem comes back, I'll add another note about the situation.


Thanks,
Lexen

- Issue History
Date Modified Username Field Change
2009-12-19 19:45 lexen New Issue
2009-12-19 19:45 lexen File Added: Kdenlive Crash 2009-12-19 - 001.txt
2010-01-19 11:55 j-b-m Note Added: 0004532
2010-01-19 11:55 j-b-m Status new => feedback
2010-01-19 20:52 lexen Note Added: 0004536
2010-01-19 20:52 lexen Status feedback => new
2010-02-09 09:04 j-b-m Status new => resolved
2010-02-09 09:04 j-b-m Resolution open => no change required
2010-02-09 09:04 j-b-m Assigned To => j-b-m
2010-02-20 08:16 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker