Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001350KdenliveUser Interfacepublic2009-12-22 22:092010-02-20 08:16
Reporterakirk 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionduplicate 
Platform64 bitOSUbuntu LinuxOS Version9.04
Product VersionRecent git 
Target VersionFixed in Version 
Summary0001350: Add clip: Clip monitor always displays frame 2 as first frame.
DescriptionMay cause the anoying 'auto rewind' functionality of the clip monitor.
Steps To ReproduceAdd a clip
Additional Informationframcntr.mp4 included. Simple 90 frame dv_ntsc_wide video with frame #'s 0-89
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Filesgz file icon framcntr.mp4.tar.gz [^] (164,171 bytes) 2009-12-22 22:09

- Relationships
duplicate of 0001349closedj-b-m Add clip: Clip monitor always displays frame 2 as first frame. 

-  Notes
(0004441)
akirk (reporter)
2009-12-22 22:55

If you save the project and then reopen it (just a project with a clip, not even in the timeline), when you reopen the project the clip monitor starts with the first frame of that clip. Add some clips, then they have the problem.
(0004462)
akirk (reporter)
2010-01-03 08:26

second frame first fix:

the end of renderer.cpp:int Render::setProducer(Mlt::Producer *producer, int position)
    ......
    m_fps = m_mltProducer->get_fps();
    int error = connectPlaylist();
    
    if (position != -1) {
        m_mltProducer->seek(position);
        emit rendererPosition(position);
    } else {
        kDebug() << " position = " << position << " err " << error;
        m_mltProducer->seek(0); // AKAK add-clip fix for position=1 instead of 0 when adding clip. probably not right place, but works
                                 // this happens because slotStart isn't called by default when opening kdenlive and not auto-restoring project??????
    }
    m_isBlocked = false;
    return error;


and:

monitor.cpp
void Monitor::rendererStopped(int pos)
{
  /* if (m_currentClip != NULL && m_playAction->isChecked()) {
        // Clip monitor
        if (pos >= m_length - 1) {
            slotStart();
            return;
        }
    } */
    m_ruler->slotNewValue(pos);
    checkOverlay();
    if (m_frametimecode) m_timePos->setText(QString::number(pos));
    else m_timePos->setText(m_monitorManager->timecode().getTimecodeFromFrames(pos));
    m_playAction->setChecked(false); // rendering has stopped, we do want these two actions taken
    m_playAction->setIcon(m_playIcon); // it's necessary on a 'rewind'
    m_monitorManager->stopActiveMonitor(); // AKAK stops the processor usage when rewind ends.
}

- Issue History
Date Modified Username Field Change
2009-12-22 22:09 akirk New Issue
2009-12-22 22:09 akirk File Added: framcntr.mp4.tar.gz
2009-12-22 22:55 akirk Note Added: 0004441
2010-01-03 00:52 j-b-m Relationship added duplicate of 0001349
2010-01-03 08:26 akirk Note Added: 0004462
2010-02-09 09:12 j-b-m Status new => resolved
2010-02-09 09:12 j-b-m Resolution open => duplicate
2010-02-09 09:12 j-b-m Assigned To => j-b-m
2010-02-20 08:16 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker