Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001369KdenliveFile Loadingpublic2010-01-02 22:332010-02-20 08:17
ReporterGoliath23 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionno change required 
Platform64 bitOSKubuntu LinuxOS Version9.10
Product Version0.7.6 
Target VersionFixed in Version0.7.7 
Summary0001369: Crash when adding clip from Canon Vixia (Legria) HF20
DescriptionKdenlive crashes when I add a clip from the Canon Legria HF20 camcorder. I uploaded the clip to

http://www.vidsolbach.de/tmp/12mbps.MTS [^]

It's 32mb. I tried to reproduce the problem with a shorter clip, but had no success.

To this report I attach the file additional_info.txt which contains the output of melt and ffplay playing the file as well as the test file mentioned on the bug report page.

Addtionally it contains the gdb backtrace of the crash.
Steps To Reproduce1. create new kdenlive project
2. add clip from
Additional InformationPlease let me know, if you need further information.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Filestxt file icon additional_info.txt [^] (48,221 bytes) 2010-01-02 22:33 [Show Content]

- Relationships

-  Notes
(0004458)
j-b-m (administrator)
2010-01-03 00:21

I can add the file without problem here. Maybe that is related to your FFmpeg version which is 7 months old... Can you update to a newer FFmpeg version?
(0004465)
Goliath23 (reporter)
2010-01-03 12:11

Hi,

I compiled ffmpeg and libx264 from current svn/git.

ffplay plays the clip:

---
david@scotty:~/Projects/ffmpeg/build$ ffplay /home/david/Datengarage/Videoschnitt/Neue\ Kamera/00012.MTS
FFplay version SVN-r21003, Copyright (c) 2003-2010 Fabrice Bellard, et al.
  built on Jan 3 2010 11:44:30 with gcc 4.4.1
  configuration: --prefix=/usr --enable-libvorbis --enable-libxvid --enable-libmp3lame --enable-libx264 --enable-libtheora --enable-libfaad --enable-gpl --enable-shared --enable-pthreads --enable-libfaac --enable-nonfree --enable-postproc
  libavutil 50. 7. 0 / 50. 7. 0
  libavcodec 52.45. 0 / 52.45. 0
  libavformat 52.46. 0 / 52.46. 0
  libavdevice 52. 2. 0 / 52. 2. 0
  libswscale 0. 7. 2 / 0. 7. 2
  libpostproc 51. 2. 0 / 51. 2. 0
[mpegts @ 0x2321ac0]MAX_READ_SIZE:5000000 reachedq= 0B
Input #0, mpegts, from '/home/david/Datengarage/Videoschnitt/Neue Kamera/00012.MTS':
  Duration: 00:00:05.76, start: 0.481233, bitrate: 12296 kb/s
  Program 1
    Stream #0.0[0x1011]: Video: h264, yuv420p, 1440x1080 [PAR 4:3 DAR 16:9], 50 fps, 50 tbr, 90k tbn, 50 tbc
    Stream #0.1[0x1100]: Audio: ac3, 48000 Hz, stereo, s16, 256 kb/s
   6.25 A-V: -0.636 aq= 0KB vq= 0KB sq= 0B 0B
---

kdenlive now tells me, that the clip is "Invalid" in a pop-up window. It doesn't play the clip.


Output on console when it displays the popup:

---
kdenlive(1245)/kio (KDirListerCache) KDirListerCache::forgetDirs: KDirLister(0x15fecc0) item moved into cache: KUrl("file:///home/david/Datengarage/Videoschnitt/Neue [^] Kamera")
kdenlive(1245) AddClipCommand::redo: ---- redoing action
kdenlive(1245) Render::getFileProperties: / / / / / / / / ERROR / / / / // CANNOT LOAD PRODUCER:
kdenlive(1245)/kdeui (KNotification) KNotification::slotReceivedId: 0
kdenlive(1245)/kdeui (KNotification) KNotification::close: 0
kdenlive(1245)/kdeui (KNotification) KNotification::~KNotification: -2
kdenlive(1245)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
kdenlive(1245)/kdeui (KNotification) KNotification::slotReceivedId: 0
kdenlive(1245)/kdeui (KNotification) KNotification::close: 0
kdenlive(1245)/kdeui (KNotification) KNotification::~KNotification: -2
kdenlive(1245) KdenliveDoc::~KdenliveDoc: // DEL CLP MAN
kdenlive(1245) ClipManager::~ClipManager:
---
(0004466)
j-b-m (administrator)
2010-01-03 12:55

If you recompiled FFMpeg, you should also recompile MLT, and make sure that you don't have older versions the ffmpeg libs still installed (libavformat, libavutil, libavcodec, libavfilter, libswscale, libpostproc)

Then, try playing the clip with MLT's command line player:

melt yourclip.mts
(0004469)
Goliath23 (reporter)
2010-01-03 14:35
edited on: 2010-01-03 14:38

I recompiled mlt (0.4.10). I had to reinstall the ffmpeg package however, to be able to install all the dev-dependencies for mlt. But afterwards I re-run make install of libx1264 and ffmpeg with --prefix=/usr ... so the old libraries should habe been properly overwritten.

mlt's ./configure didn't report missing deps when I compild (I used --enable-gpl).

However, every file I try to open now just gives a "Failed to load "/home/david/Datengarage/Videoschnitt/Neue Kamera/00012.MTS"" message and then the usage information again.

The same for .mov, .mkv, whatever.

Guess I somehow destroyed my installation here :)

Ah and another note:

I somehow expected, that ldd /usr/lib/libmlt.so.2 would list at least one ffmpeg lib. but didn't.

david@scotty:~/Projects/mlt-0.4.10$ !ldd
ldd /usr/lib/libmlt.so.2
        linux-vdso.so.1 => (0x00007fffb6db4000)
        libdl.so.2 => /lib/libdl.so.2 (0x00007fef9988c000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x00007fef99670000)
        libc.so.6 => /lib/libc.so.6 (0x00007fef99300000)
        /lib64/ld-linux-x86-64.so.2 (0x00007fef99cd7000)

(0004470)
j-b-m (administrator)
2010-01-03 14:41

No, reinstalling FFMpeg will not remove your old library files.

Check that:

ls -l /usr/lib/libavformat*

You should have only one version of the lib...

And for the MLT libraries, what you are looking for is the avformat module, located at:

/usr/lib/mlt/libmltavformat.so
(0004471)
Goliath23 (reporter)
2010-01-03 15:01

Okay. Manually deleting an old libavformat, recompiling/installing ffmpeg once more and recompiling/installing mlt finally solved the problem.

I can confirm, that the bug is not reproducible with current ffmpeg / mlt libraries. So I guess you can close it. Or should be inform downstream (Kubuntu's launchpad) so they know, that it might be beneficial to update ffmpeg for kdenlive-users?
(0004481)
j-b-m (administrator)
2010-01-03 23:08

I don't think ubuntu will upgrade their FFMpeg version because of a bug report like that, but it's up to you if you want to report it.

Also, maybe the issue is related to the MLT / FFmpeg interface, so I think it's better to just be aware that some formats require a recent FFMpeg svn version

- Issue History
Date Modified Username Field Change
2010-01-02 22:33 Goliath23 New Issue
2010-01-02 22:33 Goliath23 File Added: additional_info.txt
2010-01-03 00:21 j-b-m Note Added: 0004458
2010-01-03 00:21 j-b-m Status new => feedback
2010-01-03 12:11 Goliath23 Note Added: 0004465
2010-01-03 12:11 Goliath23 Status feedback => new
2010-01-03 12:55 j-b-m Note Added: 0004466
2010-01-03 12:55 j-b-m Status new => feedback
2010-01-03 14:35 Goliath23 Note Added: 0004469
2010-01-03 14:35 Goliath23 Status feedback => new
2010-01-03 14:38 Goliath23 Note Edited: 0004469 View Revisions
2010-01-03 14:41 j-b-m Note Added: 0004470
2010-01-03 15:01 Goliath23 Note Added: 0004471
2010-01-03 23:08 j-b-m Note Added: 0004481
2010-01-03 23:08 j-b-m Status new => resolved
2010-01-03 23:08 j-b-m Resolution open => no change required
2010-01-03 23:08 j-b-m Assigned To => j-b-m
2010-02-02 10:34 j-b-m Fixed in Version => 0.7.7
2010-02-20 08:17 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker