Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001372KdenliveBuild Systempublic2010-01-06 14:182010-02-20 08:17
Reportersiebz0r 
Assigned Toj-b-m 
PriorityhighSeverityblockReproducibilityalways
StatusclosedResolutionno change required 
Platform32 bit intel and alikeOSGentoo LinuxOS Version2008.0
Product VersionRecent git 
Target VersionFixed in Version0.7.7 
Summary0001372: make fails on renderer.cpp
DescriptionWhen installing kdenlive from svn the following error occures:
[ 39%] Building CXX object src/cmake_bindir/CMakeFiles/kdenlive.dir/gentime.o
[ 39%] Building CXX object src/cmake_bindir/CMakeFiles/kdenlive.dir/renderer.o
/var/tmp/portage/media-video/kdenlive-9999/work/kdenlive-9999/src/renderer.cpp: In member function ‘void Render::getFileProperties(const QDomElement&, const QString&, bool)’:
/var/tmp/portage/media-video/kdenlive-9999/work/kdenlive-9999/src/renderer.cpp:593: error: ‘mlt_convert_yuv422_to_rgb24a’ was not declared in this scope
make[2]: *** [src/cmake_bindir/CMakeFiles/kdenlive.dir/renderer.o] Error 1
make[1]: *** [src/cmake_bindir/CMakeFiles/kdenlive.dir/all] Error 2
make: *** [all] Error 2
Steps To Reproducesvn co
cmake .
make
Additional InformationI have made an ebuild for this, but it gives the same error when installing manualy.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0004494)
j-b-m (administrator)
2010-01-07 03:04

Well, the compilation error seems to indicate that the svn version you are trying to compile is more than one month old. Please try to update to see if the problem is solved. The error also indicates an error with MLT, so please let us know which MLT version is installed on your system.
(0004497)
siebz0r (reporter)
2010-01-08 00:30

The svn source of the kdenlive I'm trying to install is https://kdenlive.svn.sourceforge.net/svnroot/kdenlive/branches/KDE4 [^]
This is the source I got from the wiki page.

0.4.6 is the MLT version that is currently installed.
There are newer versions of MLT available but there is no ebuild file (needed for portage) available.
If I need to update MLT, I'll write an ebuild for it.
(0004498)
siebz0r (reporter)
2010-01-08 00:45

Right.. I'm to blame
I changed svn source to https://kdenlive.svn.sourceforge.net/svnroot/kdenlive/trunk/kdenlive/ [^] and it compile flawless.

- Issue History
Date Modified Username Field Change
2010-01-06 14:18 siebz0r New Issue
2010-01-07 03:04 j-b-m Note Added: 0004494
2010-01-07 03:04 j-b-m Status new => feedback
2010-01-08 00:30 siebz0r Note Added: 0004497
2010-01-08 00:30 siebz0r Status feedback => new
2010-01-08 00:45 siebz0r Note Added: 0004498
2010-01-08 14:32 j-b-m Status new => resolved
2010-01-08 14:32 j-b-m Resolution open => no change required
2010-01-08 14:32 j-b-m Assigned To => j-b-m
2010-02-02 10:34 j-b-m Fixed in Version => 0.7.7
2010-02-20 08:17 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker