Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001400KdenliveBuild Systempublic2010-01-28 09:562010-11-15 14:04
Reporterforty 
Assigned To 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platform64 bitOSGentoo LinuxOS Version2008.0
Product VersionRecent git 
Target VersionFixed in Version0.7.7 
Summary0001400: kdenlive QT 4.7
DescriptionHello,

kdenlive doesn't compile under QT 4.7 on my Gentoobox.

gcc (Gentoo 4.4.2 p1.0) 4.4.2

ERROR MESSAGE
QT 4.7 have no img.setColorCount() but img.setColorCount() works.

Here a little Patch for dvdwizardmenu.cpp.
It works in my Gentoo liveEbuild.

--- "${FILESDIR}"/src/dvdwizardmenu.cpp 2010-01-18 12:17:05.000000000 +0100
+++ kdenlive-9999-dvdwizardmenu.patch 2010-01-18 12:34:09.000000000 +0100
@@ -399,7 +399,7 @@
         m_scene->render(&p, QRectF(0, 0, m_width, m_height));
         p.end();
 #if QT_VERSION >= 0x040600
- img.setColorCount(4);
+ /*img.setColorCount(4);*/
 #else
         img.setNumColors(4);
 #endif
@@ -423,7 +423,7 @@
                 saved.setNumColors(4);
                 saved.save(img2);*/
 #if QT_VERSION >= 0x040600
- img.setColorCount(4);
+ /*img.setColorCount(4);*/
 #else
         img.setNumColors(4);
 #endif
@@ -442,7 +442,7 @@
         saved.setNumColors(4);
         saved.save(img3);*/
 #if QT_VERSION >= 0x040600
- img.setColorCount(4);
+ /*img.setColorCount(4);*/
 #else
         img.setNumColors(4);
 #endif

Thanks for this great Software
Steps To Reproducecompile under QT 4.7 without the patch
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0004590)
j-b-m (administrator)
2010-01-28 11:16

This seems a bit strange to me. Where did you get that Qt 4.7 version? The last release is Qt 4.6, and in the current development git trunk (1), the setNumColor function is there...

It was introduced in Qt 4.6, so it seems strange to me that they remove it in 4.7...

Can you point me to the doc saying it was deprecated?

(1): http://qt.gitorious.org/qt/qt/blobs/master/src/gui/image/qimage.h [^]
(0004591)
forty (reporter)
2010-01-28 13:33

The QT-Version 4.7 is from Overlay qting-edge.
git://gitorious.org/gentoo-qt/qting-edge.git [^]

ERROR-MESSAGE without the Patch

/home/forty/test/kdenlive/src/dvdwizardmenu.cpp: In member function 'void
DvdWizardMenu::createButtonImages(const QString&, const QString&, const
QString&)':
/home/forty/test/kdenlive/src/dvdwizardmenu.cpp:402: error: 'class QImage'
has no member named 'setColorCount'
/home/forty/test/kdenlive/src/dvdwizardmenu.cpp:426: error: 'class QImage'
has no member named 'setColorCount'
/home/forty/test/kdenlive/src/dvdwizardmenu.cpp:445: error: 'class QImage'
has no member named 'setColorCount'
make[2]: *** [src/cmake_bindir/CMakeFiles/kdenlive.dir/dvdwizardmenu.o]
Error 1
make[1]: *** [src/cmake_bindir/CMakeFiles/kdenlive.dir/all] Error 2
make: *** [all] Error 2
(0006067)
ttill (developer)
2010-11-15 14:04

Qt 4.7 is stable now and no one has reported such a problem yet (works for me, too).

- Issue History
Date Modified Username Field Change
2010-01-28 09:56 forty New Issue
2010-01-28 11:16 j-b-m Note Added: 0004590
2010-01-28 11:16 j-b-m Status new => feedback
2010-01-28 13:33 forty Note Added: 0004591
2010-01-28 13:33 forty Status feedback => new
2010-11-15 14:03 ttill Status new => resolved
2010-11-15 14:03 ttill Resolution open => fixed
2010-11-15 14:03 ttill Fixed in Version => 0.7.7
2010-11-15 14:04 ttill Note Added: 0006067
2010-11-15 14:04 ttill Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker