Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001408KdenliveFile Loadingpublic2010-02-02 01:552010-02-20 08:16
Reporterarmido 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionno change required 
Platform32 bit intel duo cpu 2 gb ramOSLinuxOS VersionFedora 12
Product VersionRecent git 
Target VersionFixed in Version 
Summary0001408: Program crashes using "cut clip" option and on restart.
DescriptionApplication that crashed: kdenlive
Version of the application: 0.7.7 (rev. 4219)
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.5.3
Operating System: Linux 2.6.31.12-174.2.3.fc12.i686.PAE i686

What I was doing when the application crashed:
<In detail, tell us what you were doing when the application crashed.>

 -- Backtrace:
Application: Kdenlive (kdenlive), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77557a0 (LWP 2855))]

Thread 3 (Thread 0xb01cbb70 (LWP 2874)):
[KCrash Handler]
0000006 0x004f0546 in memcpy () from /lib/libc.so.6
0000007 0xac29ced0 in ?? ()
0000008 0x01257d38 in resize_alpha (this=<value optimized out>, image=<value optimized out>, format=<value optimized out>, width=<value optimized out>, height=<value optimized out>,
    writable=<value optimized out>) at filter_resize.c:62
0000009 frame_resize_image (this=<value optimized out>, image=<value optimized out>, format=<value optimized out>, width=<value optimized out>, height=<value optimized out>,
    writable=<value optimized out>) at filter_resize.c:164
0000010 filter_get_image (this=<value optimized out>, image=<value optimized out>, format=<value optimized out>, width=<value optimized out>, height=<value optimized out>, writable=<value optimized out>)
    at filter_resize.c:312
0000011 0x005f63f6 in mlt_frame_get_image (this=<value optimized out>, buffer=<value optimized out>, format=<value optimized out>, width=<value optimized out>, height=<value optimized out>,
    writable=<value optimized out>) at mlt_frame.c:275
0000012 0x00607c88 in producer_get_image (this=<value optimized out>, buffer=<value optimized out>, format=<value optimized out>, width=<value optimized out>, height=<value optimized out>,
    writable=<value optimized out>) at mlt_tractor.c:274
0000013 0x005f63f6 in mlt_frame_get_image (this=<value optimized out>, buffer=<value optimized out>, format=<value optimized out>, width=<value optimized out>, height=<value optimized out>,
    writable=<value optimized out>) at mlt_frame.c:275
0000014 0x01247e96 in consumer_play_video (arg=<value optimized out>) at consumer_sdl_still.c:466
0000015 consumer_thread (arg=<value optimized out>) at consumer_sdl_still.c:565
0000016 0x00627ab5 in start_thread () from /lib/libpthread.so.0
0000017 0x00552dce in clone () from /lib/libc.so.6

Thread 2 (Thread 0xb0bccb70 (LWP 2875)):
#0 0x00660416 in __kernel_vsyscall ()
#1 0x0062bf72 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
0000002 0x006043d1 in mlt_consumer_put_frame (this=<value optimized out>, frame=<value optimized out>) at mlt_consumer.c:456
0000003 0x01247113 in consumer_thread (arg=<value optimized out>) at consumer_sdl_preview.c:352
0000004 0x00627ab5 in start_thread () from /lib/libpthread.so.0
0000005 0x00552dce in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb77557a0 (LWP 2855)):
#0 0x00660416 in __kernel_vsyscall ()
#1 0x006289fd in pthread_join () from /lib/libpthread.so.0
0000002 0x012468c8 in consumer_stop (parent=<value optimized out>) at consumer_sdl_preview.c:244
0000003 0x006040c4 in mlt_consumer_stop (this=<value optimized out>) at mlt_consumer.c:945
0000004 0x008f7904 in Mlt::Consumer::stop() () from /usr/lib/libmlt++.so.3
0000005 0x080d1a97 in Render::stop (this=<value optimized out>) at /home/armido/src/kdenlive/src/renderer.cpp:1229
0000006 0x08113cfa in MonitorManager::slotSwitchMonitors (this=<value optimized out>) at /home/armido/src/kdenlive/src/monitormanager.cpp:76
0000007 0x080be83a in Monitor::slotSetXml (this=<value optimized out>, clip=<value optimized out>, zone=..., position=<value optimized out>) at /home/armido/src/kdenlive/src/monitor.cpp:751
0000008 0x080c1a0c in Monitor::qt_metacall (this=<value optimized out>, _c=<value optimized out>, _id=<value optimized out>, _a=<value optimized out>)
    at /home/armido/src/kdenlive/build/src/cmake_bindir/monitor.moc:258
0000009 0x06dfcc0c in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
0000010 0x06dfd059 in QMetaObject::activate(QObject*, QMetaObject const*, int, int, void**) () from /usr/lib/libQtCore.so.4
0000011 0x080a83f3 in ProjectList::clipSelected (this=<value optimized out>, _t1=0x0, _t2=...) at /home/armido/src/kdenlive/build/src/cmake_bindir/projectlist.moc:231
0000012 0x080af953 in ProjectList::setDocument (this=<value optimized out>, doc=<value optimized out>) at /home/armido/src/kdenlive/src/projectlist.cpp:1034
0000013 0x08086658 in MainWindow::connectDocument (this=<value optimized out>, trackView=<value optimized out>, doc=<value optimized out>) at /home/armido/src/kdenlive/src/mainwindow.cpp:1973
0000014 0x080875a0 in MainWindow::activateDocument (this=<value optimized out>) at /home/armido/src/kdenlive/src/mainwindow.cpp:1471
0000015 0x080a273d in MainWindow::qt_metacall (this=<value optimized out>, _c=<value optimized out>, _id=9, _a=<value optimized out>)
    at /home/armido/src/kdenlive/build/src/cmake_bindir/mainwindow.moc:319
0000016 0x06dfcc0c in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
0000017 0x06dfd843 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
0000018 0x07a9dab4 in QTabWidget::currentChanged(int) () from /usr/lib/libQtGui.so.4
0000019 0x07a9fbcf in ?? () from /usr/lib/libQtGui.so.4
0000020 0x07a9ff02 in QTabWidget::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libQtGui.so.4
0000021 0x0666c25b in KTabWidget::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkdeui.so.5
0000022 0x06dfcc0c in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
0000023 0x06dfd843 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
0000024 0x07a91514 in QTabBar::currentChanged(int) () from /usr/lib/libQtGui.so.4
0000025 0x07a98000 in QTabBar::setCurrentIndex(int) () from /usr/lib/libQtGui.so.4
0000026 0x07a9c4fe in QTabBar::insertTab(int, QIcon const&, QString const&) () from /usr/lib/libQtGui.so.4
0000027 0x07a9f82e in QTabWidget::insertTab(int, QWidget*, QIcon const&, QString const&) () from /usr/lib/libQtGui.so.4
0000028 0x07a9f95b in QTabWidget::addTab(QWidget*, QIcon const&, QString const&) () from /usr/lib/libQtGui.so.4
0000029 0x08096c75 in MainWindow::doOpenFile (this=<value optimized out>, url=<value optimized out>, stale=<value optimized out>) at /home/armido/src/kdenlive/src/mainwindow.cpp:1656
0000030 0x0809e7d2 in MainWindow::recoverFiles (this=<value optimized out>, staleFiles=<value optimized out>) at /home/armido/src/kdenlive/src/mainwindow.cpp:1688
0000031 0x0809f2b9 in MainWindow::openFile (this=<value optimized out>, url=<value optimized out>) at /home/armido/src/kdenlive/src/mainwindow.cpp:1623
0000032 0x0809f45f in MainWindow::openFile (this=<value optimized out>) at /home/armido/src/kdenlive/src/mainwindow.cpp:1585
0000033 0x080a276f in MainWindow::qt_metacall (this=<value optimized out>, _c=<value optimized out>, _id=11, _a=<value optimized out>)
    at /home/armido/src/kdenlive/build/src/cmake_bindir/mainwindow.moc:321
0000034 0x06dfcc0c in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
0000035 0x06dfd059 in QMetaObject::activate(QObject*, QMetaObject const*, int, int, void**) () from /usr/lib/libQtCore.so.4
0000036 0x07617442 in QAction::triggered(bool) () from /usr/lib/libQtGui.so.4
0000037 0x07618a06 in QAction::activate(QAction::ActionEvent) () from /usr/lib/libQtGui.so.4
0000038 0x07ab7d73 in QToolButton::nextCheckState() () from /usr/lib/libQtGui.so.4
0000039 0x079d2714 in ?? () from /usr/lib/libQtGui.so.4
0000040 0x079d29f1 in QAbstractButton::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libQtGui.so.4
0000041 0x07ab827d in QToolButton::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libQtGui.so.4
0000042 0x07672d6f in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
0000043 0x079d09af in QAbstractButton::event(QEvent*) () from /usr/lib/libQtGui.so.4
0000044 0x07abac7b in QToolButton::event(QEvent*) () from /usr/lib/libQtGui.so.4
0000045 0x0761db24 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
0000046 0x07625a90 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
0000047 0x0655b07b in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
0000048 0x06de6d73 in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
0000049 0x07624b97 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&) () from /usr/lib/libQtGui.so.4
0000050 0x076934b8 in ?? () from /usr/lib/libQtGui.so.4
0000051 0x0769291d in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
0000052 0x076bdc92 in ?? () from /usr/lib/libQtGui.so.4
0000053 0x007f4128 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
0000054 0x007f7a58 in ?? () from /lib/libglib-2.0.so.0
0000055 0x007f7b84 in g_main_context_iteration () from /lib/libglib-2.0.so.0
0000056 0x06e11b6d in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000057 0x076bd356 in ?? () from /usr/lib/libQtGui.so.4
#58 0x06de52aa in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000059 0x06de570a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000060 0x06de7bf7 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
0000061 0x0761d9a8 in QApplication::exec() () from /usr/lib/libQtGui.so.4
0000062 0x0807d71d in main (argc=<value optimized out>, argv=<value optimized out>) at /home/armido/src/kdenlive/src/main.cpp:86

Report to http://kdenlive.org/mantis [^]
Steps To ReproduceCut clip.
Restart program.
Additional InformationVideo clips produced by camera have trailing, blank section produced after camera recording is stopped. Clip cut is used to eliminate this extra length.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0004606)
j-b-m (administrator)
2010-02-02 09:29

The crash is in MLT. Which version in installed on your system? Maybe that crash was fixed in MLT's development version. Could you attach a small video clip from your camer here so that we can test it?
(0004627)
j-b-m (administrator)
2010-02-03 23:18

The problem is in FFmpeg, which reported a duration of 14 seconds for the clip (about twice as much as the real duration), which caused the crash in MLT.

The good news is that I just updated to FFMpeg's current svn and the issue is now fixed, the clip duration is now correctly detected (about 6 seconds), and no more crash in Kdenlive.

The fix seems very recent, so you will need to compile FFMpeg by yourself if you want a quick solution.

- Issue History
Date Modified Username Field Change
2010-02-02 01:55 armido New Issue
2010-02-02 09:29 j-b-m Note Added: 0004606
2010-02-02 09:29 j-b-m Status new => feedback
2010-02-03 23:18 j-b-m Note Added: 0004627
2010-02-09 08:51 j-b-m Status feedback => resolved
2010-02-09 08:51 j-b-m Resolution open => no change required
2010-02-09 08:51 j-b-m Assigned To => j-b-m
2010-02-20 08:16 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker