Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001427KdenliveFile Loadingpublic2010-02-07 16:032010-02-20 08:16
Reporternikos.alexandris 
Assigned Toj-b-m 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.7.6 
Target VersionFixed in Version0.7.7 
Summary0001427: Broken (.kdenlive) project file
DescriptionTrying to open a project file on which I've been working for several hours (days?) leads to a segfault [1] _after_ a successful search of missing clips. All other, similar project files (with recursive searching of missing clip some times) work fine.

---
[1] from the command line I always get:

KCrash: Application 'kdenlive' crashing...
sock_file=/home/nik/.kde/socket-vertical/kdeinit4__0

[1]+ Stopped kdenlive dysthanasia_fa.kdenlive
Steps To Reproduce1. launch kdenlive
2. open Some_kdenlive_File.kdenlive
3. search for missing clips (successfully)
4. "OK" to load the project

5. segmentation fault
Tagsfile, load, open, project, segfault
Build/Install Method(select)
Attached Files? file icon corrupted.kdenlive [^] (22,752 bytes) 2010-02-07 16:12

- Relationships

-  Notes
(0004665)
nikos.alexandris (reporter)
2010-02-07 16:06

Application: Kdenlive (kdenlive), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f209fda3750 (LWP 18712))]

Thread 5 (Thread 0x7f2084569910 (LWP 18719)):
#0 0x00007f209b5bc82d in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1 0x00007f209f9c24ba in mlt_consumer_get_frame () from /usr/lib/libmlt.so.2
0000002 0x00007f209f9c261d in mlt_consumer_rt_frame () from /usr/lib/libmlt.so.2
0000003 0x00007f209380b74c in ?? () from /usr/lib/mlt/libmltsdl.so
0000004 0x00007f209b5b7a04 in start_thread () from /lib/libpthread.so.0
0000005 0x00007f209bab080d in clone () from /lib/libc.so.6
0000006 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f2084d6a910 (LWP 18720)):
#0 0x00007f209b5bc5a9 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1 0x00007f209380b08d in ?? () from /usr/lib/mlt/libmltsdl.so
0000002 0x00007f209b5b7a04 in start_thread () from /lib/libpthread.so.0
0000003 0x00007f209bab080d in clone () from /lib/libc.so.6
0000004 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f207bfff910 (LWP 18724)):
#0 0x00007f209b5bc82d in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1 0x00007f209f9c24ba in mlt_consumer_get_frame () from /usr/lib/libmlt.so.2
0000002 0x00007f209f9c261d in mlt_consumer_rt_frame () from /usr/lib/libmlt.so.2
0000003 0x00007f209380b74c in ?? () from /usr/lib/mlt/libmltsdl.so
0000004 0x00007f209b5b7a04 in start_thread () from /lib/libpthread.so.0
0000005 0x00007f209bab080d in clone () from /lib/libc.so.6
0000006 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f207b7fe910 (LWP 18725)):
#0 0x00007f209b5bc5a9 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1 0x00007f209380b08d in ?? () from /usr/lib/mlt/libmltsdl.so
0000002 0x00007f209b5b7a04 in start_thread () from /lib/libpthread.so.0
0000003 0x00007f209bab080d in clone () from /lib/libc.so.6
0000004 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f209fda3750 (LWP 18712)):
[KCrash Handler]
0000005 0x000000000049f3d8 in _start ()
(0004666)
j-b-m (administrator)
2010-02-07 18:14

Ouch, bad news! The file is really corrupted, and the timeline is lost! The cause for this corruption was fixed in latest Kdenlive, but there is no way to recover the project from your attached file.

Don't you have a backup somewhere? I am really sorry about that...
(0004667)
nikos.alexandris (reporter)
2010-02-07 18:47

No, I don't have a backup! I thought kdenlive takes care to keep a backup!? It doesn't matter though. It was a really joyful learning process and I know how I can get back to my project within less than one hour (now that I know more details of editing, applying effects, etc.).

Thanks for the reply and congrats for this very promising tool,
Nikos

- Issue History
Date Modified Username Field Change
2010-02-07 16:03 nikos.alexandris New Issue
2010-02-07 16:06 nikos.alexandris Note Added: 0004665
2010-02-07 16:07 nikos.alexandris Note View State: 4665: private
2010-02-07 16:07 nikos.alexandris Tag Attached: file
2010-02-07 16:07 nikos.alexandris Tag Attached: load
2010-02-07 16:07 nikos.alexandris Tag Attached: open
2010-02-07 16:07 nikos.alexandris Tag Attached: project
2010-02-07 16:07 nikos.alexandris Tag Attached: segfault
2010-02-07 16:07 nikos.alexandris Note View State: 4665: public
2010-02-07 16:12 nikos.alexandris File Added: corrupted.kdenlive
2010-02-07 18:14 j-b-m Note Added: 0004666
2010-02-07 18:14 j-b-m Status new => feedback
2010-02-07 18:47 nikos.alexandris Note Added: 0004667
2010-02-07 18:47 nikos.alexandris Status feedback => new
2010-02-09 08:45 j-b-m Status new => resolved
2010-02-09 08:45 j-b-m Fixed in Version => 0.7.7
2010-02-09 08:45 j-b-m Resolution open => fixed
2010-02-09 08:45 j-b-m Assigned To => j-b-m
2010-02-20 08:16 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker