Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001451KdenliveBuild Systempublic2010-02-19 05:142010-09-22 17:53
Reporterdurka42 
Assigned To 
PrioritynormalSeverityminorReproducibilityN/A
StatusclosedResolutionfixed 
PlatformMacportsOSOSX Snow LeopardOS Version10.6.2
Product Version0.7.6 
Target Version0.7.7Fixed in Version0.7.7 
Summary0001451: Feature request: remove dependency on nepomuk
DescriptionKdenlive will not install through Macports because it cannot find nepomuk.

I cannot imagine why a video editing suite would require nepomuk (partly because I can't figure out what nepomuk really is).

The feature request is to remove the dependency (by default or optionally, through some configure args).
Steps To Reproduce1. Install Macports
2. sudo port -v install kdenlive
TagsNo tags attached.
Build/Install Method3rd party package
Attached Files

- Relationships
related to 0001457closedj-b-m find_package(Nepomuk) should be macro_optional_find_package(Nepomuk) 

-  Notes
(0004728)
xzhayon (developer)
2010-02-19 08:53

there is a very good reason to depend on nepomuk: the dependency was first added to let clip descriptions being exported to the whole system, and now that nepomuk is becoming (is it?) a key component in the kde environment, it will let us (theoretically) do some other cute things

therefore, i'll add a build time option to disable it (just like NO_JOGSHUTTLE), but i cannot guarantee that it will be maintainable over the centuries :)
(0004739)
gmarco (reporter)
2010-02-21 20:41

still in (since revision 4124), nepomuk is optional and only be used if found.
(0004740)
xzhayon (developer)
2010-02-21 20:53

ah, good... closing, then
at least it will go in the changelog :)

- Issue History
Date Modified Username Field Change
2010-02-19 05:14 durka42 New Issue
2010-02-19 08:48 xzhayon Status new => assigned
2010-02-19 08:48 xzhayon Assigned To => xzhayon
2010-02-19 08:53 xzhayon Note Added: 0004728
2010-02-19 08:54 xzhayon Target Version => future version
2010-02-21 20:41 gmarco Note Added: 0004739
2010-02-21 20:53 xzhayon Note Added: 0004740
2010-02-21 20:53 xzhayon Status assigned => resolved
2010-02-21 20:53 xzhayon Fixed in Version => 0.7.7
2010-02-21 20:53 xzhayon Resolution open => fixed
2010-02-21 20:53 xzhayon Assigned To xzhayon =>
2010-02-21 20:55 xzhayon Status resolved => closed
2010-02-22 16:34 j-b-m Relationship added related to 0001457
2010-09-22 17:53 Granjow Target Version future version => 0.7.7


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker