Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001613KdenliveEffectspublic2010-05-24 17:432010-09-14 23:00
Reporterskfin 
Assigned Toxzhayon 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.7.7.1 
Target VersionFixed in Version0.7.8 
Summary0001613: Kdenlive crashes while moving text
DescriptionIn text clip editor, kdenlive crashes while dragging text blocks. Doesnt crash on every block but some texts cause it to crash every time.
Steps To ReproduceOpen text clip editor, make few text blocks and drag them.
Additional InformationIncluded kcrash report, hope it is useful.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Filestxt file icon kdenlive-20100524.txt [^] (12,676 bytes) 2010-05-24 17:43 [Show Content]

- Relationships
duplicate of 0001573closedxzhayon Crash after adding, changing and remove blur effect for text in title composer 

-  Notes
(0005202)
skfin (reporter)
2010-05-24 17:47

skfin@paranoid:~$ gdb kdenlive
GNU gdb (GDB) 7.1-ubuntu
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html> [^]
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>... [^]
Reading symbols from /usr/bin/kdenlive...Reading symbols from /usr/lib/debug/usr/bin/kdenlive...done.
done.
(gdb) run
Starting program: /usr/bin/kdenlive
[Thread debugging using libthread_db enabled]
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: Tiedostoa tai hakemistoa ei ole
[New Thread 0xb592cb70 (LWP 9349)]
QFileSystemWatcher: failed to add paths: /home/skfin/.config/ibus/bus
Bus::open: Can not get ibus-daemon's address.
IBusInputContext::createInputContext: no connection to ibus-daemon
[New Thread 0xb4da7b70 (LWP 9350)]
[New Thread 0xb45a6b70 (LWP 9351)]
[Thread 0xb4da7b70 (LWP 9350) exited]
[Thread 0xb45a6b70 (LWP 9351) exited]
[New Thread 0xb45a6b70 (LWP 9352)]
[New Thread 0xb4da7b70 (LWP 9353)]
[Thread 0xb45a6b70 (LWP 9352) exited]
[Thread 0xb4da7b70 (LWP 9353) exited]
[New Thread 0xb4da7b70 (LWP 9354)]
[New Thread 0xb45a6b70 (LWP 9355)]
[Thread 0xb4da7b70 (LWP 9354) exited]
[Thread 0xb45a6b70 (LWP 9355) exited]
[New Thread 0xb45a6b70 (LWP 9356)]
[New Thread 0xb4da7b70 (LWP 9357)]
kdenlive(9341)/kdecore (services) KMimeTypeFactory::parseMagic: Now parsing "/usr/share/mime/magic"
kdenlive(9341)/kdecore (services) KMimeTypeFactory::parseMagic: Now parsing "/home/skfin/.local/share/mime/magic"
[New Thread 0xb2d21b70 (LWP 9359)]
[New Thread 0xb2520b70 (LWP 9360)]
[Thread 0xb45a6b70 (LWP 9356) exited]
[Thread 0xb4da7b70 (LWP 9357) exited]
[New Thread 0xb4da7b70 (LWP 9361)]
[New Thread 0xb45a6b70 (LWP 9362)]
[Thread 0xb2d21b70 (LWP 9359) exited]
[Thread 0xb2520b70 (LWP 9360) exited]
[Thread 0xb4da7b70 (LWP 9361) exited]
[Thread 0xb45a6b70 (LWP 9362) exited]
[New Thread 0xb45a6b70 (LWP 9363)]
[New Thread 0xb4da7b70 (LWP 9364)]
QPixmap: It is not safe to use pixmaps outside the GUI thread

Program received signal SIGSEGV, Segmentation fault.
QPixmapBlurFilter::radius (this=0x90a1a90) at image/qpixmapfilter.cpp:555
555 image/qpixmapfilter.cpp: Tiedostoa tai hakemistoa ei ole.
    in image/qpixmapfilter.cpp
(gdb)
(0005203)
ttill (developer)
2010-05-24 18:05

This is related to using the blur effect. The bug is already resolved in current SVN.

- Issue History
Date Modified Username Field Change
2010-05-24 17:43 skfin New Issue
2010-05-24 17:43 skfin File Added: kdenlive-20100524.txt
2010-05-24 17:47 skfin Note Added: 0005202
2010-05-24 18:05 ttill Note Added: 0005203
2010-05-24 18:05 ttill Relationship added duplicate of 0001573
2010-05-24 18:06 ttill Assigned To => xzhayon
2010-05-24 18:06 ttill Status new => resolved
2010-05-24 18:06 ttill Resolution open => fixed
2010-05-24 18:06 ttill Fixed in Version => Recent git
2010-09-14 11:01 j-b-m Fixed in Version Recent git => 0.7.8
2010-09-14 23:00 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker