Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001695KdenliveBuild Systempublic2010-07-17 19:382010-09-14 23:01
Reportersunab 
Assigned Tottill 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
Platformi386 and amd64OSUbuntu JauntyOS Version9.04
Product VersionRecent git 
Target VersionFixed in Version0.7.8 
Summary0001695: latest svn fails to build with Qt 4.5
DescriptionUsing Soyuz (Launchpad automated build system for packages in a clean virtual machine), Kdenlive build blocks on that error :

/build/buildd/kdenlive-0.7.7.1+svn20100717.r4588/src/vectorscope.cpp: In member function 'void Vectorscope::calculateScope()':
/build/buildd/kdenlive-0.7.7.1+svn20100717.r4588/src/vectorscope.cpp:255: error: 'class QImage' has no member named 'byteCount'
/build/buildd/kdenlive-0.7.7.1+svn20100717.r4588/src/vectorscope.cpp:260: error: 'class QImage' has no member named 'byteCount'
make[3]: *** [src/cmake_bindir/CMakeFiles/kdenlive.dir/vectorscope.o] Error 1
make[3]: Leaving directory `/build/buildd/kdenlive-0.7.7.1+svn20100717.r4588/obj-i486-linux-gnu'
make[2]: *** [src/cmake_bindir/CMakeFiles/kdenlive.dir/all] Error 2
make[2]: Leaving directory `/build/buildd/kdenlive-0.7.7.1+svn20100717.r4588/obj-i486-linux-gnu'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/build/buildd/kdenlive-0.7.7.1+svn20100717.r4588/obj-i486-linux-gnu'
make: *** [debian/stamp-makefile-build] Error 2
dpkg-buildpackage: failure: debian/rules build gave error exit status 2
Steps To ReproduceIn Ubuntu 9.04 there is Qt 4.5.0 (KDE 4.2.2).
This happens in 3 different architectures : i386, amd64 and lpia

Note that it builds fine with Ubuntu 10.04 where Qt is 4.6.
Additional Informationjbm fixed a similar issue (0001673) when the new effectstack_ui was introduced. Here the problem is with the new vertorscope thing.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0005361)
ttill (developer)
2010-07-17 20:19

Should be fixed in svn rev. 4589
(0005362)
sunab (reporter)
2010-07-17 22:04

not fixed in r4589 but different error :

/build/buildd/kdenlive-0.7.7.1+svn20100717.r4589/src/colorplaneexport.cpp: In constructor 'ColorPlaneExport::ColorPlaneExport(QWidget*)':
/build/buildd/kdenlive-0.7.7.1+svn20100717.r4589/src/colorplaneexport.cpp:50: error: 'class KUrlRequester' has no member named 'setText'
/build/buildd/kdenlive-0.7.7.1+svn20100717.r4589/src/colorplaneexport.cpp: In member function 'void ColorPlaneExport::slotExportPlane()':
/build/buildd/kdenlive-0.7.7.1+svn20100717.r4589/src/colorplaneexport.cpp:144: error: 'class KUrlRequester' has no member named 'setText'
make[3]: *** [src/cmake_bindir/CMakeFiles/kdenlive.dir/colorplaneexport.o] Error 1
make[3]: Leaving directory `/build/buildd/kdenlive-0.7.7.1+svn20100717.r4589/obj-i486-linux-gnu'
make[2]: *** [src/cmake_bindir/CMakeFiles/kdenlive.dir/all] Error 2
make[2]: Leaving directory `/build/buildd/kdenlive-0.7.7.1+svn20100717.r4589/obj-i486-linux-gnu'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/build/buildd/kdenlive-0.7.7.1+svn20100717.r4589/obj-i486-linux-gnu'
make: *** [debian/stamp-makefile-build] Error 2
dpkg-buildpackage: failure: debian/rules build gave error exit status 2
(0005363)
ttill (developer)
2010-07-17 22:38

Does it work now after r4591, or do some other errors appear?
(0005366)
sunab (reporter)
2010-07-18 21:44

on revision 4599 all is fine, its builds fine with no errors.
Thanks

- Issue History
Date Modified Username Field Change
2010-07-17 19:38 sunab New Issue
2010-07-17 20:19 ttill Note Added: 0005361
2010-07-17 20:20 ttill Assigned To => ttill
2010-07-17 20:20 ttill Status new => feedback
2010-07-17 22:04 sunab Note Added: 0005362
2010-07-17 22:04 sunab Status feedback => assigned
2010-07-17 22:38 ttill Note Added: 0005363
2010-07-17 22:38 ttill Status assigned => feedback
2010-07-18 21:44 sunab Note Added: 0005366
2010-07-18 21:44 sunab Status feedback => assigned
2010-07-18 21:52 ttill Status assigned => resolved
2010-07-18 21:52 ttill Resolution open => fixed
2010-07-18 21:52 ttill Fixed in Version => Recent git
2010-09-14 11:01 j-b-m Fixed in Version Recent git => 0.7.8
2010-09-14 23:01 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker