Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001699KdenliveUser Interfacepublic2010-07-19 20:252013-04-07 08:45
Reportermcfrisk 
Assigned Toptitmain 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platform32bit x86OSDebianOS Versionunstable
Product VersionRecent git 
Target VersionFixed in Version0.9.6 
Summary0001699: clip preview video hangs after changing clip in and out points
DescriptionWhile going through a large number of clips in a project, I've noticed following.

When a dnxhd clip is first seeked and not played and in and out points are changed, playing the clip from cursor position does not work. Video is hung at the frame of the previous position. Stopping preview and rewinding cursor to the previous position makes the video display properly.

So for every playback after in and out point change I have to play-stop-rewind-play to actually see the clip.
Steps To ReproduceStart kdenlive with a new project, add a dnxhd clip to project (for example http://mcfrisk.kapsi.fi/media/2010/libswscale_crash_00109.m2ts.dnxhd.mov [^] ).

Select clip.

Move cursor two seconds forward by pressing shift and arrow right twice. Press o to set out point.

Move cursor one second back by pressing shift and left. Press i to set in point.

Move cursor to beginning by pressing shift and left. Start playback with space bar.

Notice that video playback starts only after the outpoint but audio playback works correctly.

Now rewind back with shift left and play with space bar. Notice that now video playback works.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0009235)
ptitmain (developer)
2013-02-10 00:09

Is this bug still present in recent version of kdenlive ?
I tried to reproduce it but setting a zone seems to be ok when playing it (with space or ctrl space)...
(0009413)
ptitmain (developer)
2013-03-24 16:49

Hi,
I think this bug is probably solved in recent versions of Kdenlive. Thus, I proposed to close this bug. Thank you for reporting it ! In case this bug appears again, please do not hesitate to revive this thread or to open a new bug.

- Issue History
Date Modified Username Field Change
2010-07-19 20:25 mcfrisk New Issue
2013-02-10 00:09 ptitmain Note Added: 0009235
2013-02-10 00:09 ptitmain Assigned To => ptitmain
2013-02-10 00:09 ptitmain Status new => feedback
2013-03-24 16:49 ptitmain Note Added: 0009413
2013-03-24 16:49 ptitmain Status feedback => resolved
2013-03-24 16:49 ptitmain Resolution open => fixed
2013-04-07 08:45 j-b-m Fixed in Version => 0.9.6
2013-04-07 08:45 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker