Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001717KdenliveMLTpublic2010-07-30 03:292011-11-01 18:56
Reporterwalxo 
Assigned Toddennedy 
PriorityhighSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSUbuntuOS Version10.04
Product Version0.7.7.1 
Target VersionFixed in Version0.8.2 
Summary0001717: Crash if playing end of clip
DescriptionGoing to the end of the timeline with movie which last thumbnail is white (like empty frame) causes program crash.

(Cant figure out why some clips are visualized with "white end". All tests are made with a phone camera.)
Additional InformationProgram received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb5fbab70 (LWP 10011)]
0x01c04fc6 in ?? () from /lib/tls/i686/cmov/libc.so.6
(gdb) thread apply all bt

Thread 14 (Thread 0xb1bb1b70 (LWP 10016)):
#0 0x0012d422 in __kernel_vsyscall ()
#1 0x00f72342 in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib/tls/i686/cmov/libpthread.so.0
0000002 0x00d5120f in QWaitCondition::wait(QMutex*, unsigned long) ()
   from /usr/lib/libQtCore.so.4
0000003 0x00d452eb in ?? () from /usr/lib/libQtCore.so.4
0000004 0x00d5032e in ?? () from /usr/lib/libQtCore.so.4
0000005 0x00f6d96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
0000006 0x01c5da4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 13 (Thread 0xb2fb4b70 (LWP 10015)):
#0 0x0012d422 in __kernel_vsyscall ()
#1 0x00f72015 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/i686/cmov/libpthread.so.0
0000002 0x0391649f in ?? () from /usr/lib/mlt/libmltsdl.so
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 12 (Thread 0xb37b5b70 (LWP 10014)):
#0 0x0012d422 in __kernel_vsyscall ()
#1 0x00f72342 in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib/tls/i686/cmov/libpthread.so.0
---Type <return> to continue, or q <return> to quit---
0000002 0x00143289 in mlt_consumer_get_frame () from /usr/lib/libmlt.so.2
0000003 0xb37b51b8 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 11 (Thread 0xb57b9b70 (LWP 10012)):
#0 0x0012d422 in __kernel_vsyscall ()
#1 0x00f72015 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/i686/cmov/libpthread.so.0
0000002 0x0391649f in ?? () from /usr/lib/mlt/libmltsdl.so
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 10 (Thread 0xb5fbab70 (LWP 10011)):
#0 0x01c04fc6 in ?? () from /lib/tls/i686/cmov/libc.so.6
#1 0xb6649ea4 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 1 (Thread 0xb7fd9930 (LWP 10000)):
#0 0x0012d422 in __kernel_vsyscall ()
#1 0x01c4fb86 in poll () from /lib/tls/i686/cmov/libc.so.6
0000002 0x0225a4eb in g_poll () from /lib/libglib-2.0.so.0
0000003 0x0224d0ac in ?? () from /lib/libglib-2.0.so.0
0000004 0x0224d4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
0000005 0x00e7e5d5 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::Process---Type <return> to continue, or q <return> to quit---
EventsFlag>) () from /usr/lib/libQtCore.so.4
0000006 0x011ce135 in ?? () from /usr/lib/libQtGui.so.4

0000007 0x00e51059 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000008 0x00e514aa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /usr/lib/libQtCore.so.4
0000009 0x00e5569f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
0000010 0x0110e577 in QApplication::exec() () from /usr/lib/libQtGui.so.4

0000011 0x08082a9d in _start ()
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Filesgz file icon 10072010028.mp4.tar.gz [^] (9,068,870 bytes) 2010-07-30 13:57

- Relationships

-  Notes
(0005423)
walxo (reporter)
2010-07-30 14:00

I've uploaded a test movie with d?scribed problem...
(0005461)
ttill (developer)
2010-08-03 11:41

Crashes for me, too.
I also have some files with the last frame(s) beeing white, but they do not crash.
(0005817)
ttill (developer)
2010-09-12 15:30

I cannot reproduce anymore, so I guess Dan fixed this in MLT somewhere between the MLT 0.5.6 release and now.
(0005834)
walxo (reporter)
2010-09-14 01:06

Well-done! Thank you! :)
(0005880)
ddennedy (developer)
2010-09-22 05:38

Yes, the first git commit after the 0.5.6 release.
0d8eb5b94dcfadffd8e4d67efd62ec09a0934c7f

- Issue History
Date Modified Username Field Change
2010-07-30 03:29 walxo New Issue
2010-07-30 13:57 walxo File Added: 10072010028.mp4.tar.gz
2010-07-30 14:00 walxo Note Added: 0005423
2010-08-03 11:41 ttill Note Added: 0005461
2010-08-03 11:42 ttill Status new => acknowledged
2010-08-03 11:42 ttill Category File Loading => MLT
2010-08-03 11:42 ttill Summary Crash if the end of the movie is selected => Crash if playing end of clip
2010-08-03 11:42 ttill Additional Information Updated View Revisions
2010-09-12 15:30 ttill Note Added: 0005817
2010-09-14 01:06 walxo Note Added: 0005834
2010-09-22 05:38 ddennedy Note Added: 0005880
2010-09-22 05:38 ddennedy Status acknowledged => resolved
2010-09-22 05:38 ddennedy Fixed in Version => 0.7.8
2010-09-22 05:38 ddennedy Resolution open => fixed
2010-09-22 05:38 ddennedy Assigned To => ddennedy
2011-07-05 12:15 j-b-m Fixed in Version 0.7.8 => 0.8.2
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker