Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001720KdenliveMLTpublic2010-07-31 00:592011-11-01 18:56
Reportermrbumpy4096 
Assigned Toddennedy 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platformi686OSKubuntuOS Version10.04
Product Version0.7.7.1 
Target VersionFixed in Version0.8.2 
Summary0001720: crash when adding lossless Matroska file to project
DescriptionI used Kdenlive's transcode option to create a lossless Matroska file. When I try to add this file to the project tree, Kdenlive segfaults.
Steps To ReproduceI captured 3.5 minutes of my desktop using the following ffmpeg command:
ffmpeg -f x11grab -r 30 -s 1088x612 -i :0.0 -vcodec libx264 -vpre lossless_ultrafast -threads 0 output.mkv

The resulting file is 7.6 MB in size, and I rename it to:
Scarlatti K466 sheet music.mkv

However, if I crop the beginning off of the resulting video in Kdenlive, the first several seconds of the video are garbled (it's missing a keyframe, I'm guessing). So I convert the video to lossless Matroska in an attempt to get around this. These are the options I use:

-an -sn -vcodec huffyuv %1.mkv

The transcoded file is 1.5 GB in size, and I name it:
Scarlatti K466 sheet music-lossless.mkv

Then, when I drag the file into my project (or even a blank project), Kdenlive segfaults.
Additional InformationThe crash happens with both MLT version 0.5.4 (ubuntu repository) and 0.5.6 (ppa:sunab/ppa). I generated the bug report using version 0.5.4 since sunab's repository doesn't contain the debug packages for 0.5.6.

** My System **
Motherboard: MSI K9N SLI Platinum (nForce 570 SLI chipset)
CPU: AMD Athlon(tm) 64 Processor 4000+ (2.6 GHz)
RAM: 2GB DDR2
Video: Dell NVIDIA GeForce 7800 GTX w/ 256 MB RAM (PCI Express)
OS: Kubuntu 10.04 i386 w/ KDE 4.4.5
Linux Kernel: 2.6.32-24-lowlatency
NVIDIA driver: 195.36.15
Screen Resolution: 1280 x 960
X.org: 7.5
Qt: 4.6.2
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files? file icon kdenlive-20100730.kcrash [^] (5,831 bytes) 2010-07-31 00:59 [Show Content]

- Relationships

-  Notes
(0005424)
mrbumpy4096 (reporter)
2010-07-31 01:07

I tried playing the lossless Matroska file with ffplay and melt. Neither played the file and both had the same error.

ffplay:
Error generating huffman table
lossless.mkv: could not open codecs

melt:
Error generating huffman table
Segmentation fault 0
(0005425)
mrbumpy4096 (reporter)
2010-07-31 01:23
edited on: 2010-07-31 01:24

If I convert the original file to an .avi rather than .mkv file, then ffplay, melt, and Kdenlive all are happy with it. I make the conversion from the command line:

ffmpeg -i input.mkv -an -sn -vcodec huffyuv output.avi

(0005460)
ttill (developer)
2010-08-03 11:40

Maybe just something went wrong during transcoding. Did you try to transcode a second time? For me the transcode profile works.
However I noticed the quality of the file (ffmpeg -f x11grab -r 30 -s 1280x720 -i :0.0 -vcodec libx264 -vpre lossless_ultrafast -threads 0 output.mkv) is way better in ffplay than in melt or kdenlive.
(0005469)
mrbumpy4096 (reporter)
2010-08-04 01:07

re-transcoding the file results in the same errors and Kdenlive crash. VLC plays the file just fine. Would you like me to send you the file I'm transcoding from? It's only 7.6 MB in size. Perhaps you might be able to reproduce the crash with my file. Just let me know how you'd like me to get the file to you.
(0005484)
ttill (developer)
2010-08-08 21:07

I recorded a file with your command and transcoded it afterwards with the options you gave, but Kdenlive does not crash.
If you want you can send the file to "root [at] ttill . de"
(0005553)
ttill (developer)
2010-08-11 15:18

I tried with the file you sent but could not reproduce. As it does not work in ffplay for you the problem is probably there. Maybe this is something that was fixed in the meantime (I use ffmpeg from svn).
Additionally I can also use the original file and crop from its beginning without it looking different.
(0005559)
mrbumpy4096 (reporter)
2010-08-11 17:54

Thanks for all your time, anyway. At least I have a workaround for now (transcoding to AVI).
(0005887)
ddennedy (developer)
2010-09-22 06:04

Fixed in MLT git commit 713917b4b3bb6d764996e348a3178b3a21c4e8b0 for the 0.5.8 version.

- Issue History
Date Modified Username Field Change
2010-07-31 00:59 mrbumpy4096 New Issue
2010-07-31 00:59 mrbumpy4096 File Added: kdenlive-20100730.kcrash
2010-07-31 01:07 mrbumpy4096 Note Added: 0005424
2010-07-31 01:23 mrbumpy4096 Note Added: 0005425
2010-07-31 01:24 mrbumpy4096 Note Edited: 0005425 View Revisions
2010-08-03 11:40 ttill Note Added: 0005460
2010-08-03 11:40 ttill Status new => feedback
2010-08-04 01:07 mrbumpy4096 Note Added: 0005469
2010-08-04 01:07 mrbumpy4096 Status feedback => new
2010-08-08 21:07 ttill Note Added: 0005484
2010-08-11 15:18 ttill Note Added: 0005553
2010-08-11 17:54 mrbumpy4096 Note Added: 0005559
2010-09-22 06:04 ddennedy Note Added: 0005887
2010-09-22 06:04 ddennedy Status new => resolved
2010-09-22 06:04 ddennedy Fixed in Version => 0.7.8
2010-09-22 06:04 ddennedy Resolution open => fixed
2010-09-22 06:04 ddennedy Assigned To => ddennedy
2011-07-05 12:15 j-b-m Fixed in Version 0.7.8 => 0.8.2
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker