Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001730KdenliveUser Interfacepublic2010-08-03 21:432010-09-14 23:01
Reportertidris769 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platform32 bit intelOSUbuntu LinuxOS Version9.10
Product VersionRecent git 
Target VersionFixed in Version0.7.8 
Summary0001730: Odd behavior in composite transition UI
DescriptionThe position control (text + up/down arrows) for the composite transition UI has problems when the video profile is 720p 59.94 fps and the control is displaying the hh:mm:ss:ff format. Problems go away with video profile 720p 60 fps.

First problem is that the position control sometimes displays negative position values such as 00:00:00:-2 and 00:00:00:-1.

Second problem is that the up arrow in the position control sometimes decreases the position value instead of increasing it.
Steps To Reproduce1- Create new project.
2- Add color clip to the project.
3- Drag color clip to timeline.
4- Add composite transition to color clip and enlarge the transition so it spans the entire clip.
5- Click the composite transition to activate its UI.
6- In the composite transition UI, slowly drag the position triangle from left to right. Note how the position control displays values such as 00:00:00;-2 and 00:00:00;-1 when the position is near zero.
7- Drag the position triangle all the way to the left.
8- Click the up arrow in the position control once. Note the position reading goes from 00:00:00;00 to 00:00:00;01 as expected.
9- Click the up arrow in the position control again. Note the position moved down to 00:00:00;00 instead of going up to 00:00:00;02.
Additional Informationsvn 4680
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0005467)
tidris769 (reporter)
2010-08-03 21:56

The affine transition UI has the same problem.
(0005490)
j-b-m (administrator)
2010-08-08 22:06

Can you please try svn rev. 4688 and tell me if the issue is fixed?
(0005492)
tidris769 (reporter)
2010-08-08 23:14

This looks fixed on svn 4689. I did notice that when the composite transition UI is first activated, the text box that shows the position is initially blank instead of showing 00:00:00;00. Not sure if that can be called a bug or not.
(0005494)
j-b-m (administrator)
2010-08-08 23:39

Blank timecode at startup is also fixed now, closing this one.

- Issue History
Date Modified Username Field Change
2010-08-03 21:43 tidris769 New Issue
2010-08-03 21:56 tidris769 Note Added: 0005467
2010-08-08 16:04 j-b-m Assigned To => j-b-m
2010-08-08 16:04 j-b-m Status new => assigned
2010-08-08 22:06 j-b-m Note Added: 0005490
2010-08-08 22:06 j-b-m Status assigned => feedback
2010-08-08 23:14 tidris769 Note Added: 0005492
2010-08-08 23:14 tidris769 Status feedback => assigned
2010-08-08 23:39 j-b-m Note Added: 0005494
2010-08-08 23:39 j-b-m Status assigned => resolved
2010-08-08 23:39 j-b-m Fixed in Version => Recent git
2010-08-08 23:39 j-b-m Resolution open => fixed
2010-09-14 11:00 j-b-m Fixed in Version Recent git => 0.7.8
2010-09-14 23:01 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker