Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001763KdenliveMLTpublic2010-08-23 15:212010-09-14 23:01
ReporterGranjow 
Assigned Toddennedy 
PrioritynormalSeveritycrashReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version0.7.8 
Summary0001763: Segfault in consumer_sdl_still.c when clicking a clip in the project tree
DescriptionSegfault in the last line of this snipplet from consumer_sdl_still.c:

    if ( this->sdl_screen == NULL || changed )
    {
        // open SDL window
        pthread_mutex_lock( &mlt_sdl_mutex );
        this->sdl_screen = SDL_SetVideoMode( this->window_width, this->window_height, 0, this->sdl_flags );
        if ( consumer_get_dimensions( &this->window_width, &this->window_height ) )
            this->sdl_screen = SDL_SetVideoMode( this->window_width, this->window_height, 0, this->sdl_flags );
        pthread_mutex_unlock( &mlt_sdl_mutex );

        uint32_t color = mlt_properties_get_int( this->properties, "window_background" );
        SDL_FillRect( this->sdl_screen, NULL, color >> 8 );
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0005660)
Granjow (developer)
2010-08-23 15:45
edited on: 2010-08-23 15:46

Was finally able to load the project after removing all generated thumbnails and rebuilding them. kdenlive also doesn't crash anymore since.

(0005727)
ttill (developer)
2010-08-31 22:57

Looks like Dan already fixed it:
http://mltframework.org/gitweb/mlt.git?p=mltframework.org/mlt.git;a=commitdiff;h=eb884ab888d9f3b0ad831e4b6e2f2fc3bf5738f2 [^]
(0005737)
Granjow (developer)
2010-09-01 10:38

Okay, closing.

- Issue History
Date Modified Username Field Change
2010-08-23 15:21 Granjow New Issue
2010-08-23 15:28 Granjow Summary Segfault when clicking any clip in the project tree => Segfault in consumer_sdl_still.c when clicking any clip in the project tree
2010-08-23 15:45 Granjow Note Added: 0005660
2010-08-23 15:45 Granjow Summary Segfault in consumer_sdl_still.c when clicking any clip in the project tree => Segfault in consumer_sdl_still.c when clicking a clip in the project tree
2010-08-23 15:46 Granjow Note Edited: 0005660 View Revisions
2010-08-31 22:57 ttill Note Added: 0005727
2010-08-31 22:58 ttill Status new => feedback
2010-09-01 10:38 Granjow Note Added: 0005737
2010-09-01 10:38 Granjow Status feedback => new
2010-09-01 10:38 Granjow Status new => resolved
2010-09-01 10:38 Granjow Fixed in Version => Recent git
2010-09-01 10:38 Granjow Resolution open => fixed
2010-09-01 10:38 Granjow Assigned To => ddennedy
2010-09-14 11:00 j-b-m Fixed in Version Recent git => 0.7.8
2010-09-14 23:01 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker