Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001775KdenliveMLTpublic2010-08-25 17:442010-09-14 23:17
Reportertidris769 
Assigned Toddennedy 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionwon't fix 
Platform32 bit intel and alikeOSUbuntu LinuxOS Version9.10
Product VersionRecent git 
Target VersionFixed in Version 
Summary0001775: Blue Screen Effect Doesn't Work Right on Grayscale Clips
DescriptionThere is big trouble when the blue screen effect is used on grayscale clips.

If the key color is set to any grayscale level then all grayscale levels in the clip become transparent whenever the variance is 1 or higher.

Also if the key color is pure black then all grayscale pixels become transparent even with variance at 0.
Steps To Reproduce- Create new project.
- Add a video or picture clip to project.
- Drag video or picture clip to timeline.
- Drag grayscale effect to clip in timeline.
- Drag blue screen effect to clip in timeline.
- Set variance to 0 in blue screen UI.
- Use the dropper tool in blue screen UI to set key color to a shade of gray from the clip. Note none of the pixels become transparent at this point.
- Set variance to 1. Note all pixels become transparent regardless of what grayscale level they have.
- Set variance to 0. Note none of the pixels are transparent now.
- Set key color to pure black through the Select Color pop up window. Note all the pixels are now transparent regardless of grayscale level.
Additional InformationUsing current mlt as well as current kdenlive.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0005677)
tidris769 (reporter)
2010-08-25 17:53

Forgot to list one important step, which is to add a composite transition against the black track to the clip in on the timeline.
(0005691)
ddennedy (developer)
2010-08-28 07:36

This is _by design_. It is a _chroma_ key filter; not a luma key.

- Issue History
Date Modified Username Field Change
2010-08-25 17:44 tidris769 New Issue
2010-08-25 17:53 tidris769 Note Added: 0005677
2010-08-28 07:36 ddennedy Note Added: 0005691
2010-08-28 07:36 ddennedy Status new => resolved
2010-08-28 07:36 ddennedy Resolution open => won't fix
2010-08-28 07:36 ddennedy Assigned To => ddennedy
2010-09-14 23:17 ttill Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker