Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001780KdenliveMLTpublic2010-08-28 10:122010-09-14 23:01
ReporterGranjow 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionunable to reproduce 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version0.7.8 
Summary0001780: Segfault in swscale_template.c after pressing play in a monitor
DescriptionLast line here:

inline static void RENAME(hcscale)(SwsContext *c, uint16_t *dst, long dstWidth, const uint8_t *src1, const uint8_t *src2,
                                   int srcW, int xInc, const int16_t *hChrFilter,
                                   const int16_t *hChrFilterPos, int hChrFilterSize,
                                   uint8_t *formatConvBuffer,
                                   uint32_t *pal)
{

    src1 += c->chrSrcOffset;
    src2 += c->chrSrcOffset;

    if (c->chrToYV12) {
        c->chrToYV12(formatConvBuffer, formatConvBuffer+VOFW, src1, src2, srcW, pal);
        src1= formatConvBuffer;
        src2= formatConvBuffer+VOFW;
    }

    if (!c->hcscale_fast) {
        c->hScale(dst , dstWidth, src1, srcW, xInc, hChrFilter, hChrFilterPos, hChrFilterSize);
Additional Information0 ?? 0 0x0000000000000000
1 hcscale_MMX2 swscale_template.c 2544 0x00007fffe2a37500
2 swScale_MMX2 swscale_template.c 2714 0x00007fffe2a37500
3 sws_scale swscale.c 1952 0x00007fffe2a39889
4 av_convert_image filter_avcolour_space.c 102 0x00007fffe3e122d6
5 convert_image filter_avcolour_space.c 163 0x00007fffe3e122d6
6 mlt_frame_get_image mlt_frame.c 396 0x00007ffff78abd9f
7 filter_get_image filter_crop.c 75 0x00007fffddd0643b
8 mlt_frame_get_image mlt_frame.c 389 0x00007ffff78abd3a
9 filter_get_image filter_deinterlace.c 218 0x00007fffe7dd429e
10 mlt_frame_get_image mlt_frame.c 389 0x00007ffff78abd3a
11 filter_get_image filter_rescale.c 218 0x00007fffddd0b444
12 mlt_frame_get_image mlt_frame.c 389 0x00007ffff78abd3a
13 filter_get_image filter_resize.c 262 0x00007fffddd0b945
14 mlt_frame_get_image mlt_frame.c 389 0x00007ffff78abd3a
15 consumer_read_ahead_thread mlt_consumer.c 705 0x00007ffff78b8fb9
16 start_thread /lib/libpthread.so.0 0 0x00007ffff25398ba
17 clone /lib/libc.so.6 0 0x00007ffff281e01d
18 ?? 0 0x0000000000000000
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files? file icon Haselbogen.kdenlive [^] (210,789 bytes) 2010-08-28 10:18

- Relationships

-  Notes
(0005694)
Granjow (developer)
2010-08-28 10:14

Next crash here:
static inline void RENAME(yuv2packedX)(SwsContext *c, const int16_t *lumFilter, const int16_t **lumSrc, int lumFilterSize,
                                       const int16_t *chrFilter, const int16_t **chrSrc, int chrFilterSize,
                                       const int16_t **alpSrc, uint8_t *dest, long dstW, long dstY)
{
#if COMPILE_TEMPLATE_MMX
    x86_reg dummy=0;
    x86_reg dstW_reg = dstW;
    if(!(c->flags & SWS_BITEXACT)) {
        if (c->flags & SWS_ACCURATE_RND) {
            switch(c->dstFormat) {
            case PIX_FMT_RGB32:
                if (CONFIG_SWSCALE_ALPHA && c->alpPixBuf) {
                    YSCALEYUV2PACKEDX_ACCURATE
                    YSCALEYUV2RGBX
                    "movq %%mm2, "U_TEMP"(%0) \n\t"
                    "movq %%mm4, "V_TEMP"(%0) \n\t"
                    "movq %%mm5, "Y_TEMP"(%0) \n\t"
                    YSCALEYUV2PACKEDX_ACCURATE_YA(ALP_MMX_FILTER_OFFSET)
                    "movq "Y_TEMP"(%0), %%mm5 \n\t"
                    "psraw $3, %%mm1 \n\t"
                    "psraw $3, %%mm7 \n\t"
                    "packuswb %%mm7, %%mm1 \n\t"
                    WRITEBGR32(%4, %5, %%REGa, %%mm3, %%mm4, %%mm5, %%mm1, %%mm0, %%mm7, %%mm2, %%mm6)

                    YSCALEYUV2PACKEDX_END
                } else {
                    YSCALEYUV2PACKEDX_ACCURATE
                    YSCALEYUV2RGBX
                    "pcmpeqd %%mm7, %%mm7 \n\t"
                    WRITEBGR32(%4, %5, %%REGa, %%mm2, %%mm4, %%mm5, %%mm7, %%mm0, %%mm1, %%mm3, %%mm6)

                    YSCALEYUV2PACKEDX_END
                }
                return;
            case PIX_FMT_BGR24:
                YSCALEYUV2PACKEDX_ACCURATE
                YSCALEYUV2RGBX
                "pxor %%mm7, %%mm7 \n\t"
                "lea (%%"REG_a", %%"REG_a", 2), %%"REG_c"\n\t" //FIXME optimize
                "add %4, %%"REG_c" \n\t"
                WRITEBGR24(%%REGc, %5, %%REGa)


                :: "r" (&c->redDither),
                "m" (dummy), "m" (dummy), "m" (dummy),
                "r" (dest), "m" (dstW_reg)
                : "%"REG_a, "%"REG_c, "%"REG_d, "%"REG_S
                );
                return;
            case PIX_FMT_RGB555:
                YSCALEYUV2PACKEDX_ACCURATE
                YSCALEYUV2RGBX
                "pxor %%mm7, %%mm7 \n\t"
                /* mm2=B, %%mm4=G, %%mm5=R, %%mm7=0 */
#ifdef DITHER1XBPP
                "paddusb "BLUE_DITHER"(%0), %%mm2\n\t"
                "paddusb "GREEN_DITHER"(%0), %%mm4\n\t"
                "paddusb "RED_DITHER"(%0), %%mm5\n\t"
#endif

                WRITERGB15(%4, %5, %%REGa)
                YSCALEYUV2PACKEDX_END
                return;
            case PIX_FMT_RGB565:
                YSCALEYUV2PACKEDX_ACCURATE
                YSCALEYUV2RGBX
                "pxor %%mm7, %%mm7 \n\t"
                /* mm2=B, %%mm4=G, %%mm5=R, %%mm7=0 */
#ifdef DITHER1XBPP
                "paddusb "BLUE_DITHER"(%0), %%mm2\n\t"
                "paddusb "GREEN_DITHER"(%0), %%mm4\n\t"
                "paddusb "RED_DITHER"(%0), %%mm5\n\t"
#endif

                WRITERGB16(%4, %5, %%REGa)
                YSCALEYUV2PACKEDX_END
                return;
            case PIX_FMT_YUYV422:
                YSCALEYUV2PACKEDX_ACCURATE



0 yuv2packedX_MMX2 swscale_template.c 1100 0x00007fffe2a2c9c0
1 swScale_MMX2 swscale_template.c 2853 0x00007fffe2a38f58
2 sws_scale swscale.c 1952 0x00007fffe2a39889
3 av_convert_image filter_avcolour_space.c 102 0x00007fffe3e122d6
4 convert_image filter_avcolour_space.c 163 0x00007fffe3e122d6
5 mlt_frame_get_image mlt_frame.c 396 0x00007ffff78abd9f
6 filter_get_image filter_crop.c 75 0x00007fffddd0643b
7 mlt_frame_get_image mlt_frame.c 389 0x00007ffff78abd3a
8 filter_get_image filter_deinterlace.c 218 0x00007fffe7dd429e
9 mlt_frame_get_image mlt_frame.c 389 0x00007ffff78abd3a
10 filter_get_image filter_rescale.c 218 0x00007fffddd0b444
11 mlt_frame_get_image mlt_frame.c 389 0x00007ffff78abd3a
12 filter_get_image filter_resize.c 262 0x00007fffddd0b945
13 mlt_frame_get_image mlt_frame.c 389 0x00007ffff78abd3a
14 consumer_read_ahead_thread mlt_consumer.c 705 0x00007ffff78b8fb9
15 start_thread /lib/libpthread.so.0 0 0x00007ffff25398ba
16 clone /lib/libc.so.6 0 0x00007ffff281e01d
17 ?? 0 0x0000000000000000
(0005695)
Granjow (developer)
2010-08-28 10:20

To reproduce:
1. Open the attached project file
2. Select «Use placeholders for missing clips»
3. Drop the last title clip in the «Titel 1» folder to Video 0, right after the cursor (after 12:30:00)
4. Press Space

Perhaps also possible:
3. Press Space
(0005697)
j-b-m (administrator)
2010-08-28 12:35

cannot reproduce here... can you try to narrow the problem, for example check if the issue remains if you delete all clips but the crashing title in timeline...
(0005711)
Granjow (developer)
2010-08-30 20:23

Cannot reproduce anymore either with ffmpeg/MLT/kdenlive up-to-date.

- Issue History
Date Modified Username Field Change
2010-08-28 10:12 Granjow New Issue
2010-08-28 10:14 Granjow Note Added: 0005694
2010-08-28 10:17 Granjow Reproducibility N/A => always
2010-08-28 10:18 Granjow File Added: Haselbogen.kdenlive
2010-08-28 10:20 Granjow Note Added: 0005695
2010-08-28 12:35 j-b-m Note Added: 0005697
2010-08-28 12:35 j-b-m Assigned To => j-b-m
2010-08-28 12:35 j-b-m Status new => feedback
2010-08-30 20:23 Granjow Note Added: 0005711
2010-08-30 20:23 Granjow Status feedback => assigned
2010-08-30 20:23 Granjow Status assigned => resolved
2010-08-30 20:23 Granjow Fixed in Version => Recent git
2010-08-30 20:23 Granjow Resolution open => unable to reproduce
2010-09-14 11:00 j-b-m Fixed in Version Recent git => 0.7.8
2010-09-14 23:01 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker