Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001833KdenliveFile Loadingpublic2010-09-29 10:432011-06-10 10:48
ReporterDodgeV83 
Assigned Toj-b-m 
PriorityimmediateSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
Platform64 bit Ubuntu 10.10OSUbuntuOS Version10.10
Product VersionRecent git 
Target VersionFixed in Version0.8 
Summary0001833: After yesterday's update (SVN), no longer able to play any type of audio stream in the timeline: "src ratio outside *** range"
DescriptionAfter yesterday's update (SVN), no longer able to play any type of audio stream in the timeline: "src ratio outside *** range"

1. Don't have several versions of MLT

2. Plays in ffplay

3. Plays in melt

4. Sample test_file.kdenlive file plays

Any file without audio plays without crashing. Any file with audio (even just an mp3 or a wav) crashes immediately upon trying to play it in the timeline:

Using the following ppa: ppa:sunab/kdenlive-svn
Steps To ReproduceAdd any clip with audio into the timeline.

Press Play.
TagsNo tags attached.
Build/Install Method3rd party package
Attached Filespng file icon Screenshot-1.png [^] (178,407 bytes) 2010-09-29 10:43

- Relationships

-  Notes
(0005930)
DodgeV83 (reporter)
2010-09-29 10:44

I have also tried this with different profiles, same result.
(0005931)
sunab (developer)
2010-09-29 14:33

Same here, when you press play with an audio file kdenlive crashes.

Backtrace :

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb2143b70 (LWP 2129)]
0x0439b114 in avcodec_decode_audio3 () from /usr/lib/i686/cmov/libavcodec.so.52

But the audio file (ogg, wav, mp3) plays fine with melt or ffplay
(0005932)
j-b-m (administrator)
2010-09-29 16:26

This issue should be fixed by my recent patch for MLT that was committed last night be Dan. Please try updating to latest MLT & report back.
(0005934)
sunab (developer)
2010-09-29 18:21

Sorry I didn't see it. It works with the latest mlt.

Fixed. Thanks.

Note for DodgeV83 : at this moment the update is only available for Ubuntu Maverick as for now mlt don't build with ffmpeg < 0.6 (bug reported on mlt bugtracker)

- Issue History
Date Modified Username Field Change
2010-09-29 10:43 DodgeV83 New Issue
2010-09-29 10:43 DodgeV83 File Added: Screenshot-1.png
2010-09-29 10:44 DodgeV83 Note Added: 0005930
2010-09-29 14:33 sunab Note Added: 0005931
2010-09-29 16:26 j-b-m Note Added: 0005932
2010-09-29 16:26 j-b-m Assigned To => j-b-m
2010-09-29 16:26 j-b-m Status new => feedback
2010-09-29 18:21 sunab Note Added: 0005934
2010-09-29 18:34 j-b-m Status feedback => resolved
2010-09-29 18:34 j-b-m Fixed in Version => Recent git
2010-09-29 18:34 j-b-m Resolution open => fixed
2011-04-26 21:58 j-b-m Fixed in Version Recent git => 0.8
2011-06-10 10:48 Granjow Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker