Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000187KdenliveUser Interfacepublic2008-10-09 09:522008-12-29 16:26
Reportergrosa 
Assigned Tomadsdyd 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionunable to reproduce 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version 
Summary0000187: kdenlive crashes when loading a project
DescriptionWhen loading an existing .kdenlive file, kdenlive segfaults at:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb57cc700 (LWP 17827)]
0x080fcab8 in KdenliveDoc::checkProjectClips (this=0x88c9b58) at /home/grosa/Builds/kdenlive/src/kdenlivedoc.cpp:641
641 if (clip->clipType() == TEXT && !QFile::exists(clip->fileURL().path())) {
(gdb) bt

examining "clip" in gdb, it turns out it's NULL. I was able to fix this problem by adding a check to line 641, like so:

        if (clip != NULL && clip->clipType() == TEXT && !QFile::exists(clip->fileURL().path())) {

however, not being familiar with the code, I'm not sure if this has serious repercussions somewhere else.

it did, however, fix the loading issue.
TagsNo tags attached.
Build/Install Method
Attached Files

- Relationships

-  Notes
(0000901)
madsdyd (administrator)
2008-11-08 19:59

Is this a kdenlive 0.5 or 0.7 file? Could you perhaps attach the kdenlive file?
(0001851)
madsdyd (administrator)
2008-12-21 11:49

As we lack feedback from reporter, I am resolving this to a "unable to reproduce"

- Issue History
Date Modified Username Field Change
2008-10-09 09:52 grosa New Issue
2008-11-08 19:59 madsdyd Note Added: 0000901
2008-11-08 19:59 madsdyd Status new => feedback
2008-12-21 11:49 madsdyd Note Added: 0001851
2008-12-21 11:49 madsdyd Status feedback => resolved
2008-12-21 11:49 madsdyd Resolution open => unable to reproduce
2008-12-21 11:49 madsdyd Assigned To => madsdyd
2008-12-29 16:26 madsdyd Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker