Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001917KdenliveFile Loadingpublic2010-12-10 22:162010-12-10 22:24
Reportersederb 
Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
StatusnewResolutionopen 
PlatformIntel E8500 with 4gb ram. severaOSFedora 13 X_64OS Version9.0
Product Version0.7.7.1 
Target VersionFixed in Version 
Summary0001917: when attempting to load a .AVI DV file over 10gb the program crashes every time.
Descriptiontried with several clips and when over 10gb the same result. no problem with multiple sub 10gb files
Steps To Reproducesimply load a 10gb+ .avi file
Additional InformationBacktrace
Application: kdenlive (0.7.7.1)
KDE Platform Version: 4.5.3 (KDE 4.5.3)
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-63.fc13.x86_64 x86_64
Distribution: "Fedora release 13 (Goddard)"

-- Information about the crash:
<In detail, tell us what you were doing when the application crashed.>

The crash can be reproduced every time.

-- Backtrace:
Application: Kdenlive (kdenlive), signal: Segmentation fault
41 int result = INLINE_SYSCALL (wait4, 4, pid, stat_loc, options, NULL);
[Current thread is 1 (Thread 0x7f6caa441820 (LWP 25108))]

Thread 3 (Thread 0x7f6c97546710 (LWP 25115)):
#0 pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:212
#1 0x0000003130a15e4a in mlt_consumer_get_frame (this=0x1454ed0) at mlt_consumer.c:502
0000002 0x0000003130a15fad in mlt_consumer_rt_frame (this=0x1454ed0) at mlt_consumer.c:900
0000003 0x00007f6c9ca0682c in consumer_thread (arg=0x1454ed0) at consumer_sdl_still.c:563
0000004 0x0000003619207761 in start_thread (arg=0x7f6c97546710) at pthread_create.c:301
0000005 0x0000003618ae14fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f6c97f47710 (LWP 25116)):
#0 pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1 0x00007f6c9ca06165 in consumer_thread (arg=0x14447e0) at consumer_sdl_preview.c:428
0000002 0x0000003619207761 in start_thread (arg=0x7f6c97f47710) at pthread_create.c:301
0000003 0x0000003618ae14fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f6caa441820 (LWP 25108)):
[KCrash Handler]
0000004 avi_read_packet (s=0x19f6260, pkt=0x7fff5bf5e5d0) at /usr/src/debug/ffmpeg-0.6/libavformat/avidec.c:705
0000005 0x00007f6c9ac02779 in av_read_packet (s=0x19f6260, pkt=0x7fff5bf5e5d0) at /usr/src/debug/ffmpeg-0.6/libavformat/utils.c:668
0000006 0x00007f6c9ac03e97 in av_read_frame_internal (s=0x19f6260, pkt=0x7fff5bf5e730) at /usr/src/debug/ffmpeg-0.6/libavformat/utils.c:1100
0000007 0x00007f6c9ae41520 in producer_get_image (frame=<value optimized out>, buffer=0x7fff5bf5e8c8, format=0x7fff5bf5f9ec, width=0x7fff5bf5e8dc, height=0x7fff5bf5e8d8, writable=0)
    at producer_avformat.c:1069
0000008 0x0000003130a0932a in mlt_frame_get_image (this=<value optimized out>, buffer=0x7fff5bf5e8c8, format=0x7fff5bf5f9ec, width=0x7fff5bf5e8dc, height=0x7fff5bf5e8d8, writable=0) at mlt_frame.c:389
0000009 0x00007f6c9bd3b954 in deinterlace_yadif (frame=0x17fd820, filter=0x18c7640, image=0x7fff5bf5ec48, format=0x7fff5bf5f9ec, width=0x7fff5bf5ea6c, height=0x7fff5bf5ea68, mode=0)
    at filter_deinterlace.c:55
0000010 0x00007f6c9bd3bf95 in filter_get_image (this=0x17fd820, image=0x7fff5bf5ec48, format=0x7fff5bf5f9ec, width=0x7fff5bf5ea6c, height=0x7fff5bf5ea68, writable=0) at filter_deinterlace.c:172
0000011 0x0000003130a0932a in mlt_frame_get_image (this=<value optimized out>, buffer=0x7fff5bf5ec48, format=0x7fff5bf5f9ec, width=0x7fff5bf5ea6c, height=0x7fff5bf5ea68, writable=0) at mlt_frame.c:389
0000012 0x00007f6c9c352334 in filter_get_image (this=0x17fd820, image=0x7fff5bf5ec48, format=0x7fff5bf5f9ec, width=0x7fff5bf5eb9c, height=0x7fff5bf5eb98, writable=0) at filter_rescale.c:218
0000013 0x0000003130a0932a in mlt_frame_get_image (this=<value optimized out>, buffer=0x7fff5bf5ec48, format=0x7fff5bf5f9ec, width=0x7fff5bf5eb9c, height=0x7fff5bf5eb98, writable=0) at mlt_frame.c:389
0000014 0x00007f6c9c352841 in filter_get_image (this=0x17fd820, image=0x7fff5bf5ec48, format=0x7fff5bf5f9ec, width=0x7fff5bf5f9e8, height=0x7fff5bf5f9e4, writable=0) at filter_resize.c:267
0000015 0x0000003130a0932a in mlt_frame_get_image (this=<value optimized out>, buffer=0x7fff5bf5ec48, format=0x7fff5bf5f9ec, width=0x7fff5bf5f9e8, height=0x7fff5bf5f9e4, writable=0) at mlt_frame.c:389
0000016 0x0000003130e104ad in Mlt::Frame::get_image (this=0x193e810, format=@0x7fff5bf5f9ec, w=@0x7fff5bf5f9e8, h=@0x7fff5bf5f9e4, writable=0) at MltFrame.cpp:59
0000017 0x0000000000495caf in _start ()

Report to http://kdenlive.org/mantis [^]
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
(0006153)
sederb (reporter)
2010-12-10 22:24

Sorry to mislead. it seems a specific .avi file is causing the problem. trouble is I can play the file with totem and also open in with openshot without error. Also can open other files of greater size (my original sample of files wasn't big enough to see that only one file was the problem).
Still how can I get around this?

- Issue History
Date Modified Username Field Change
2010-12-10 22:16 sederb New Issue
2010-12-10 22:24 sederb Note Added: 0006153


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker