Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001939KdenliveUser Interfacepublic2010-12-23 16:232011-06-10 10:48
ReporterGranjow 
Assigned Tottill 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Versionfuture versionFixed in Version0.8 
Summary0001939: Frei0r effects: Show optional explanation of the parameter
DescriptionSome parameters are not intuitively clear. In this case it would be neat to have the possibility to show explanations (perhaps collapsible ones?) to still be able to describe the parameter accordingly and not steal too much room for the slider.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Filespng file icon kdenlive-effectstack-width.png [^] (13,705 bytes) 2010-12-23 16:23


png file icon kdenlive-effectstack.png [^] (69,301 bytes) 2010-12-25 15:34


png file icon power-red-comment.png [^] (28,155 bytes) 2010-12-25 21:02


png file icon kdenlive-effectstack-html.png [^] (9,702 bytes) 2010-12-27 12:49

- Relationships
parent of 0001968closedttill Show parameter comments for checkboxes as well 
related to 0001948closedttill Show additional explanation for frei0r effects without parameters 

-  Notes
(0006200)
ttill (developer)
2010-12-24 00:20
edited on: 2010-12-24 00:21

In r5193 I just added a first draft of this.
It is now possible to add a comment as shown here:
http://kdenlive.svn.sf.net/viewvc/kdenlive/trunk/kdenlive/effects/frei0r_hqdn3d.xml?r1=5193&r2=5192&pathrev=5193 [^]
The comment will be shown as a tooltip (for now only for the double parameter type).
I plan to do some further work on this in the next few days (maybe a little help icon next to the reset one?).

(0006202)
Granjow (developer)
2010-12-24 08:43

This is already very helpful!
Good question what would be best. I initially thought of (hideable) text boxes below the sliders since then you do not need to hover over the slider to see the explanation. Additionally one could format the text a little bit (newlines, bold, etc.) with HTML. Since this could require quite some space, the user should have the possibility to hide explanations as well (all on/all off for the sake of simplicity).
But there may be better solutions :)
(0006203)
ttill (developer)
2010-12-25 01:33
edited on: 2010-12-25 01:34

r5197:
There now is a button next to the reset one to show/hide the label at the bottom of the effect stack containing the comment. I think showing the comments of all parameters at once would make the effect stack appear very bloated.
HTML can be used with the help of CDATA:
<comment>
<![CDATA[< b>Important< /b>:< br />A comment!]]>
</comment>

Btw.: It is also possible to use HTML in tooltips (see the tooltips for the items in the effect list introduced in r5196)

(0006204)
Granjow (developer)
2010-12-25 15:34

Added some comments for SOP/Sat in r5198. HTML does not seem to work yet (I tried it for the Power Red slider). Or I did it the wrong way.

I agree that showing all of them would make the effect stack look bloated, on the other hand one could hide the text when not required and the UI would be a little simpler (just one button for all comments, instead of one for each parameter with a comment assigned).
(0006207)
ttill (developer)
2010-12-25 21:03
edited on: 2010-12-25 21:03

Hm, your HTML works for me (newline + different font for [0, 1]; see screenshot).

(0006243)
ttill (developer)
2010-12-26 13:17

r5203: All comments are shown/hidden at once.
Please have a look at it.
(0006246)
Granjow (developer)
2010-12-27 12:17

Thank you! Looks nice :)
Two details:
* Could you make the radio button remain at the top, right next to the revert icon? Perhaps even use the full width for the text box?
* And maybe add 5 px space at the bottom of the of the text box such that it is easier to see where it belongs to.

HTML still does not work here (screenshot), perhaps a Qt bug.
libqt4-dev:
  Installiert: 4:4.6.3-4
My brain supports live-translation from HTML to formatted text anyway, so nothing to worry about ;)
(0006252)
ttill (developer)
2010-12-27 20:47
edited on: 2010-12-27 20:48

r5207:
- radio button remaining at the top
- comment box closer to rest of parameter + 15 margin bottom

Maybe HTML works now for you, too?

Using the full width for the comment box is not possible (or not easy at least) because the comment box is part of the parameter widget whereas the radiobutton belongs to the keyframe table.
This way it is possible to introduce parameter widgets (thinking of the B├ęzier color curves widget I still have to write) with the comment located somewhere else or even more than one comment (+ different from the one given through the xml file) to explain GUI elements.

(0006256)
Granjow (developer)
2010-12-28 17:58

Cool! It's perfect now. Thank you very much!
(0006258)
ttill (developer)
2010-12-28 19:50

Including HTML?
(0006259)
Granjow (developer)
2010-12-28 20:16

Yes!

- Issue History
Date Modified Username Field Change
2010-12-23 16:23 Granjow New Issue
2010-12-23 16:23 Granjow File Added: kdenlive-effectstack-width.png
2010-12-24 00:20 ttill Note Added: 0006200
2010-12-24 00:21 ttill Note Edited: 0006200 View Revisions
2010-12-24 00:21 ttill Assigned To => ttill
2010-12-24 00:21 ttill Status new => assigned
2010-12-24 08:43 Granjow Note Added: 0006202
2010-12-25 01:33 ttill Note Added: 0006203
2010-12-25 01:33 ttill Note Edited: 0006203 View Revisions
2010-12-25 01:34 ttill Note Edited: 0006203 View Revisions
2010-12-25 15:34 Granjow Note Added: 0006204
2010-12-25 15:34 Granjow File Added: kdenlive-effectstack.png
2010-12-25 21:02 ttill File Added: power-red-comment.png
2010-12-25 21:03 ttill Note Added: 0006207
2010-12-25 21:03 ttill Note Edited: 0006207 View Revisions
2010-12-26 13:17 ttill Note Added: 0006243
2010-12-27 12:17 Granjow Note Added: 0006246
2010-12-27 12:49 Granjow File Added: kdenlive-effectstack-html.png
2010-12-27 20:47 ttill Note Added: 0006252
2010-12-27 20:48 ttill Note Edited: 0006252 View Revisions
2010-12-28 17:58 Granjow Note Added: 0006256
2010-12-28 17:58 Granjow Status assigned => resolved
2010-12-28 17:58 Granjow Fixed in Version => Recent git
2010-12-28 17:58 Granjow Resolution open => fixed
2010-12-28 18:02 Granjow Relationship added related to 0001948
2010-12-28 19:50 ttill Note Added: 0006258
2010-12-28 20:16 Granjow Note Added: 0006259
2011-01-06 09:20 Granjow Relationship added parent of 0001968
2011-04-26 21:58 j-b-m Fixed in Version Recent git => 0.8
2011-06-10 10:48 Granjow Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker