Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001958KdenliveBuild Systempublic2011-01-02 11:502011-06-10 10:48
Reportersunab 
Assigned Tottill 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platformall (amd64 and x86)OSUbuntu LinuxOS Version9.10
Product VersionRecent git 
Target VersionFixed in Version0.8 
Summary0001958: kdenlive trunk fails to build with Qt 4.5
DescriptionUsing soyuz building system (Ubuntu ppa) :

revision 5232 builds fine with Qt>4.5 (with Ubuntu 10.04 and 10.10).

But fails with previous versions :


/build/buildd/kdenlive-0.7.8+svn20110101.r5232/src/dvdwizard.cpp: In member function 'void DvdWizard::generateDvd()':
/build/buildd/kdenlive-0.7.8+svn20110101.r5232/src/dvdwizard.cpp:489: error: 'QProcessEnvironment' was not declared in this scope
/build/buildd/kdenlive-0.7.8+svn20110101.r5232/src/dvdwizard.cpp:489: error: expected ';' before 'env'
/build/buildd/kdenlive-0.7.8+svn20110101.r5232/src/dvdwizard.cpp:490: error: 'env' was not declared in this scope
/build/buildd/kdenlive-0.7.8+svn20110101.r5232/src/dvdwizard.cpp:491: error: 'class QProcess' has no member named 'setProcessEnvironment'
make[3]: *** [src/cmake_bindir/CMakeFiles/kdenlive.dir/dvdwizard.o] Error 1
TagsNo tags attached.
Build/Install Method(select)
Attached Files

- Relationships

-  Notes
(0006268)
ttill (developer)
2011-01-03 14:51

Should be fixed in r5246.
(0006269)
sunab (reporter)
2011-01-03 18:30

not fixed in r5247, the error has changed :

/build/buildd/kdenlive-0.7.8+svn20110103.r5247/src/dvdwizard.cpp: In member function 'void DvdWizard::generateDvd()':
/build/buildd/kdenlive-0.7.8+svn20110103.r5247/src/dvdwizard.cpp:495: error: invalid operands of types 'const char [14]' and 'const char*' to binary 'operator+'
make[3]: *** [src/cmake_bindir/CMakeFiles/kdenlive.dir/dvdwizard.o] Error 1
(0006270)
ttill (developer)
2011-01-03 18:46

Should be fixed in r5248.
However I suspect that there are some more problems in the new Bézier Spline widget.
(0006275)
sunab (reporter)
2011-01-03 19:29
edited on: 2011-01-03 20:02

you are right it fails now on another wigdet :

/build/buildd/kdenlive-0.7.8+svn20110103.r5248/src/onmonitoritems/onmonitorrectitem.cpp: In member function 'virtual void OnMonitorRectItem::slotMouseMoved(QGraphicsSceneMouseEvent*)':
/build/buildd/kdenlive-0.7.8+svn20110103.r5248/src/onmonitoritems/onmonitorrectitem.cpp:201: error: 'setY' was not declared in this scope
/build/buildd/kdenlive-0.7.8+svn20110103.r5248/src/onmonitoritems/onmonitorrectitem.cpp:204: error: 'setX' was not declared in this scope
make[3]: *** [src/cmake_bindir/CMakeFiles/kdenlive.dir/onmonitoritems/onmonitorrectitem.o] Error 1

ps : sorry, it's been a while since I have tried to build kdenlive against Qt 4.5, last time was on the 11 of december.

(0006276)
ttill (developer)
2011-01-03 20:08

Should be fixed in r5251.
Another issue (the one i mentioned in my previous comment) should be fixed in r5253.
(0006280)
sunab (reporter)
2011-01-03 23:49
edited on: 2011-01-03 23:49

some Bézier Spline widget problem remains ( r5258):

/build/buildd/kdenlive-0.7.8+svn20110103.r5258/src/beziercurve/beziersplineeditor.cpp: In member function 'virtual void BezierSplineEditor::paintEvent(QPaintEvent*)':
/build/buildd/kdenlive-0.7.8+svn20110103.r5258/src/beziercurve/beziersplineeditor.cpp:225: error: 'class QPolygon' has no member named 'translated'
/build/buildd/kdenlive-0.7.8+svn20110103.r5258/src/beziercurve/beziersplineeditor.cpp:227: error: 'class QPolygon' has no member named 'translated'
make[3]: *** [src/cmake_bindir/CMakeFiles/kdenlive.dir/beziercurve/beziersplineeditor.o] Error 1

(0006281)
ttill (developer)
2011-01-04 07:48

Next try: r5260.
(0006283)
sunab (reporter)
2011-01-04 08:59

now it stops on line 241 :

build/buildd/kdenlive-0.7.8+svn20110104.r5260/src/beziercurve/beziersplineeditor.cpp: In member function 'virtual void BezierSplineEditor::paintEvent(QPaintEvent*)':
/build/buildd/kdenlive-0.7.8+svn20110104.r5260/src/beziercurve/beziersplineeditor.cpp:241: error: 'class QPolygon' has no member named 'translated'
make[3]: *** [src/cmake_bindir/CMakeFiles/kdenlive.dir/beziercurve/beziersplineeditor.o] Error 1
(0006289)
ttill (developer)
2011-01-04 21:13

Sorry for all the mess.
I hope it is now finally fixed in r5264.
(0006293)
sunab (reporter)
2011-01-05 14:33

It is now fixed, thanks.

- Issue History
Date Modified Username Field Change
2011-01-02 11:50 sunab New Issue
2011-01-03 14:51 ttill Note Added: 0006268
2011-01-03 14:51 ttill Assigned To => ttill
2011-01-03 14:51 ttill Status new => feedback
2011-01-03 18:30 sunab Note Added: 0006269
2011-01-03 18:30 sunab Status feedback => assigned
2011-01-03 18:46 ttill Note Added: 0006270
2011-01-03 19:29 sunab Note Added: 0006275
2011-01-03 20:02 sunab Note Edited: 0006275 View Revisions
2011-01-03 20:08 ttill Note Added: 0006276
2011-01-03 23:49 sunab Note Added: 0006280
2011-01-03 23:49 sunab Note Edited: 0006280 View Revisions
2011-01-04 07:48 ttill Note Added: 0006281
2011-01-04 08:59 sunab Note Added: 0006283
2011-01-04 21:13 ttill Note Added: 0006289
2011-01-05 14:33 sunab Note Added: 0006293
2011-01-05 14:48 ttill Status assigned => resolved
2011-01-05 14:48 ttill Resolution open => fixed
2011-01-05 14:48 ttill Fixed in Version => Recent git
2011-04-26 21:58 j-b-m Fixed in Version Recent git => 0.8
2011-06-10 10:48 Granjow Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker